Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Июл 2017, 09:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение полей документа данными другого документа/справочника  (Прочитано 970 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Георгий Ширинкин

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-19
  • Сайт: 
Доброго дня!
Помогите пожалуйста новичку.
Есть справочник "Контрагенты". Есть документ "Договор". В них обоих есть идентичные поля "ЮрАдрес", "ИНН", "КПП" и прочее. Эти поля изначально заполняются в справочнике.
Задача: Надо что-бы при выборе в документе "Договор" контрагента (СправочникСсылка.Контрагенты), заполнение сопутствующих полей договора элементами справочника происходило автоматически.
Благодарю!


Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Пишите код в событие ПриИзминении Договора
типа Док.Инн = Договор.инн и т.д
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Георгий Ширинкин

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-19
  • Сайт: 
Пишите код в событие ПриИзминении Договора
типа Док.Инн = Договор.инн и т.д
Про обработчик события это понятно. А вот как описать сам механизм выборки нужных полей из выбранного контрагента (Справочник.Контрагенты) мне не ясно. Гугл меня тоже сегодня не балует =(

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн xdto

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-10-01
  • Сайт: 
  • Профессия: Программист 1С
Процедура КонтрагентПриИзменении(Элемент)
ДанныеРеквизитаКонтрагент = Контрагент.Ссылка;

ВыбранныйКонтрагент = ДанныеРеквизитаКонтрагент.Ссылка;
ПолучитьРеквизитыКонтрагента(ВыбранныйКонтрагент);

 КонецПроцедуры

Функция ПолучитьРеквизитыКонтрагента(КонтрагентСсылка) 
РеквизитыКонтрагента = Новый Структура;
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | Контрагенты.ЮрАдрес,
               | Контрагенты.ИНН,
               | Контрагенты.КПП
               |ИЗ
               | Справочник.Контрагенты КАК Контрагенты
   |ГДЕ
   | Контрагенты.Ссылка = &Ссылка";
                       
Запрос.УстановитьПараметр("Ссылка", КонтрагентСсылка);
Выборка = Запрос.Выполнить().Выбрать();
 
Если  Выборка.Следующий() Тогда
ЮрАдрес = Выборка.ЮрАдрес;
ИНН = Выборка.ИНН;
КПП = Выборка.КПП;
КонецЕсли;
РеквизитыКонтрагента.Вставить("ЮрАдрес", ЮрАдрес);
РеквизитыКонтрагента.Вставить("ИНН", ИНН);
РеквизитыКонтрагента.Вставить("КПП", КПП);
Возврат РеквизитыКонтрагента;


КонецФункции

Оффлайн Георгий Ширинкин

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-19
  • Сайт: 
Благодарю всех откликнувшихся.
Перебрал разные варианты, остановился на этом:
&НаКлиенте
Процедура КонтрагентПриИзменении(Элемент)

// вариант 1
РеквизитыКонтрагента = ПолучитьРеквизитыКонтрагента(Объект.Контрагент);

Объект.ИНН = РеквизитыКонтрагента.ИНН;
Объект.КПП = РеквизитыКонтрагента.ИНН;
Объект.ЮрАдрес = РеквизитыКонтрагента.ЮрАдрес;

// вариант 2
//ПриИзмененииКонтрагентаНаСервере();

КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьРеквизитыКонтрагента(КонтрагентСсылка)
    РеквизитыКонтрагента = Новый Структура;

    РеквизитыКонтрагента.Вставить("ЮрАдрес" , КонтрагентСсылка.ЮрАдрес);
    РеквизитыКонтрагента.Вставить("ИНН" , КонтрагентСсылка.ИНН);
    РеквизитыКонтрагента.Вставить("КПП" , КонтрагентСсылка.КПП);

Возврат РеквизитыКонтрагента;   

КонецФункции

&НаСервере
Процедура ПриИзмененииКонтрагентаНаСервере()

Объект.ИНН = Объект.Контрагент.ИНН;
Объект.КПП = Объект.Контрагент.ИНН;
Объект.ЮрАдрес = Объект.Контрагент.ЮрАдрес;

КонецПроцедуры

Еще раз всем спасибо! =)


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6051
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1671
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3555
Последний ответ 15 Дек 2011, 00:04
от Vit1501
Чистка справочника "Налоги и взносы"

Автор dim3740Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 191
Последний ответ 17 Май 2017, 17:55
от Геннадий ОбьГЭС
Удалить запись из справочника "Сотрудники" уволенного

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3399
Последний ответ 02 Фев 2014, 21:37
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
116 Сообщений
alex0402
102 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
AIFrame
50 Сообщений
ilyay ilyay
49 Сообщений
Golickoff Golickoff
49 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 222
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal