Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Мар 2017, 17:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: заполнение субконто в проводке счет 70  (Прочитано 568 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн pevgeni

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-18
  • Сайт: 
  • Профессия: Программист 8.1
Добрый день всем ! Помогите начинающему программисту 1С. Создаю обработку по формировании операции с проводками. Все создается, не могу заполнить Субконто - сотрудника по счету 70. Весь интернет облазил.
Нужен пример рабочий создания Операции и привязка простых проводок.


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6214
  • РЕПУТАЦИЯ: 728
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Проводка.СубконтоКт.Сотрудники = Сотрудник;

Оффлайн pevgeni

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-18
  • Сайт: 
  • Профессия: Программист 8.1
Проводка.СубконтоКт.Сотрудники = Сотрудник;

Пишет Поле объекта не обнаружено.
Субконто у 70 сч оказывается физлицо.
пробовал подставить физлицо - то же самое.

Вот текст. Если СубконтоКт[0] подставлять - то все проходит но остается незаполненным субконто.
НоваяПроводка.СубконтоКт[0]=НайденныйСотр;


НоваяПроводка = ДокОперация.Движения.Хозрасчетный.Добавить();
   
   
   Если СтрДлина(Планысчетов.Хозрасчетный.НайтиПоКоду(СокрЛП(База.DB)))>0 Тогда
       СчетДт1=Планысчетов.Хозрасчетный.НайтиПоКоду(СокрЛП(База.DB));
         НоваяПроводка.СчетДт=СчетДт1 ;
      Сообщить("Счет Дб="+СчетДт1.Наименование+", "+счетДт1.Код);
   Иначе Сообщить("Не найден в Плане счетов Дб="+СокрЛП(База.DB));
    tok=0;
    КонецЕсли;                           
   
   Если СтрДлина(Планысчетов.Хозрасчетный.НайтиПоКоду(СокрЛП(База.KR)))>0 Тогда
     СчетКт1=Планысчетов.Хозрасчетный.НайтиПоКоду(СокрЛП(База.KR));   
     НоваяПроводка.СчетКТ=СчетКт1 ;
      Сообщить("Счет Кт="+СчетКт1.Наименование+", "+счетКт1.Код);


     Если СтрДлина(СокрЛП(База.KRNAME))>0 Тогда
      СпрСотр=Справочники.ФизическиеЛица; 
      //СпрСотр = Справочники.Сотрудники;
        НайденныйСотр = СпрСотр.НайтиПоНаименованию(СокрЛП(База.KRNAME)); //по наименованию
        Если НайденныйСотр = Неопределено Тогда
       Сообщить("Не найден "+База.KRNAME);
    Иначе
         
       //  НоваяПроводка.СубконтоКт.Сотрудники = НайденныйСотр;
       НоваяПроводка.СубконтоКт[0]=НайденныйСотр; 
      
      
        Сообщить(НайденныйСотр.ФИО);
       КонецЕсли;
        
      КонецЕсли;
   
    Иначе Сообщить("Не найден в Плане счетов Кт="+СокрЛП(База.KR));
    tok=0;
    КонецЕсли;
   
   
   НоваяПроводка.Период=ТекущаяДата();
    НоваяПроводка.Сумма = База.Summa;
   НоваяПроводка.Содержание=База.NAME;
   НоваяПроводка.Активность=истина;




Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 6069
Последний ответ 16 Авг 2012, 21:50
от Will
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2160
Последний ответ 30 Ноя 2011, 07:10
от has
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 13693
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3335
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3086
Последний ответ 10 Июн 2013, 22:34
от Sasa1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
alex0402
115 Сообщений
Norfolk
51 Сообщений
LexaK
45 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
друган
21 Сообщений
alexandr_ll
20 Сообщений
AsadRoman
20 Сообщений
Константин5825
18 Сообщений
Alex55
18 Сообщений

* Кто онлайн

  • Точка Гостей: 286
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal