Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2017, 20:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема со считыванием данных из регистра сведений  (Прочитано 328 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дианочка Баутина

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-17
  • Сайт: 
Здравствуйте! Помогите решить проблему, пожалуйста.

Имеется регистр сведений Акционные товары:

   Измерение: Номенклатура (Тип Справочник.Ссылка.Номенклатура)

   Ресурс: Процент (Тип Число)

Регистр подчинен регистратору (Документ УстановкаСкидокНаНоменлатуру)

Теперь нужно, чтобы в табличной части документа Расходная накладная, при выборе номенклатуры заполнялось поле скидка значением процент из регистра.

Написала такой код:

&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
   СтрокаТабличнойЧасти=Элементы.Товары.ТекущиеДанные;
   СтрокаТабличнойЧасти.Скидка=ПолучитьСкидку(Объект.Дата, СтрокаТабличнойЧасти.Номенклатура);   
КонецПроцедуры

&НаСервере
Функция ПолучитьСкидку(АктуальнаяДата, Номенклатура)
   Отбор=Новый Структура;
   Отбор.Вставить("Номенклатура", Номенклатура);
    Скидка=РегистрыСведений.АкционныеТовары.ПолучитьПоследнее(АктДата, Отбор);
   Возврат Скидка.Процент;   
КонецФункции

 

Но возвращает 0, несмотря на то, что в регистре имеется запись с данным элементом номенклатуры.

Что я не так делаю, помогите пожалуйста.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн Golickoff

  • ***
  • Сообщений: 186
  • РЕПУТАЦИЯ: 10
  • КПД: 5%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
&НаСервере
Функция ПолучитьСкидку(АктуальнаяДата, Номенклатура)
   Отбор=Новый Структура;
   Отбор.Вставить("Номенклатура", Номенклатура);
   Скидка=РегистрыСведений.АкционныеТовары.ПолучитьПоследнее(АктДата, Отбор);
   Возврат Скидка.Процент;   
КонецФункции

Непонятно, что за АктДата.


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5083
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2140
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 59
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 2791
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3798
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
63 Сообщений
MuI_I_Ika MuI_I_Ika
46 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
32 Сообщений
sertak sertak
27 Сообщений
Vzonder
22 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 251
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal