Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Окт 2017, 01:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема со считыванием данных из регистра сведений  (Прочитано 570 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дианочка Баутина

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-17
  • Сайт: 
Здравствуйте! Помогите решить проблему, пожалуйста.

Имеется регистр сведений Акционные товары:

   Измерение: Номенклатура (Тип Справочник.Ссылка.Номенклатура)

   Ресурс: Процент (Тип Число)

Регистр подчинен регистратору (Документ УстановкаСкидокНаНоменлатуру)

Теперь нужно, чтобы в табличной части документа Расходная накладная, при выборе номенклатуры заполнялось поле скидка значением процент из регистра.

Написала такой код:

&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
   СтрокаТабличнойЧасти=Элементы.Товары.ТекущиеДанные;
   СтрокаТабличнойЧасти.Скидка=ПолучитьСкидку(Объект.Дата, СтрокаТабличнойЧасти.Номенклатура);   
КонецПроцедуры

&НаСервере
Функция ПолучитьСкидку(АктуальнаяДата, Номенклатура)
   Отбор=Новый Структура;
   Отбор.Вставить("Номенклатура", Номенклатура);
    Скидка=РегистрыСведений.АкционныеТовары.ПолучитьПоследнее(АктДата, Отбор);
   Возврат Скидка.Процент;   
КонецФункции

 

Но возвращает 0, несмотря на то, что в регистре имеется запись с данным элементом номенклатуры.

Что я не так делаю, помогите пожалуйста.


Оффлайн Golickoff

  • ****
  • Сообщений: 321
  • РЕПУТАЦИЯ: 27
  • КПД: 8%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
&НаСервере
Функция ПолучитьСкидку(АктуальнаяДата, Номенклатура)
   Отбор=Новый Структура;
   Отбор.Вставить("Номенклатура", Номенклатура);
   Скидка=РегистрыСведений.АкционныеТовары.ПолучитьПоследнее(АктДата, Отбор);
   Возврат Скидка.Процент;   
КонецФункции

Непонятно, что за АктДата.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7228
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3800
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1992
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 6984
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6729
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
89 Сообщений
alex0402
43 Сообщений
AIFrame
42 Сообщений
Oldman06
31 Сообщений
vitasw
29 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
29 Сообщений
Golickoff Golickoff
27 Сообщений
Liv98 Liv98
20 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
DmitriyF DmitriyF
14 Сообщений

* Кто онлайн

  • Точка Гостей: 227
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal