Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2017, 09:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как программно заменить префикс документа?  (Прочитано 902 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gennadiyy

  • **
  • Сообщений: 80
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2015-12-08
  • Сайт: 
Здравствуйте! Необходимо следующее: При создании нового документа "счет на оплату" при определенных условиях ставить другой префикс, к примеру сейчас документы имеют префикс НФФР, а при установленной галки должен генерироваться с префиксом "ТО", в модуле объекта документа счет на оплату делаю так:

Если ЭтоНовый() Тогда
Если ЭтотОбъект.ТО Тогда
ЭтотОбъект.УстановитьНовыйНомер("ТО-");
КонецЕсли;
КонецЕсли;
Проблема в следующем: он подставляет к уже имеющемуся префикс "то-" и получается НФФР-ТО-001, и из за этого у нумерации документа улетучиваются 3 разряда.


Оффлайн LexaK

  • *****
  • Сообщений: 1214
  • РЕПУТАЦИЯ: 333
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте прямую замену префикса
после стандартного получения номера, просто выполните замену, (правда придется подумать над контролем)
...
Если ЭтотОбъект.ТО Тогда
     ЭтотОбъект.Номер = СтрЗаменить(ЭтотОбъект.Номер,"НФФР","ТО-");
КонецЕсли;
...

по идее не должно быть такой ситуации с задвоением префикса, где-то косяк в коде,

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
У объекта есть такое событие "ПриУстановкеНовогоНомера", используйте его в модуле объекта. Передается второй параметр "Префикс"
Т.е. будет что-то типа этого
Процедура ПриУстановкеНовогоНомера(СтандартнаяОбработка, Префикс)
    Если Тогда
        Префикс = "xxx";
    КонецЕсли;
КонецПроцедуры

Оффлайн Gennadiyy

  • **
  • Сообщений: 80
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2015-12-08
  • Сайт: 
У объекта есть такое событие "ПриУстановкеНовогоНомера", используйте его в модуле объекта. Передается второй параметр "Префикс"
Т.е. будет что-то типа этого
Процедура ПриУстановкеНовогоНомера(СтандартнаяОбработка, Префикс)
    Если Тогда
        Префикс = "xxx";
    КонецЕсли;
КонецПроцедуры
Спасибо) Так тоже пробовал, эффект тот же, и по какой то причине (возможно потому, что префикс берется из кэша) - он в последующих документах во всех заменяет префикс, без разницы выполнилось ли условие или нет, поэтому на рабочей базе решил не рисковать с этим)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4038
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14193
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3538
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 145
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7002
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
83 Сообщений
wise wise
63 Сообщений
Dethmontt Dethmontt
60 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
49 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilyay ilyay
32 Сообщений
ilnur75
23 Сообщений
Дмитрий Медведков
19 Сообщений
magnifico61
18 Сообщений

* Кто онлайн

  • Точка Гостей: 280
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal