Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Июл 2017, 19:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подскажите что не так- пытаюсь сохранить html документ на диск С  (Прочитано 488 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexs-safin

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите что не так- пытаюсь сохранить html документ на диск С:\\ а он сохраняет в этот документ не тело документа, а название адреса "https://yandex.ru/"

&НаКлиенте
Процедура заполнитьHTML(ЭлементТекстРедактирования)
    ПолеHTML = ЭлементТекстРедактирования;
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   Объект.АдресHTML = "https://yandex.ru/";
    ЗаполнитьHTML(Объект.АдресHTML);
КонецПроцедуры

&НаКлиенте
Процедура ПолеHTMLДокументСформирован(Элемент)
   ДокументСформирован = Истина;
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   ДокументСформирован = Ложь;
КонецПроцедуры

&НаКлиенте
Процедура ПолеHTMLПриИзменении(Элемент)
   ДокументСформирован = Ложь;
КонецПроцедуры

&НаСервере
Процедура кнСохранитьИОбрабоатьНаСервере()
   ТекстДок = Новый ТекстовыйДокумент;
   ТекстДок.ДобавитьСтроку(ПолеHTML);
   ТекстДок.Записать("c:\tmp\1.html");
КонецПроцедуры

&НаКлиенте
Процедура кнСохранитьИОбработать(Команда)
   кнСохранитьИОбрабоатьНаСервере();
КонецПроцедуры


Оффлайн alexs-safin

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Сделал, вот если что:
&НаКлиенте
Процедура кнСохранитьИОбработать(Команда)
   //кнСохранитьИОбрабоатьНаСервере();
   ТекстовыйДокумент = Новый ТекстовыйДокумент;
   ТекстовыйДокумент.УстановитьТекст(Элементы.ПолеHTML.Документ.body.outerHTML);
   ТекстовыйДокумент.НачатьЗапись(,"c:\tmp\1.html",);   
КонецПроцедуры


Теги: html 
 

Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4221
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8222
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3019
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 17338
Последний ответ 10 Ноя 2010, 14:08
от Lexius
Документ "Сторно" в 1с 8.2 бух 2.0

Автор cannabis_86Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 11938
Последний ответ 09 Июн 2011, 12:57
от defers

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
140 Сообщений
alex0402
112 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
ilyay ilyay
51 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
43 Сообщений
wise wise
40 Сообщений
ab30ru
38 Сообщений
Амал
35 Сообщений
Dethmontt Dethmontt
25 Сообщений

* Кто онлайн

  • Точка Гостей: 322
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal