Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 03:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение стандартной функции клавиши "Del" в документе  (Прочитано 2662 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн APMEH19

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте,
Помогомогите решить проблему.
При заполнении табличной части документа, нажатие клавиши "Del" приводит к удалению всей строки. Я хотел бы, чтобы при нажатии этой клавиши удалялось содержимое выделенной ячейки табличной части. Возможно ли провести перенастройку этой клавиши?
Никакая задача не покажеться невыполнимой, если разбить ее на маленькие части


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Конечно можно.
В процедуре "ПередУдалением" пишем что-то вроде:
Процедура ТабЧастьПередУдалением(Элемент, Отказ)
        ТекущаяСтрока=ЭлементыФормы.Табчасть.ТекущаяСтрока;
Если ТекущаяСтрока<>неопределено тогда
Отказ=Истина;
Попытка // на случай, если нельзя очищать поле. Например, поле "НомерСтроки"
ТекущаяСтрока[ЭлементыФормы.ТабЧасть.ТекущаяКолонка.Имя]=ПустоеЗначениеНужногоТипа;
исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецПроцедуры

ПустоеЗначениеНужногоТипа=Справочники.ИмяСправочника.ПустаяСсылка();
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн APMEH19

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 1С
Спасибо за ответ, но это не то.
Описанный Вами способ подразумевает замену операции удаления на другую операцию. При этом не важно, каким способом проделана операция удаления. Я же хочу только перепрограммировать клавишу "Del" на клавиатуре при работе в форме конкретного документа. То есть нажатие кнопки "Del" на клавиатуре должна привести к удалению значения в ячейке, нажатие кнопки "Удалить" на командной панели табличной части - к удалению всей строки.
Никакая задача не покажеться невыполнимой, если разбить ее на маленькие части

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Ну тогда так:
1. Переопределяем процедуру по кнопке "Удалить" в
Процедура КоманднаяПанель3Действие(Кнопка)
ТекущаяСтрока=ЭлементыФормы.ТабЧасть.ТекущаяСтрока;
Если ТекущаяСтрока<>Неопределено тогда
ДанныеРассылки.Удалить(ТекущаяСтрока);
КонецЕсли;
КонецПроцедуры
2. И оставляем процедуру ТабЧастьПередУдалением (из моего прошлого поста)
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 305
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
Изменение оформления строки по индексу строки

Автор BladrannerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 163
Последний ответ 13 Ноя 2017, 15:19
от alex0402
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3043
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
Если декларант не может предоставить дополнительные документы, это не влечет изменение таможенной стоимости

Автор newsРаздел Новости

Ответов: 0
Просмотров: 809
Последний ответ 05 Ноя 2014, 12:06
от news
Изменение цвета строки сотрудника при подборе в табеле учета рабочего времени 1С ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 719
Последний ответ 28 Ноя 2016, 10:30
от ksander-fars

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 163
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal