Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2018, 15:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отгрузка по факту  (Прочитано 349 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Marat61191

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-24
  • Сайт: 
  • Профессия: Ученик 1С
Помогите: надо сделать так чтобы при нажатии на отгрузке по факту(если заказ покупателя не проведен) писалось "Заказ покупателя не проведен!" и невозможно было отгрузить товар.
К примеру сейчас если не указан факт. вес нельзя отгружать товар, вот код к нему:
Процедура ОтгрузкаПоФактуПриИзменении(Элемент)
   Если Элемент.Значение = Истина тогда
      Для Каждого Строка Из Товары Цикл
         Если не ЗначениеЗаполнено(Строка.лс_ВесПоФакту) тогда
            Сообщить("Заполните фактический вес!");
            Элемент.Значение = Ложь;
            возврат;
         КонецЕсли;
      КонецЦикла;
      ЭлементыФормы.Товары.Колонки.Количество.Видимость = Ложь;
   иначе
      ЭлементыФормы.Товары.Колонки.Количество.Видимость = Истина;
   КонецЕсли;
   УстановитьВидимостьКолонокФакт();
   ПересчитатьЦеныТовары();
КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
108 Сообщений
AIFrame
100 Сообщений
alex0402
32 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
18 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
Artibon
15 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 1035
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal