Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Июл 2017, 21:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: средную цену поставил из регистр накопление....?  (Прочитано 1259 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bek007

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-12
  • Сайт: 
  • Профессия: Ученик 1С
средную цену поставил из регистр накопление теперь когда изменяю цену на одну дату не изменяются на следующих дат помогите пожалюста.

&НаСервере
Функция ОстатокНаСкладе(Дата,Дата1,Материал,ЕднИзм)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|КОЛИЧЕСТВО(РАЗЛИЧНЫЕ ЦенаОстаткиИОбороты.Прораб) КАК Прораб,
|ЦенаОстаткиИОбороты.Материал,
|ЦенаОстаткиИОбороты.ЕднИзм,
|СУММА(ЦенаОстаткиИОбороты.КолвоНачальныйОстаток) КАК КолвоНачальныйОстаток,
|СУММА(ЦенаОстаткиИОбороты.КолвоКонечныйОстаток) КАК КолвоКонечныйОстаток,
|СУММА(ЦенаОстаткиИОбороты.КолвоПриход) КАК КолвоПриход,
|СУММА(ЦенаОстаткиИОбороты.КолвоРасход) КАК КолвоРасход,
|СУММА(ЦенаОстаткиИОбороты.СуммаНачальныйОстаток) КАК СуммаНачальныйОстаток,
|СУММА(ЦенаОстаткиИОбороты.СуммаКонечныйОстаток) КАК СуммаКонечныйОстаток,
|СУММА(ЦенаОстаткиИОбороты.СуммаПриход) КАК СуммаПриход,
|СУММА(ЦенаОстаткиИОбороты.СуммаРасход) КАК СуммаРасход
|ИЗ
|РегистрНакопления.Цена.ОстаткиИОбороты(&Дата,&Дата1,День,ДвиженияИГраницыПериода,&Материал = Материал И &ЕднИзм = ЕднИзм) КАК ЦенаОстаткиИОбороты

|СГРУППИРОВАТЬ ПО
|ЦенаОстаткиИОбороты.Материал,
|ЦенаОстаткиИОбороты.ЕднИзм";

Запрос.УстановитьПараметр("Дата",Дата);
Запрос.УстановитьПараметр("Дата1",Дата1);
Запрос.УстановитьПараметр("Материал", Материал);
Запрос.УстановитьПараметр("ЕднИзм", ЕднИзм);
ВыборкаДетальныеЗаписи = Запрос.Выполнить().Выбрать();
Если ВыборкаДетальныеЗаписи.Следующий() Тогда
Возврат ВыборкаДетальныеЗаписи.СуммаНачальныйОстаток / ВыборкаДетальныеЗаписи.КолвоНачальныйОстаток;


Иначе
Возврат 0;
КонецЕсли;
КонецФункции

&НаКлиенте
Процедура ТоварыМатериалПриИзменении(Элемент)
Стр1= Объект.Дата;
Стр2 = Элементы.От.ТекстРедактирования;
Стр = Элементы.Товары.ТекущиеДанные;
стр.ЕднИзм = ПолучитьЕднИзм(стр.Материал);
Если ОстатокНаСкладе(Стр1,Стр1,Стр.Материал,Стр.ЕднИзм)<>0 и стр2 <> "Поставшик" тогда
стр.Цена = ОстатокНаСкладе(Стр1,Стр1,Стр.Материал,Стр.ЕднИзм);
РасчитатьСумму();
Иначе стр.Цена = стр.Цена;
КонецЕсли;

КонецПроцедуры

незнаю так правильно или нет но работает!


Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
изменяю цену на одну дату не изменяются на следующих дат
?


Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн bek007

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-12
  • Сайт: 
  • Профессия: Ученик 1С
изменяю цену на одну дату не изменяются на следующих дат
?
например из поставшика пришел что небуд цена вводится ручную  и средная цена изменяется но не изменяется на следуюшие дни тоесть надо вручную открыт все партии и провести

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Поставщик, который извергает товары :D , есть метод пересчет итогов в регистрах накопления
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн bek007

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Поставщик, который извергает товары :D , есть метод пересчет итогов в регистрах накопления
я новичок в этом деле надо сделать так чтобы при изменение цену на пример 10,05,2016 изменилса цена этого товара на 11,05,2016 ...... пожалюста
Добавлено: 12 Май 2016, 17:26

помогите пожалуйста дайте хот направление типа пробуй так или так очень прошу

Последний раз редактировалось: bek007; 12 Май 2016, 17:26. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1. возьмите не таблицу ОстаткиИОбороты а таблицу Остатки
2. цену (=Сумма/Количество) сразу в запросе посчитайте
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн bek007

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-12
  • Сайт: 
  • Профессия: Ученик 1С
1. возьмите не таблицу ОстаткиИОбороты а таблицу Остатки
2. цену (=Сумма/Количество) сразу в запросе посчитайте
1. так тоже можно 2. сумма расчитивается сумма=количество*цена проблема в том что я немогу цену поставит на следуюших месяцев. когда добавлю не переодично цена не изменяется на следуюших месяцев((
Добавлено: 13 Май 2016, 10:13

может я не туда пишу события. их пишу в модуле формы так правилно?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
вы меня конечно извините...
ваще ничего не понятно что вы пишите :trhregerhg:
нету никого рядом кто лучше говорит по-русски?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн bek007

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-12
  • Сайт: 
  • Профессия: Ученик 1С
вы меня конечно извините...
ваще ничего не понятно что вы пишите :trhregerhg:
нету никого рядом кто лучше говорит по-русски?
пример: на складе цемент - средная цена  1 тн 1500 на 12.05.2016| сделаю  приход на 13.05.2016| от поставшика цемент - цена 1 тн 2000 на 08.05.2016| от поставшика цена пишется в ручную а не средная. проблема: чтобы правильно все было(сред.цена на 12.05.2016 - 1750) мне надо открыт и препровести все документы, тоесть 08.05.2016, 09.05.2016, ... и.т.д тут документов много надо все это автоматом сделалас помоги пожалюста:(   
Добавлено: 13 Май 2016, 18:05

вы меня конечно извините...
ваще ничего не понятно что вы пишите :trhregerhg:
нету никого рядом кто лучше говорит по-русски?
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   Стр1= Объект.Дата;
   Стр = Объект.Товары[0].Материал;
   стр3 = Объект.Товары[0].ЕднИзм;
   Стр2 = Объект.От.Наименование;
   Если ОстатокНаСкладе(Стр1,Стр1,Стр,Стр3)<>0 и стр2 <> "Поставшик" тогда
   Объект.Товары[0].Цена = ОстатокНаСкладе(Стр1,Стр1,Стр,Стр3);
Иначе Объект.Товары[0].Цена = Объект.Товары[0].Цена
   Команды
   КонецЕсли;

КонецПроцедуры
 помоги с этим пожалюста

Последний раз редактировалось: bek007; 13 Май 2016, 18:05. Причина: Объединение сообщений

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
   Команды
Это что?

ОстатокНаСкладе(Стр1,Стр1,Стр,Стр3)
а это что?

Объект.Товары[0].Цена = Объект.Товары[0].Цена
в чем прикол этого?

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 

Регистр сведений "Версии объектов"

Автор ЕвгенийЗерноРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 64
Последний ответ Сегодня в 17:00
от ЕвгенийЗерно
Не формируется регистр НУ "Расходы на оплату труда"

Автор DOKA@Раздел Пользователям "1С - Предприятие 8"

Ответов: 14
Просмотров: 9182
Последний ответ 23 Дек 2013, 17:22
от LordWizard
регистр "Данные о времени для расчета среднего"

Автор AlexRasmusРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2245
Последний ответ 15 Сен 2015, 19:14
от Дмитрий@
Регистр накоплений - себестоимость, не записываются движения документа "Реализация товаров"

Автор ekaterinka87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2226
Последний ответ 20 Июл 2015, 11:10
от ferrari314
1С:Консолидация ПРОФ, редакция 1.6( Операнд "Регистр бух-рии внешней ИБ" )

Автор BaranovaPolinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2755
Последний ответ 31 Мар 2011, 18:31
от BaranovaPolina

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
140 Сообщений
alex0402
112 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
ilyay ilyay
51 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
43 Сообщений
wise wise
40 Сообщений
ab30ru
38 Сообщений
Амал
35 Сообщений
Dethmontt Dethmontt
25 Сообщений

* Кто онлайн

  • Точка Гостей: 325
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal