Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Июл 2017, 09:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: УТ 11.1.9.66 (платформа 8.3.7.1790) Рабочее место кассира  (Прочитано 1287 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Psm_2015

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 3
  • КПД: 5%
  • Регистрация: 2015-06-12
  • Сайт: 
  • Профессия: Ученик 1С
УТ 11.1.9.66 (платформа 8.3.7.1790)
    В разделе "Продажи" есть пункт "Рабочее место кассира", по которому открывается "ФормаДокументаМастер" документа "ЧекККМ". Среди кнопок нижней панели этой формы есть кнопки "В резерв" и "Отложить", но нет кнопки "Продолжить отложенный чек". Причем, если нажать любую из них, текущий чек проводится с соответствующим статусом, но форма не очищается. (хз почему так, кто знает поясните пожалуйста)
    Открыть же отложенный чек можно из раздела "Продажи" пункта "Чеки ККМ". По которому открывается форма списка журнала документов "ЧекиККМ". Здесь при выборе  срабатывает следующий код:
&НаКлиенте
Процедура ЧекиККМВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

ТекущиеДанные = Элементы.ЧекиККМ.ТекущиеДанные;
Если ТекущиеДанные.Тип = Тип("ДокументСсылка.ЧекККМ") Тогда
ПараметрыОткрытия = Новый Структура("Ключ", ТекущиеДанные.Ссылка);
Если ТекущиеДанные.Статус <> ПредопределенноеЗначение("Перечисление.СтатусыЧековККМ.Пробит") И СменаОткрыта Тогда
СтандартнаяОбработка = Ложь;
ОткрытьФорму("Документ.ЧекККМ.Форма.ФормаДокументаМастер", ПараметрыОткрытия);
КонецЕсли;
КонецЕсли;

КонецПроцедуры

    Нужно сделать, чтобы в форме "Рабочее место кассира" была кнопка "Продолжить чек", по которой открывается форма со списком отложенных чеков и при выборе форма бы закрывалась, а в основной форме отображался выбранный чек.

    Если по кнопке открывать форму журнала со своими отборами (без пометки на удаление, текущая кассовая смена, статус чека ) то при выборе чека будет открываться новая форма "Рабочее место кассира", а не старая. Как сделать чтоб в старой открывалось?


Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
так открывайте форму выбора чека ккм со своими отборами, а потом обрабатывайте выбранный документ
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Psm_2015

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 3
  • КПД: 5%
  • Регистрация: 2015-06-12
  • Сайт: 
  • Профессия: Ученик 1С

так открывайте форму выбора чека ккм со своими отборами, а потом обрабатывайте выбранный документ

    Когда так делал с другой проблемой столкнулся.

    В "ОбработкеВыбора" формы "Рабочее место кассира" получал ссылку, и заполнял свойства объекта и табчасти. Все нормально открывалось, но при расчете ничего не происходило. Как потом показала отладка, я номер отложенного чека в текущий объект записал и во время проверки резервирования (при попытке записи) ошибка выводилась о не уникальности номера. Если номер не заполнять то расчет проходит, но соответственно это другой документ получается.

    Можно конечно после расчета или после получения отложенного чека удалять его, или не трогать т.к. в настройках при закрытии смены все отложенные чеки автоматически удаляются. Но мне показалось что такой вариант как-то через жопу сделан будет, и что я какую-то простую ошибку допускаю и не вижу её.

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
попробуйте заполнить Объект.Ссылка выбранным документом, а потом вызвать УстановитьЗначенияПоНастройкам()
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Psm_2015

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 3
  • КПД: 5%
  • Регистрация: 2015-06-12
  • Сайт: 
  • Профессия: Ученик 1С
попробуйте заполнить Объект.Ссылка выбранным документом, а потом вызвать УстановитьЗначенияПоНастройкам()
сорри, туплю.

Объект у нас реквизит формы, данныеФормыСтруктура. Если писать:

      Объект.Ссылка = ЧекЗаполнения;

где ЧекЗаполнения это ссылка на выбранный отложенный чек, то выдает ошибку
"поле объекта недоступно для записи (ссылка)"

как правильно заполнить ссылку?

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура КакНазовете()
Вашапроцедура();

АдресПримененныхСкидокВоВременномХранилище = "";
УправляемыеСкидки = Новый СписокЗначений;

Элементы.Страницы.ТекущаяСтраница = Элементы.СтраницаТовары;
ПересчитатьДокументНаКлиенте();
КонецПрцедуры

&НаСеврере
Процедура вашаПроцедура()

    ВыбранныйЧек = //тут вы выбираете чек
ЗначениеВДанныеФормы(ВыбранныйЧек, Объект);

ТолькоПросмотр = Ложь;
ПараметрыУказанияСерий = Новый ФиксированнаяСтруктура(НоменклатураСервер.ПараметрыУказанияСерий(Объект, Документы.ЧекККМ));

ПриСозданииЧека();

КонецПроцедуры


Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Psm_2015

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 3
  • КПД: 5%
  • Регистрация: 2015-06-12
  • Сайт: 
  • Профессия: Ученик 1С
На "ЗначениеВДанныеФормы" ошибку ругается что-то про метод контекста.

В итоге вот так получилось:
&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)

// получаем выбранный отложенный чек из ФормаСпискаОтложенных и заполняем объект
Если ИсточникВыбора.ИмяФормы = "Документ.ЧекККМ.Форма.ФормаСпискаОтложенных" И
ТипЗнч(ВыбранноеЗначение) = Тип("ДокументСсылка.ЧекККМ") Тогда
   
Отказ = Ложь;
ЗаполнитьДаннымиПоЧекуККМ(ВыбранноеЗначение,Отказ);

Если Отказ Тогда
ПоказатьПредупреждение(,"Ошибка загрузки чека!");
Возврат;
КонецЕсли;

ПересчитатьДокументНаКлиенте();

КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ЗаполнитьДаннымиПоЧекуККМ(ЧекЗаполнения, Отказ)

Попытка
ЧекЗаполненияОбъект = ЧекЗаполнения.ПолучитьОбъект();
ЗначениеВРеквизитФормы(ЧекЗаполненияОбъект, "Объект");
Объект.Дата = ТекущаяДатаСеанса();
Исключение
Отказ = Истина;
КонецПопытки;

КонецПроцедуры

Спасибо Rasty!


Теги:
 

При старте системы выдает ошибку ВнешняяОбработка.Платформа.МодульОбъекта(111):Значение не является значением объектного типа(ТипМножественноеЧисло) конфигурация Полный учет в отделе ИТ(2017.3.1)

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 174
Последний ответ 05 Июл 2017, 10:25
от Dethmontt
Мобильная платформа и кнопка "меню"

Автор nickroblogger_Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1422
Последний ответ 09 Мар 2015, 16:49
от temrmal
платформа 8.3 Окно выдает "Неверный формат хранилища данных" Помогите

Автор Виктор АлександровичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 697
Последний ответ 17 Мар 2016, 08:47
от Виктор Александрович
Как изменить макет печатной формы документа "Прием в ремонт" УНФ 1.6 Платформа 8.3

Автор AlexK39Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 553
Последний ответ 11 Дек 2016, 15:32
от cast
Настройка смс-порталов (sms4b) для "ДАЛИОН: АвтоБизнес", ред. 1.3 (1.3.4.32), платформа 8.2

Автор Оксана НовочРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 748
Последний ответ 17 Янв 2017, 09:29
от Oldman06

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
92 Сообщений
oleg-x
73 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
40 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 833
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal