Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2017, 05:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрос отрабатывает через раз  (Прочитано 385 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн viksa

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-11
  • Сайт: 
  • Профессия: Ученик 1С
Не могу понять почему запрос отрабатывает через раз...
//Проверка остатков
Для Каждого ТекСтрокаПутевойЛист Из ПутевойЛист Цикл
ТовДляОтбора = ТекСтрокаПутевойЛист.Товар;
Запрос = Новый Запрос;
Запрос.Текст =                                       
"ВЫБРАТЬ
|ОстаткиОстатки.Товар КАК Товар,                 
|ОстаткиОстатки.КоличествоОстаток
|ИЗ
|РегистрНакопления.Остатки.Остатки КАК ОстаткиОстатки
  |ГДЕ
| ОстаткиОстатки.Товар = &ТоварОст";
    Запрос.УстановитьПараметр("ТоварОст", ТовДляОтбора);
ВыборкаТовара = Запрос.Выполнить();
Выборка = ВыборкаТовара.Выбрать();       
Пока Выборка.Следующий() Цикл
Сообщить(Выборка.КоличествоОстаток-ТекСтрокаПутевойЛист.Доставить);
Если  Выборка.КоличествоОстаток-ТекСтрокаПутевойЛист.Доставить < 0 Тогда
ТекстСообщения = "В строке № "+ТекСтрокаПутевойЛист.НомерСтроки+" товара "+СокрЛП(ТекСтрокаПутевойЛист.Товар)+" не хватает на складе. На складе осталось - "+СокрЛП(Выборка.КоличествоОстаток);
Сообщить(ТекстСообщения,СтатусСообщения.Важное);
Отказ = Истина;
Прервать;
КонецЕсли;
КонецЦикла;
КонецЦикла;


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Запрос в цикле писать нельзя.
отрабатывает через раз...
- не очень информативное описание проблемы

Оффлайн viksa

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-11
  • Сайт: 
  • Профессия: Ученик 1С
Запускаешь, проводишь документ с ошибкой - ругается, создаешь другой/проводишь - может ругнутся, а может пропустить, создаешь третий/проводишь - пропускает при этом в выборке пусто, все 3 документа на один товар
Добавлено: 11 Май 2016, 17:07

Вот что в отладке... попробовала прописать условие на NULL, но не помогло
Добавлено: 11 Май 2016, 17:11

Вернее вот это, первый скрин когда проходит проверк
Добавлено: 11 Май 2016, 17:21

Разобралась, можно тему закрывать :ooifh:
P.S. Не то условие ставила для проверки пустого запроса...:nhsrm:

Последний раз редактировалось: viksa; 11 Май 2016, 17:21. Причина: Объединение сообщений


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7710
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2586
Последний ответ 15 Май 2013, 23:27
от Березин
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 715
Последний ответ 11 Июл 2016, 09:00
от vitasw
Запрос по обработке "Согласование заявок"

Автор DenielAkreedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 420
Последний ответ 29 Сен 2016, 02:39
от DenielAkreed
8.2 Бух. Запрос с условием "комментарий содержит текст"

Автор bolobolРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 14540
Последний ответ 02 Сен 2011, 01:14
от bolobol

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
91 Сообщений
Dethmontt Dethmontt
66 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
62 Сообщений
alex0402
58 Сообщений
ilyay ilyay
42 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
magnifico61
25 Сообщений
ilnur75
22 Сообщений
Дмитрий Медведков
18 Сообщений

* Кто онлайн

  • Точка Гостей: 192
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal