Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Май 2017, 16:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматическое заполнение цены в документе  (Прочитано 1246 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн szhutov

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-09
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте! Возникла такая проблема. Документом ЛЗК списывается материал со склада по остаточной стоимости. Нужно, чтобы при выборе номенклатуры цена в документе заполнялась автоматически (как частное суммы остатка материала и количества остатка из регистра накопления).

Ничего не получается.
Вот мои художества -

Процедура МатериалыНоменклатураПриИзменении(Элемент)
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
|   ЛЗКМатериалы.Номенклатура,
|   ЛЗКМатериалы.Количество,
|   ЛЗКМатериалы.Сумма,
|   ОстаткиМатериаловОстатки.Материал,
|   ОстаткиМатериаловОстатки.КоличествоОстаток,
|   ОстаткиМатериаловОстатки.СуммаОстаток
|ИЗ
|   Документ.ЛЗК.Материалы КАК ЛЗКМатериалы
|      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиМатериалов.Остатки КАК ОстаткиМатериаловОстатки
|      ПО (ЛЗКМатериалы.Номенклатура = ОстаткиМатериаловОстатки.Материал)
|         И (ЛЗКМатериалы.Количество = ОстаткиМатериаловОстатки.КоличествоОстаток)
|         И (ЛЗКМатериалы.Сумма = ОстаткиМатериаловОстатки.СуммаОстаток)";

   ВыборкаРезультатаЗапроса = Запрос.Выполнить().Выбрать();
   
   СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
   СтрокаТабличнойЧасти.ЕдИзмерения=СтрокаТабличнойЧасти.Номенклатура.ЕдиницаИзмерения;
   
   СтрокаТабличнойЧасти.Цена = ВыборкаРезультатаЗапроса.СуммаОстаток/ВыборкаРезультатаЗапроса.КоличествоОстаток;
КонецПроцедуры

Сама конфа во вложении. Может кому пригодиться.


Оффлайн szhutov

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-09
  • Сайт: 
  • Профессия: Бухгалтер
Забыл сказать - конфигурация самописная на платформе 8.1.
При выборе номенклатуры, в ФОРМЕ ВЫБОРА справочника "Номенклатура" все остатки видны и цена расчитывается. А как все это запихать в ЛЗК?

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Запрос.Текст =
   "ВЫБРАТЬ
   |   ОстаткиМатериаловОстатки.СуммаОстаток / ОстаткиМатериаловОстатки.КоличествоОстаток КАК Цена
   |ИЗ
   |   РегистрНакопления.ОстаткиМатериалов.Остатки КАК ОстаткиМатериаловОстатки
   |ГДЕ
   |   ОстаткиМатериаловОстатки.Материал = &Номенклатура";

   Запрос.УстановитьПараметр("Номенклатура", ЭлементыФормы.Материалы.ТекущиеДанные.Номенклатура);
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн szhutov

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-09
  • Сайт: 
  • Профессия: Бухгалтер
Процедура МатериалыНоменклатураПриИзменении(Элемент)
    Запрос = Новый Запрос;   
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ОстаткиМатериаловОстатки.СуммаОстаток / ОстаткиМатериаловОстатки.КоличествоОстаток КАК Цена
   |ИЗ
   |   РегистрНакопления.ОстаткиМатериалов.Остатки КАК ОстаткиМатериаловОстатки
   |ГДЕ
   |   ОстаткиМатериаловОстатки.Материал = &Номенклатура";

   Запрос.УстановитьПараметр("Номенклатура", ЭлементыФормы.Материалы.ТекущиеДанные.Номенклатура);
   

   ВыборкаРезультатаЗапроса = Запрос.Выполнить().Выбрать();
   
   СтрокаТабличнойЧасти=ЭлементыФормы.Материалы.ТекущиеДанные;
   СтрокаТабличнойЧасти.ЕдИзмерения=СтрокаТабличнойЧасти.Номенклатура.ЕдиницаИзмерения;
   
   СтрокаТабличнойЧасти.Цена = ВыборкаРезультатаЗапроса.Цена;

КонецПроцедуры

Единица измерения заполняется автоматом(берется из справочника "Номенклатура"), а цена никак не хочет.

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а что в выборкарезультатзапроса?
Добавлено: 10 Май 2016, 11:04

аааа ну точно, нужно сделать так
Если ВыборкаРезультатЗапроса.Следующий() Тогда
    СтрокаТабличнойЧасти.Цена = ВыборкаРезультатаЗапроса.Цена;
Иначе
    Сообщить("Сообщение какое-нибудь");
КонецЕсли;
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн szhutov

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-09
  • Сайт: 
  • Профессия: Бухгалтер
Я так понимаю цены по всем позициям номенклатуры из регистра накопления "Остатки материалов" сопоставленные с номенклатурой из справочника "Номенклатура".

(Дело в том, что программа досталась от предшественника, сам я только начинаю вникать в 1с, (работал в С++), хочется доработать программку)

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Вообще цены должны храниться в регистре сведений, а остатки в регистре накопления
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн szhutov

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-09
  • Сайт: 
  • Профессия: Бухгалтер
Все получилось! Огромное СПАСИБО! Удачи!


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 6375
Последний ответ 16 Авг 2012, 21:50
от Will
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2237
Последний ответ 30 Ноя 2011, 07:10
от has
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3546
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 151
Последний ответ 10 Май 2017, 20:44
от ilnur75
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1155
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
85 Сообщений
wise wise
65 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
50 Сообщений
Dethmontt Dethmontt
49 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilyay ilyay
30 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal