Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Янв 2017, 16:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка формы списка регистра сведений и заполнение значений в документ  (Прочитано 487 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн onlyko

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-08
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Столкнулась с такой проблемой: имеется документ "Запись на занятия" с реквизитами: дата, время, клиент, стиль, тренер. При нажатии кнопки открывается форма списка с отбором регистра сведений "Расписание занятий" с аналогичными реквизитами. При выборе строки из регистра необходимо заполнение ее значения в документ. Однако у меня не работает, в обработку выбора не заходит. Реализовываю следующим образом.

В форме документа

&НаКлиенте
Процедура ВыбратьРасписание(Команда)
     Отбор = Новый Структура("Дата", Объект.ДатаЗанятия);
     ПараметрыФормы = Новый Структура;
     ПараметрыФормы.Вставить("РежимВыбора", Истина);
     ПараметрыФормы.Вставить("Отбор", Отбор);
     ОткрытьФормуМодально("РегистрСведений.РасписаниеЗанятий.ФормаСписка", ПараметрыФормы, ЭтаФорма);   
       
КонецПроцедуры


&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
   
    ДанныеСтроки=Новый Структура("Тренер, Стиль, Время");
    ЗаполнитьЗначенияСвойств(ДанныеСтроки, ВыбранноеЗначение);
    ЗаполнитьЗначенияСвойств(Объект, ДанныеСтроки);
    Модифицированность=Истина;

КонецПроцедуры


В форме списка регистра сведений

&НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
   
    Стр=Элементы.Список.ТекущиеДанные;
   
    СтандартнаяОбработка = Ложь;
    СтруктураРезультат=Новый Структура;
    СтруктураРезультат.Вставить("Тренер", Стр.Тренер);
    СтруктураРезультат.Вставить("Стиль", Стр.Стиль);
    СтруктураРезультат.Вставить("ВремяНачала", Стр.ВремяНачала);
    ЗаполнитьЗначенияСвойств(СтруктураРезультат, ЭтаФорма);
    ОповеститьОВыборе(СтруктураРезультат);
   
КонецПроцедуры


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
   
    Стр=Элементы.Список.ТекущиеДанные;
   
    СтандартнаяОбработка = Ложь;
    СтруктураРезультат=Новый Структура;
    СтруктураРезультат.Вставить("Тренер", Стр.Тренер);
    СтруктураРезультат.Вставить("Стиль", Стр.Стиль);
    СтруктураРезультат.Вставить("ВремяНачала", Стр.ВремяНачала);
    ЗаполнитьЗначенияСвойств(СтруктураРезультат, ЭтаФорма);????????????????? зачем?
    ОповеститьОВыборе(СтруктураРезультат);
   
КонецПроцедуры



Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 5737
Последний ответ 16 Авг 2012, 21:50
от Will
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3596
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2572
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3566
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3955
Последний ответ 25 Ноя 2008, 10:43
от DDD

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
alex0402
56 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
crow1983
37 Сообщений
LexaK
32 Сообщений
alexandr_ll
28 Сообщений
sertak sertak
25 Сообщений
Vzonder
21 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 986
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal