Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2017, 00:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отправка сканов из папки привязанных к кодам серий номенклатуры из Реализауия товаров и услуг  (Прочитано 1344 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Гайдар

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С

Доброго времени суток!

Процедура ниже ... Хочу отправить файлов привязанных к кодам серий номенклатуры и документа Реализация, но вложение не добавляется.
Сообщение.Вложения.Добавить(Новый ДвоичныеДанные(ВыбФайл),ВыбФайл.Имя);
по причине:
Файл не обнаружен 'Файл'

Что подскажете?


Процедура ОсновныеДействияФормыПечатьPDF(Кнопка)
     МассивФайлов = Новый Массив;
     Путь = "D:\Сканы TIFF\";
     ТипФайла = ".Tif";
Для каждого стр из Товары цикл
         
Если ЭтотОбъект.Контрагент.Код = "Ц00002520" Тогда
ВыбФайл = Новый Файл(Путь+стр.СерияНоменклатуры.Код+ТипФайла);
Если ВыбФайл.Существует() Тогда
   сообщить(ВыбФайл.Имя);
Почта = Новый ИнтернетПочта;
Попытка
Почта.Подключиться(ПолучитьПрофиль());
Исключение
Сообщить(ОписаниеОшибки()+ " " + "Возможно нет связи, проверьте интернет и повторите для данного склада");
Возврат;
КонецПопытки;

Сообщение = Новый ИнтернетПочтовоеСообщение;
Сообщение.Вложения.Добавить(Новый ДвоичныеДанные(ВыбФайл),ВыбФайл.Имя);
Сообщение.Отправитель = "zayavkitp@mail.ru";
Сообщение.ИмяОтправителя = "Справки";
ПочтовыеАдреса = Сообщение.Получатели;

ПочтовыйАдрес = ПочтовыеАдреса.Добавить();
ПочтовыйАдрес.Адрес = "abasov.gaydar@mail.ru";


Сообщение.Тема ="Справки";

ИнтернетТекстПочтовогоСообщения = Сообщение.Тексты.Добавить();
ИнтернетТекстПочтовогоСообщения.Текст = "Скачивайте файлы справок и скопируйте в необходиму папку";
ИнтернетТекстПочтовогоСообщения.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;

Попытка
// Пытаемся послать письмо
Почта.Послать(Сообщение);
Исключение
Сообщить(ОписаниеОшибки()+ " " + "Возможно нет связи, проверьте интернет и повторите для данного склада");
Возврат;
КонецПопытки;
// отключение
Сообщить("Справки отправлены по почте");
Почта.Отключиться();
КонецЕсли;
КонецЕсли;



КонецЦикла;

КонецПроцедуры


Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
так вложение добавляются по пути файла, зачем двоичные данные?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Гайдар

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
так вложение добавляются по пути файла, зачем двоичные данные?


Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Оффлайн Kironten

  • *****
  • Сообщений: 716
  • РЕПУТАЦИЯ: 153
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
так вложение добавляются по пути файла, зачем двоичные данные?


Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Потому как ВыбФайл у вас тип "Файл", а передавать надо тип "Строка".

Оффлайн Гайдар

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
так вложение добавляются по пути файла, зачем двоичные данные?


Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Потому как ВыбФайл у вас тип "Файл", а передавать надо тип "Строка".

Сообщение.Вложения.Добавить() - напишите эту строку кода как правильно , я начинающий , не пойму

Оффлайн Kironten

  • *****
  • Сообщений: 716
  • РЕПУТАЦИЯ: 153
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
так вложение добавляются по пути файла, зачем двоичные данные?


Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Потому как ВыбФайл у вас тип "Файл", а передавать надо тип "Строка".

Сообщение.Вложения.Добавить() - напишите эту строку кода как правильно , я начинающий , не пойму
Все у нас тут начинающие :btbzdb:
Сообщение.Вложения.Добавить(ВыбФайл.ПолноеИмя);

Оффлайн Гайдар

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С
так вложение добавляются по пути файла, зачем двоичные данные?


Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Потому как ВыбФайл у вас тип "Файл", а передавать надо тип "Строка".

Сообщение.Вложения.Добавить() - напишите эту строку кода как правильно , я начинающий , не пойму
Все у нас тут начинающие :btbzdb:
Сообщение.Вложения.Добавить(ВыбФайл.ПолноеИмя);
Рабтает :zebzdr: СПАСИБО:ooifh:    было лучще если все файлы по документу отправляла одним письмом:(

Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Гайдар

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2011-09-16
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 

"фильтрация" номенклатуры

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 5716
Последний ответ 11 Мар 2014, 16:09
от mashencev_anton
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 66
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
Номенклатуры типов "расход" и "услуга. Как использовать?

Автор joyerРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2208
Последний ответ 29 Июн 2011, 21:11
от joyer
Перенос товаров из д-та "Поступление Т и У" в "Отчет о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 4041
Последний ответ 01 Июн 2011, 16:31
от Eugeneer
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 150
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
63 Сообщений
MuI_I_Ika MuI_I_Ika
47 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
30 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
17 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal