Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Мар 2017, 22:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Бизнес-процесс не двигается по этапам  (Прочитано 889 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lcnw

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-03
  • Сайт: 
  • Профессия: Ученик 1С
В "1С: Бухгалтерия Предприятия 8.3" делаю Бизнес-процесс, в котором создается некий договор, указывается поэтапная последовательность, в которой пользователи должны согласовывать документ. В табличной части мы указываем номер этапа, и пользователей, которым будут созданы задачи на этом этапе.

Проблема в том, что БП работает только на первом этапе. На первом этапе создается либо одна задача, если один пользователь, либо несколько, если несколько пользователей указано на первом этапе. А на следующие этапы БП не переходит, и завершается сразу после выполнения всех задач первого этапа. Как это исправить?

Вот код модуля Бизнес-процесса, карта маршрута состоит из трех элементов - Старт, Точка Действия - "Созание Задач", и Завершение.
Процедура СозданиеЗадачПередСозданиемЗадач(ТочкаМаршрутаБизнесПроцесса, ФормируемыеЗадачи, СтандартнаяОбработка)
    Для Каждого Элемент Из Согласованность Цикл
        Если Элемент.Этап=ТекущийЭтап Тогда
            НоваяЗадача=Задачи.ЗадачаДляКурсовой.СоздатьЗадачу();
            НоваяЗадача.БизнесПроцесс=ЭтотОбъект.Ссылка;
            НоваяЗадача.ТочкаМаршрута=БизнесПроцессы.БПКурсовой.ТочкиМаршрута.СозданиеЗадач;
            НоваяЗадача.Наименование="Согласование "+Элемент.Согласователь;
            НоваяЗадача.Ответственный=Элемент.Согласователь;
            НоваяЗадача.Этап=ТекущийЭтап;
            НоваяЗадача.Дата=ТекущаяДата();
            НоваяЗадача.Записать();
            ФормируемыеЗадачи.Добавить(НоваяЗадача);
        КонецЕсли;
    КонецЦикла;
    Записать();
    СтандартнаяОбработка=Ложь;
КонецПроцедуры
 
Процедура СтартПередСтартом(ТочкаМаршрутаБизнесПроцесса, Отказ)
    Сообщить("Старт БП!");
    Согласованно=Перечисления.СтатусДоговора.НаСогласовании;
    ТекущийЭтап=1;
КонецПроцедуры
 
Процедура ЗавершениеПриЗавершении(ТочкаМаршрутаБизнесПроцесса, Отказ)       
    Дгвр=Справочники.ДоговорДляСогласования.НайтиПоНаименованию(Договор).ПолучитьОбъект();
    Если Согласованно=Перечисления.СтатусДоговора.Согласован Тогда
        Дгвр.Согласован=Перечисления.СтатусДоговора.Согласован;
    Иначе
        Дгвр.Согласован=Перечисления.СтатусДоговора.Отклонен;
    КонецЕсли;
    Дгвр.Записать();
КонецПроцедуры


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
карта маршрута состоит из трех элементов - Старт, Точка Действия - "Созание Задач", и Завершение.
номер этапа, и пользователей, которым будут созданы задачи на этом этапе.

карта маршрута и ваша хотелка не совпадают. задачи создаются только по карте БП.

Оффлайн lcnw

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-03
  • Сайт: 
  • Профессия: Ученик 1С
карта маршрута и ваша хотелка не совпадают. задачи создаются только по карте БП.
Имеется в виду карта маршрута самого Бизнес-процесса

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Так  о том же. Согласно карте вашего БП у вас только одна задача и сразу завершение. то что вы там программно ваяете - это народное творчество и к текущему БП дела не имеет.

Оффлайн lcnw

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-03
  • Сайт: 
  • Профессия: Ученик 1С
Так  о том же. Согласно карте вашего БП у вас только одна задача и сразу завершение. то что вы там программно ваяете - это народное творчество и к текущему БП дела не имеет.
Мне нужно добавить больше точек действия в карту, для моих задач? Что именно нужно исправить в данном случае?

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Карту маршрута конечно. Каждая задача вашего БП отражается картой. нет карты = нет задачи.

Оффлайн lcnw

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-03
  • Сайт: 
  • Профессия: Ученик 1С
Карту маршрута конечно. Каждая задача вашего БП отражается картой. нет карты = нет задачи.
Извините заранее за глупый вопрос, но мне надо получше в этом разобраться. Вот у нас есть Бизнес-процесс, который должен создавать задачи пользователям. Когда мы запускаем Бизнес-Процесс, он идет по карте маршрута, доходит до точки действия, в которой должен создавать задачи, создает их, ждет их выполнения пользователями, и завершается. Я правильно логику работы понимаю?
В точке действия Бизнес-Процесса мы можем создать только одну задачу или неограниченное?


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
156 Сообщений
alex0402
118 Сообщений
Norfolk
51 Сообщений
LexaK
48 Сообщений
MuI_I_Ika MuI_I_Ika
44 Сообщений
AsadRoman
22 Сообщений
друган
21 Сообщений
alexandr_ll
19 Сообщений
SlimShady
19 Сообщений
Константин5825
18 Сообщений

* Кто онлайн

  • Точка Гостей: 316
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal