Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Июл 2017, 11:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод данных из справочника в csv  (Прочитано 658 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн boyarincev

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-06
  • Сайт: 
  • Профессия: Бухгалтер
Добрый день форумчане... Давно не пользовался 1с 7.7
Надо вспомнить!
Задача, Имеется справочник.организации
в них находятся поля: к примеру Справочник.Организации.ПолнНаимен и Справочник.Организации.ПочтовыйАдресОрганизации
Плиззз подскажите - всю логику забыл, как мне сделать выгрузку в CSV (txt с разделителями ";" )
вида
000001;ООО"Пупсик";Ставраполь*******;
000002;******************************

Очень жду подсказок... не работал в ней лет 5 уже


Оффлайн boyarincev

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-06
  • Сайт: 
  • Профессия: Бухгалтер
не оставляйте без внимания пожалуйста!!!

Оффлайн VivaBrunko

  • ***
  • Сообщений: 107
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2015-04-30
  • Сайт: 
  • Профессия: ГлавБух
не оставляйте без внимания пожалуйста!!!
курите гугл

Оффлайн boyarincev

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-06
  • Сайт: 
  • Профессия: Бухгалтер
Гугл вкурил - торчануло, все получилось - ИТОГ:

Перем ТекЗакладка;
Процедура Сформировать()         
   Сообщить ("Началась обработка");
       Т=СоздатьОбъект ("Текст");
      СпрФ=СоздатьОбъект ("Справочник.Организации");   
      СпрФ.ПорядокКодов ();
      СпрФ.ВыбратьЭлементы ();
Пока СпрФ.ПолучитьЭлемент ()>0 Цикл
        Если СпрФ.ЭтоГруппа ()=1 Тогда 
Продолжить;                               
КонецЕсли; 
Наим = Сокрлп(СпрФ.ПолнНаимен);
Юрадр = Сокрлп(СпрФ.ЮрАдресОрганизации);
ТелОрг = Сокрлп(СпрФ.ТелефоныОрганизации);
ТекЗакладка = СпрФ.Код;
Спр = СоздатьОбъект("Справочник.Контрагенты");
    Спр.НайтиПоКоду(ТекЗакладка);
    Если Спр.выбран()=1 тогда
        Емайл = Спр.Email;
   Иначе
      Емайл = " ";
    КонецЕсли;
Т.ДобавитьСтроку(СпрФ.Код+";"+СпрФ.ИНН+";"+Наим+";"+Юрадр+";"+ТелОрг+";"+Емайл);   

КонецЦикла;       
Файл="yurorg.csv";
Т.Записать (Файл);
Сообщить ("Файл с данными "+Файл+" сохранен в каталоге пользователя");
КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
94 Сообщений
oleg-x
71 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений
BuhRust
22 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal