Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Мар 2017, 22:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод данных из справочника в csv  (Прочитано 551 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн boyarincev

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-06
  • Сайт: 
  • Профессия: Бухгалтер
Добрый день форумчане... Давно не пользовался 1с 7.7
Надо вспомнить!
Задача, Имеется справочник.организации
в них находятся поля: к примеру Справочник.Организации.ПолнНаимен и Справочник.Организации.ПочтовыйАдресОрганизации
Плиззз подскажите - всю логику забыл, как мне сделать выгрузку в CSV (txt с разделителями ";" )
вида
000001;ООО"Пупсик";Ставраполь*******;
000002;******************************

Очень жду подсказок... не работал в ней лет 5 уже


Оффлайн boyarincev

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-06
  • Сайт: 
  • Профессия: Бухгалтер
не оставляйте без внимания пожалуйста!!!

Оффлайн VivaBrunko

  • ***
  • Сообщений: 107
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2015-04-30
  • Сайт: 
  • Профессия: ГлавБух
не оставляйте без внимания пожалуйста!!!
курите гугл

Оффлайн boyarincev

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-06
  • Сайт: 
  • Профессия: Бухгалтер
Гугл вкурил - торчануло, все получилось - ИТОГ:

Перем ТекЗакладка;
Процедура Сформировать()         
   Сообщить ("Началась обработка");
       Т=СоздатьОбъект ("Текст");
      СпрФ=СоздатьОбъект ("Справочник.Организации");   
      СпрФ.ПорядокКодов ();
      СпрФ.ВыбратьЭлементы ();
Пока СпрФ.ПолучитьЭлемент ()>0 Цикл
        Если СпрФ.ЭтоГруппа ()=1 Тогда 
Продолжить;                               
КонецЕсли; 
Наим = Сокрлп(СпрФ.ПолнНаимен);
Юрадр = Сокрлп(СпрФ.ЮрАдресОрганизации);
ТелОрг = Сокрлп(СпрФ.ТелефоныОрганизации);
ТекЗакладка = СпрФ.Код;
Спр = СоздатьОбъект("Справочник.Контрагенты");
    Спр.НайтиПоКоду(ТекЗакладка);
    Если Спр.выбран()=1 тогда
        Емайл = Спр.Email;
   Иначе
      Емайл = " ";
    КонецЕсли;
Т.ДобавитьСтроку(СпрФ.Код+";"+СпрФ.ИНН+";"+Наим+";"+Юрадр+";"+ТелОрг+";"+Емайл);   

КонецЦикла;       
Файл="yurorg.csv";
Т.Записать (Файл);
Сообщить ("Файл с данными "+Файл+" сохранен в каталоге пользователя");
КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
alex0402
124 Сообщений
MuI_I_Ika MuI_I_Ika
53 Сообщений
Norfolk
52 Сообщений
LexaK
47 Сообщений
AsadRoman
20 Сообщений
друган
20 Сообщений
alexandr_ll
20 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 432
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal