Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 02:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: обработка внешней формы после обновления конфигурации  (Прочитано 2976 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mi-mi

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Бухгалтер
Господа программисты, помогите страдающему бухгалтеру...
Есть epf форма , через которую в 8.1 двухлетней давности загружали xls-файлы с приходом и реализацией товара.
после недавнего обновления конфигурации, выгрузка не работает в части номенклатуры.
справочник заполнен, и программа вместо того, чтобы выбрать существующий артикул, выдает ошибку- не уникальный код.
т.е. получается каждый раз один и тот же товар для программы как новый.
что делать?  :( :( :(

привожу часть кода:


Функция НайтиНоменклатуру(СтруктураДанных)
   
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   Номенклатура.Ссылка
   |ИЗ
   |   Справочник.Номенклатура КАК Номенклатура
   |ГДЕ
   |   Номенклатура.Код = &Код";
   
   Запрос.УстановитьПараметр("Код", СтруктураДанных.Артикул);
   Выборка = Запрос.Выполнить().Выбрать();
   
   Если Выборка.Следующий() Тогда
      Возврат Выборка.Ссылка;
   КонецЕсли;
   
   // -- Создание нового
   СпрНоменклатура = Справочники.Номенклатура.СоздатьЭлемент();
   СпрНоменклатура.Наименование = СтруктураДанных.Наименование;
   СпрНоменклатура.НаименованиеПолное = СтруктураДанных.Наименование;
   СпрНоменклатура.СтавкаНДС = ?(СтруктураДанных.СтавкаНДС = "10",Перечисления.СтавкиНДС.НДС10,?(СтруктураДанных.СтавкаНДС = "20",Перечисления.СтавкиНДС.НДС20,Перечисления.СтавкиНДС.НДС18));
   СпрНоменклатура.БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоНаименованию(СтруктураДанных.ЕдИзм);
   СпрНоменклатура.Код = СтруктураДанных.Артикул;
   СпрНоменклатура.Родитель = ГруппаНовойНоменклатуры;
   НомГруппа = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Товар");
   Если НомГруппа.Пустая() Тогда
      НомГруппа = Справочники.НоменклатурныеГруппы.СоздатьЭлемент();
      НомГруппа.Наименование = "Товар";
      НомГруппа.УстановитьНовыйКод();
      НомГруппа.Записать();
   КонецЕсли;
   СпрНоменклатура.НоменклатурнаяГруппа = НомГруппа.Ссылка;
   СпрНоменклатура.Записать();
   Сообщить("Создана новая номентлатура " + СпрНоменклатура.Наименование);
   Возврат СпрНоменклатура.Ссылка;
   
КонецФункции


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Нужно проверить, на каком именно элементе ругается база - при создании единицы измерения или самого элемента номенклатуры?
Как вариант, возможно в одном из справочников (Номенклатура, Единицы измерения) просто закончилась (или сбилась) нумерация. Проверьте - нет ли элементов с кодами вида "99999" (количество девяток зависит от длины кода данного конкретного справочника)
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн mi-mi

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Бухгалтер
Нужно проверить, на каком именно элементе ругается база - при создании единицы измерения или самого элемента номенклатуры?
Как вариант, возможно в одном из справочников (Номенклатура, Единицы измерения) просто закончилась (или сбилась) нумерация. Проверьте - нет ли элементов с кодами вида "99999" (количество девяток зависит от длины кода данного конкретного справочника)

ругается на элемент номенклатуры. когда добавила несколько произвольных символов в артикул, то все загрузилось нормально, и теперь в справочнике товары с одинаковыми наименованиями и разными артикулами.

а что делать, если действительно есть такой код 99999? как нормализовать нумерацию? если можно, пошагово, иначе заплутаю в конфигураторе навечно  :ehtwrtjryj:

Оффлайн mi-mi

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Бухгалтер
Как вариант, возможно в одном из справочников (Номенклатура, Единицы измерения) просто закончилась (или сбилась) нумерация. Проверьте - нет ли элементов с кодами вида "99999" (количество девяток зависит от длины кода данного конкретного справочника)

нумерации с кодами "99999" нет, но смущает тот факт, что существует несколько наименований с абсолютно одинаковыми артикулами. а как же уникальность кода?.. программа навряд ли дала возможность завести такие позиции...
могла ли база при обновлении обрезать значения кодов до 11 знаков? как восстановить потерянное?

Оффлайн mi-mi

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-21
  • Сайт: 
  • Профессия: Бухгалтер
В общем, разобралась.   :zebzdr:
Увеличила количество знаков в коде с 11 до 20 и фсё.
Klyacksa, спасибо за наводку о длине кода.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Как бороться с нумерацией - либо ручками менять, либо обработку писать, которая перенумерует - будет перебирать элементы, и по какому-то правилу перенумеровывать.
И нужно будет где-то сбросить текущий номер, но это я так с лёту уже не скажу, где. Нужно смотреть.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 293
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4820
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3416
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4996
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 586
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 138
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal