Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2017, 20:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удалить строки из ТЧ  (Прочитано 340 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bestname

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Пытаюсь в табличной части документа убрать строки, с пустой Номенклатурой.
Почему условие не выполняется? Строки, у которых пустое значение "Номенклатура" в документе есть!

	
    СтруктураОтбора = Новый Структура("Номенклатура", Справочники.Номенклатура.ПустаяСсылка());
    ПодходящиеСтроки = Товары.НайтиСтроки(СтруктураОтбора);
    Если НЕ ПодходящиеСтроки.Количество()= 0 Тогда
        Для Каждого Строка Из ПодходящиеСтроки Цикл
            Товары.Удалить(Строка);
        КонецЦикла;
    КонецЕсли;

Делал так:
СтруктураОтбора = Новый Структура("Номенклатура", "")
Так тоже не работает.


Оффлайн Gennadiyy

  • **
  • Сообщений: 71
  • РЕПУТАЦИЯ: 4
  • КПД: 6%
  • Регистрация: 2015-12-08
  • Сайт: 
Попробуй так, сейчас нет под рукой конфигуратора, что бы проверить, уже точно не вспомню как делал: Строка.Удалить(); или Строка.Удалить(НомерСтроки), НомерСтроки - счетчик
Добавлено: 26 Апр 2016, 14:04

Попробуй так, сейчас нет под рукой конфигуратора, что бы проверить, уже точно не вспомню как делал: Строка.Удалить(); или Строка.Удалить(НомерСтроки), НомерСтроки - счетчик

ПС: по условию попробуй добавить: Если Не ЗначениеЗаполнено(Строка.Наименование) Тогда Строка.Удалить(НомерСтроки); КонецЕсли;

Последний раз редактировалось: Gennadiyy; 26 Апр 2016, 14:04. Причина: Объединение сообщений

Оффлайн bestname

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за отклик, все получилось!


Теги:
 

Как при вставке текста запроса с консоли запроса ив программный код конфигурации автоматически добавлять прямую черту в начале каждой строки

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1228
Последний ответ 16 Ноя 2015, 08:12
от KrivosheevEV
"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1251
Последний ответ 20 Авг 2014, 12:22
от has
как перебрать строки в табличной части документа в форме документа

Автор IaterРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3509
Последний ответ 06 Май 2015, 23:03
от Iater
В акте-сверки пустые строки в столбце "Документ" и нет периода в заголовке

Автор Анастасия СРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 558
Последний ответ 23 Дек 2016, 19:18
от ignatovsam
Заполнение строки документа значениями реквизитов табличной части документа

Автор green_ezhikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 2253
Последний ответ 01 Апр 2015, 22:19
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
155 Сообщений
alex0402
76 Сообщений
alexandr_ll
38 Сообщений
LexaK
29 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
crow1983
27 Сообщений
sertak sertak
23 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений
Vzonder
16 Сообщений

* Кто онлайн

  • Точка Гостей: 355
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal