Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2017, 17:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удалить строки из ТЧ  (Прочитано 428 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bestname

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 3
  • КПД: 5%
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Пытаюсь в табличной части документа убрать строки, с пустой Номенклатурой.
Почему условие не выполняется? Строки, у которых пустое значение "Номенклатура" в документе есть!

	
    СтруктураОтбора = Новый Структура("Номенклатура", Справочники.Номенклатура.ПустаяСсылка());
    ПодходящиеСтроки = Товары.НайтиСтроки(СтруктураОтбора);
    Если НЕ ПодходящиеСтроки.Количество()= 0 Тогда
        Для Каждого Строка Из ПодходящиеСтроки Цикл
            Товары.Удалить(Строка);
        КонецЦикла;
    КонецЕсли;

Делал так:
СтруктураОтбора = Новый Структура("Номенклатура", "")
Так тоже не работает.


Оффлайн Gennadiyy

  • **
  • Сообщений: 80
  • РЕПУТАЦИЯ: 5
  • КПД: 6%
  • Регистрация: 2015-12-08
  • Сайт: 
Попробуй так, сейчас нет под рукой конфигуратора, что бы проверить, уже точно не вспомню как делал: Строка.Удалить(); или Строка.Удалить(НомерСтроки), НомерСтроки - счетчик
Добавлено: 26 Апр 2016, 14:04

Попробуй так, сейчас нет под рукой конфигуратора, что бы проверить, уже точно не вспомню как делал: Строка.Удалить(); или Строка.Удалить(НомерСтроки), НомерСтроки - счетчик

ПС: по условию попробуй добавить: Если Не ЗначениеЗаполнено(Строка.Наименование) Тогда Строка.Удалить(НомерСтроки); КонецЕсли;

Последний раз редактировалось: Gennadiyy; 26 Апр 2016, 14:04. Причина: Объединение сообщений

Оффлайн bestname

  • **
  • Сообщений: 65
  • РЕПУТАЦИЯ: 3
  • КПД: 5%
  • Регистрация: 2015-06-10
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за отклик, все получилось!


Теги:
 

Как при вставке текста запроса с консоли запроса ив программный код конфигурации автоматически добавлять прямую черту в начале каждой строки

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1598
Последний ответ 16 Ноя 2015, 08:12
от KrivosheevEV
"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1437
Последний ответ 20 Авг 2014, 12:22
от has
как перебрать строки в табличной части документа в форме документа

Автор IaterРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5078
Последний ответ 06 Май 2015, 23:03
от Iater
Изменение строки "Скидка" в чеке ККМ в Розница 2.2

Автор magnifico61Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 155
Последний ответ 06 Апр 2017, 08:40
от magnifico61
В акте-сверки пустые строки в столбце "Документ" и нет периода в заголовке

Автор Анастасия СРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 1322
Последний ответ 23 Дек 2016, 19:18
от ignatovsam

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
96 Сообщений
Dethmontt Dethmontt
69 Сообщений
alex0402
66 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
61 Сообщений
ilyay ilyay
41 Сообщений
Сергей Федоров Сергей Федоров
34 Сообщений
magnifico61
23 Сообщений
ilnur75
21 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

  • Точка Гостей: 760
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal