Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Сен 2017, 18:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Мобильная платформа - СредстваМультимедиа  (Прочитано 768 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Товарищи!
Прошу Вас помочь разобраться в следующем. Моб.платформа.
Делаю все по методичке, но после того как переделал 6й раз, думаю разобью компьютер (он то тут не причем).

В общ. команда - модуль команды:

 
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
   
#Если НЕ МобильноеПриложениеКлиент Тогда
    Сообщить ("Функция не поддерживается");
     Возврат;
 
#Иначе   
Кнопки = Новый СписокЗначений;
Кнопки.Добавить("Фото","Фото");
Кнопки.Добавить("Видео","Видео");
Кнопки.Добавить("Звук","Звук");
Кнопки.Добавить("Отмена","Отмена");
Ответ = Вопрос("Выберете опцию:",Кнопки,,,"Что сделать?");
Если Ответ = "Отмена" Тогда Возврат КонецЕсли;

Результат = Неопределено;
Мультимедиа = Новый СредстваМультимедиа;
Если Ответ = "Фото" Тогда
    Если Мультимедиа.ПоддерживаетсяФотоснимок()
    Тогда Результат = Мультимедиа.СделатьФотоснимок();
Иначе
    Сообщить("Не поддерживается фото!");
КонецЕсли;

ИначеЕсли Ответ = "Видео" Тогда
Если Мультимедиа.ПоддерживаетсяВидеозапись()
    Тогда Результат = Мультимедиа.СделатьВидеозапись();
Иначе Сообщить("Не поддерживается видео!");
КонецЕсли;

ИначеЕсли Ответ = "Звук" Тогда
Если Мультимедиа.ПоддерживаетсяАудиозапись()
    Тогда Результат = Мультимедиа.СделатьАудиозапись();
Иначе Сообщить("Не поддерживается аудио запись!");
КонецЕсли;
КонецЕсли;

Если Результат = Неопределено Тогда Возврат
КонецЕсли;

Данные = Результат.ПолучитьДвоичныеДанные();
РасширениеФайла = Результат.РасширениеФайла;
ЗаписатьДанныеВРегистр(РасширениеФайла,Данные,ПараметрКоманды);

#КонецЕсли

КонецПроцедуры


При проверке выдает ОШИБКУ:

{ОбщаяКоманда.СоздатьВложение.МодульКоманды(19,21)}: Конструктор не найден
Мультимедиа = Новый <<?>>СредстваМультимедиа;  (Проверка: Мобильное приложение-клиент)


Кто знает, кому не сложно, подскажите ПОЖАЛУЙСТА!
Может уже глаза замылил, что не вижу простого ...

Заранее благодарен!




Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
а версия платформы какая?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
а версия платформы какая?



Спасибо! Разобрался!


Теги:
 

При старте системы выдает ошибку ВнешняяОбработка.Платформа.МодульОбъекта(111):Значение не является значением объектного типа(ТипМножественноеЧисло) конфигурация Полный учет в отделе ИТ(2017.3.1)

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 325
Последний ответ 20 Сен 2017, 09:10
от Геннадий ОбьГЭС
платформа 8.3 Окно выдает "Неверный формат хранилища данных" Помогите

Автор Виктор АлександровичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 753
Последний ответ 17 Мар 2016, 08:47
от Виктор Александрович
Как изменить макет печатной формы документа "Прием в ремонт" УНФ 1.6 Платформа 8.3

Автор AlexK39Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 647
Последний ответ 11 Дек 2016, 15:32
от cast
Настройка смс-порталов (sms4b) для "ДАЛИОН: АвтоБизнес", ред. 1.3 (1.3.4.32), платформа 8.2

Автор Оксана НовочРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 842
Последний ответ 17 Янв 2017, 09:29
от Oldman06
Начинающие программисты 1С - Хочу вас поздравить! Теперь платформа 1C для обучения доступна для скачивания бесплатно!

Автор DethmonttРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 29432
Последний ответ 13 Май 2013, 21:34
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Фрегат агент

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
165 Сообщений
alex0402
86 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
85 Сообщений
Golickoff Golickoff
32 Сообщений
Kironten
29 Сообщений
ilyay ilyay
27 Сообщений
BuhRust
26 Сообщений
AIFrame
26 Сообщений
AsadRoman
24 Сообщений
Варвар
20 Сообщений

* Кто онлайн

  • Точка Гостей: 444
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal