Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Май 2017, 04:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Мобильная платформа - СредстваМультимедиа  (Прочитано 603 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
Товарищи!
Прошу Вас помочь разобраться в следующем. Моб.платформа.
Делаю все по методичке, но после того как переделал 6й раз, думаю разобью компьютер (он то тут не причем).

В общ. команда - модуль команды:

 
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
   
#Если НЕ МобильноеПриложениеКлиент Тогда
    Сообщить ("Функция не поддерживается");
     Возврат;
 
#Иначе   
Кнопки = Новый СписокЗначений;
Кнопки.Добавить("Фото","Фото");
Кнопки.Добавить("Видео","Видео");
Кнопки.Добавить("Звук","Звук");
Кнопки.Добавить("Отмена","Отмена");
Ответ = Вопрос("Выберете опцию:",Кнопки,,,"Что сделать?");
Если Ответ = "Отмена" Тогда Возврат КонецЕсли;

Результат = Неопределено;
Мультимедиа = Новый СредстваМультимедиа;
Если Ответ = "Фото" Тогда
    Если Мультимедиа.ПоддерживаетсяФотоснимок()
    Тогда Результат = Мультимедиа.СделатьФотоснимок();
Иначе
    Сообщить("Не поддерживается фото!");
КонецЕсли;

ИначеЕсли Ответ = "Видео" Тогда
Если Мультимедиа.ПоддерживаетсяВидеозапись()
    Тогда Результат = Мультимедиа.СделатьВидеозапись();
Иначе Сообщить("Не поддерживается видео!");
КонецЕсли;

ИначеЕсли Ответ = "Звук" Тогда
Если Мультимедиа.ПоддерживаетсяАудиозапись()
    Тогда Результат = Мультимедиа.СделатьАудиозапись();
Иначе Сообщить("Не поддерживается аудио запись!");
КонецЕсли;
КонецЕсли;

Если Результат = Неопределено Тогда Возврат
КонецЕсли;

Данные = Результат.ПолучитьДвоичныеДанные();
РасширениеФайла = Результат.РасширениеФайла;
ЗаписатьДанныеВРегистр(РасширениеФайла,Данные,ПараметрКоманды);

#КонецЕсли

КонецПроцедуры


При проверке выдает ОШИБКУ:

{ОбщаяКоманда.СоздатьВложение.МодульКоманды(19,21)}: Конструктор не найден
Мультимедиа = Новый <<?>>СредстваМультимедиа;  (Проверка: Мобильное приложение-клиент)


Кто знает, кому не сложно, подскажите ПОЖАЛУЙСТА!
Может уже глаза замылил, что не вижу простого ...

Заранее благодарен!



Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
а версия платформы какая?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Dimonmsk

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-27
  • Сайт: 
  • Профессия: Ученик 1С
а версия платформы какая?



Спасибо! Разобрался!


Теги:
 

платформа 8.3 Окно выдает "Неверный формат хранилища данных" Помогите

Автор Виктор АлександровичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 626
Последний ответ 17 Мар 2016, 08:47
от Виктор Александрович
Как изменить макет печатной формы документа "Прием в ремонт" УНФ 1.6 Платформа 8.3

Автор AlexK39Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 429
Последний ответ 11 Дек 2016, 15:32
от cast
Настройка смс-порталов (sms4b) для "ДАЛИОН: АвтоБизнес", ред. 1.3 (1.3.4.32), платформа 8.2

Автор Оксана НовочРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 667
Последний ответ 17 Янв 2017, 09:29
от Oldman06
Начинающие программисты 1С - Хочу вас поздравить! Теперь платформа 1C для обучения доступна для скачивания бесплатно!

Автор DethmonttРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 28836
Последний ответ 13 Май 2013, 21:34
от Dethmontt
1с 8.3: Бухгалтерия.базовая платформа 8.3.6.2152 (отрицательного сальдо быть не должно-сбой системы)

Автор LyonaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1228
Последний ответ 10 Окт 2015, 09:39
от Lyona

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
81 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
49 Сообщений
Dethmontt Dethmontt
49 Сообщений
alex0402
43 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilyay ilyay
27 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 219
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal