Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июл 2017, 13:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка "Переменная не определена"  (Прочитано 1264 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн ElenaZar

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-20
  • Сайт: 
  • Профессия: Разработчик 1С
Здравствуйте, я начинаю изучать 1С, читаю книгу Радченко "Практическое пособие разработчика. Примеры и типовые приемы". Возникла ошибочка, помогите пожалуйста. В общем модуле такой текст:
Процедура РассчитатьСумму (СтрокаТабличнойЧасти) Экспорт
   СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличойЧасти.Цена;
   КонецПроцедуры

Выдаёт ошибку {ОбщийМодуль.РаботаСДокументами.Модуль(2,65)}: Переменная не определена (СтрокаТабличойЧасти)
   СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * <<?>>СтрокаТабличойЧасти.Цена; (Проверка: Тонкий клиент)

В модуле формы такой текст:
&НаКлиенте
Процедура МатериалыКоличествоПриИзменении(Элемент)
   СтрокаТабличнойЧасти = Элементы.Материалы.ТекущиеДанные;
   РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры

&НаКлиенте
Процедура МатериалыЦенаПриИзменении(Элемент)
   СтрокаТабличнойЧасти = Элементы.Материалы.ТекущиеДанные;
   РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры


Оффлайн pavl_vs

  • *****
  • Сообщений: 1006
  • РЕПУТАЦИЯ: 160
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
ElenaZar, как я понимаю, код для платформы 8.1 - у Вас с этим все в порядке?
В режиме отладчика посмотрите, что передается в процедуру РассчитатьСумму.

А вообще, если 8.1, то должно быть не Элементы.Материалы..., а ЭлементыФормы.Материалы...


Теги:
 

Закрытие месеца, ошибка при закрытие 26сч

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3802
Последний ответ 26 Июл 2013, 11:00
от Gendelf
ОШИБКА 1С 8.3. Файл не найден в хранилище файлов. Возможно файл удален антивирусной программой. Обратитесь к администратору

Автор Сергей БатуринРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 5111
Последний ответ 18 Май 2016, 18:18
от Сергей Батурин
При попытке проведения документов по НДФЛ (справка 2 НДФЛ ) вылезает ошибка:

Автор klaus38Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2572
Последний ответ 19 Фев 2015, 20:54
от vitasw
При входе пользователя 1с77 по RDP (Server2008) выдается ошибка и выпадает 1с77

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1432
Последний ответ 07 Дек 2016, 09:17
от alex0402
Как создать в 1С 8.2 группы контроагентов когда при ножатие папочки с плюсом выходит ошибка при устоновке значения атрибута текста (ОсновнойМенеджерПокупателя)

Автор fat001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2622
Последний ответ 02 Апр 2014, 23:11
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Проверки по счетам учета

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
92 Сообщений
oleg-x
81 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений
Dethmontt Dethmontt
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal