Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Окт 2017, 04:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: не отображается реквизит на форме  (Прочитано 3470 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yamuna

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
ДОброго времени суток! Не отображается реквизит на форме. Конфигурация УправлениеТорговлей 11 демо, документ РеализацияТоваровУслуг на форме объекта в конфигураторе есть реквизит Автомобиль, а пользовательском режиме этот реквизит не отображается. Что надо сделать чтоб  реквизит отображался?


Оффлайн Rasty

  • *****
  • Сообщений: 979
  • РЕПУТАЦИЯ: 138
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
посмотрите его видимость в конец процедуры ПриОткрытии()
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Yamuna

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
посмотрите его видимость в конец процедуры ПриОткрытии()

Вот процедура модуля формы ПриОткрытии
&НаКлиенте
Процедура ПриОткрытии(Отказ)
   
   // МеханизмВнешнегоОборудования
   Если ИспользоватьПодключаемоеОборудование
      И МенеджерОборудованияКлиент.ОбновитьРабочееМестоКлиента() Тогда
      
      ОписаниеОшибки = "";
      
      ПоддерживаемыеТипыВО = Новый Массив();
      ПоддерживаемыеТипыВО.Добавить("СканерШтрихкода");
      
      Если Не МенеджерОборудованияКлиент.ПодключитьОборудованиеПоТипу(УникальныйИдентификатор, ПоддерживаемыеТипыВО, ОписаниеОшибки) Тогда
         ТекстСообщения = НСтр("ru = 'При подключении оборудования произошла ошибка:
                               |""%ОписаниеОшибки%"".'");
         ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%", ОписаниеОшибки);
         ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
      КонецЕсли;
      
   КонецЕсли;
   // Конец МеханизмВнешнегоОборудования
   
КонецПроцедуры // ПриОткрытии()

похоже здесь ничего нет...

Добавлено: 19 Апр 2016, 17:36

&НаКлиенте
Процедура ПриОткрытии(Отказ)

// МеханизмВнешнегоОборудования
Если ИспользоватьПодключаемоеОборудование
И МенеджерОборудованияКлиент.ОбновитьРабочееМестоКлиента() Тогда

ОписаниеОшибки = "";

ПоддерживаемыеТипыВО = Новый Массив();
ПоддерживаемыеТипыВО.Добавить("СканерШтрихкода");

Если Не МенеджерОборудованияКлиент.ПодключитьОборудованиеПоТипу(УникальныйИдентификатор, ПоддерживаемыеТипыВО, ОписаниеОшибки) Тогда
ТекстСообщения = НСтр("ru = 'При подключении оборудования произошла ошибка:
                      |""%ОписаниеОшибки%"".'");
ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%", ОписаниеОшибки);
ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
КонецЕсли;

КонецЕсли;
// Конец МеханизмВнешнегоОборудования

КонецПроцедуры // ПриОткрытии()
похоже так будет лучше

Оффлайн Rasty

  • *****
  • Сообщений: 979
  • РЕПУТАЦИЯ: 138
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а если открыть окно вычисления значений и написать Элементы.Автомобиль.Видимость
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Yamuna

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
а если открыть окно вычисления значений и написать Элементы.Автомобиль.Видимость
вы имели в виду вот это?
Элементы.Автомобиль.Видимость   Истина   Булево

Оффлайн Rasty

  • *****
  • Сообщений: 979
  • РЕПУТАЦИЯ: 138
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а он включен в какую нибудь группу включен?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Yamuna

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
а он включен в какую нибудь группу включен?
группа ТТН в конфигураторе формы объекта

Оффлайн Rasty

  • *****
  • Сообщений: 979
  • РЕПУТАЦИЯ: 138
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а у нее как с видимостью?

Добавлено: 19 Апр 2016, 18:29

ну и если еще есть родители, то и там посмотрите
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Yamuna

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
а у нее как с видимостью?

Добавлено: 19 Апр 2016, 18:29

ну и если еще есть родители, то и там посмотрите

Элементы.ГруппаТТН.Видимость   Истина   Булево
Элементы.ГруппаПечатьПраво.Видимость   Истина   Булево
Элементы.ГруппаПечать.Видимость   Истина   Булево

кажется все нормально..

но в пользовательском режиме группа ТТН не отображается

Оффлайн Kironten

  • *****
  • Сообщений: 873
  • РЕПУТАЦИЯ: 182
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
а у нее как с видимостью?

Добавлено: 19 Апр 2016, 18:29

ну и если еще есть родители, то и там посмотрите

Элементы.ГруппаТТН.Видимость   Истина   Булево
Элементы.ГруппаПечатьПраво.Видимость   Истина   Булево
Элементы.ГруппаПечать.Видимость   Истина   Булево

кажется все нормально..

но в пользовательском режиме группа ТТН не отображается
О, уже оказывается и сама группа не отображается, а не только входящий в неё реквизит.
Ищем дальше.


 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1632
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 141
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2199
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 170
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2620
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
86 Сообщений
alex0402
52 Сообщений
AIFrame
40 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
38 Сообщений
Oldman06
31 Сообщений
Golickoff Golickoff
30 Сообщений
vitasw
29 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
BuhRust
14 Сообщений
DmitriyF DmitriyF
13 Сообщений

* Кто онлайн

  • Точка Гостей: 212
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal