Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите новичку! Пожалуйста  (Прочитано 6502 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ted

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-30
  • Сайт: 
  • Профессия: Программист 8.1
Процедура ЗаполнитьТЧПриходныеКассовыеОрдера()

СписокСтатусов = Новый Массив;
    СписокСтатусов.Добавить(Перечисления.СтатусыОтгрузки.КОтгрузке);
Запрос =  Новый  Запрос;
Запрос.Текст =
       
                 "ВЫБРАТЬ
         |    КП_МаршрутныйЛистРеализацииТоваровУслуг.РеализацияТоваровУслуг КАК Реализация,
         |    КП_МаршрутныйЛистРеализацииТоваровУслуг.РеализацияТоваровУслуг.ЗаказКлиента КАК Заказ,
         |    КП_МаршрутныйЛистРеализацииТоваровУслуг.РеализацияТоваровУслуг.СуммаВзаиморасчетов КАК Сумма,
         |    КП_МаршрутныйЛистРеализацииТоваровУслуг.РеализацияТоваровУслуг.КП_СуммаВзаиморасчетовПоНеоплаченнымЗалогам КАК СуммаВзаиморасчетов
         |ИЗ
         |    Документ.КП_МаршрутныйЛист.РеализацииТоваровУслуг КАК КП_МаршрутныйЛистРеализацииТоваровУслуг
         |ГДЕ
         |    КП_МаршрутныйЛистРеализацииТоваровУслуг.Ссылка = &Ссылка
         |    И КП_МаршрутныйЛистРеализацииТоваровУслуг.РеализацияТоваровУслуг.ЗаказКлиента.Статус <> &СтатусОтгрузкиОтменен";
         
        Запрос.УстановитьПараметр("Ссылка",Объект.МаршрутныйЛист.Ссылка);
        Запрос.УстановитьПараметр("СтатусОтгрузкиОтменен", Перечисления.СтатусыЗаказовКлиентов.КП_Отменен);
        Выборка = Запрос.Выполнить().Выбрать();
       
        Пока Выборка.Следующий()  Цикл
           
           
           
           
НоваяСтрока = Объект.ПриходныеКассовыеОрдера.Добавить();

НоваяСтрока.Реализация=Выборка.Реализация;                     
НоваяСтрока.Заказ = Выборка.Заказ;

НоваяСтрока.СуммаВзаиморасчетов  = Выборка.Сумма;

  НоваяСтрока.СуммаВзаиморасчетовПоЗалогам          = Выборка.СуммаВзаиморасчетов;
 
КонецЦикла;

КонецПроцедуры

Но у меня вообще теперь ни чего не заполняет, при любом статусе


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Можно услышать внятный вопрос?

Оффлайн SupremeMax

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-26
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Я начинающий программист (всего месяц), работаю в версии 8.2, требуется ваша неоценимая помощь! Имеется ИЕРАРХИЧЕСКИЙ справочник "Сотрудники", состоящий из 2х групп: Работающие и Уволенные. Справочник состоит из 4х колонок: Код, Наименование(имеется ввиду ФИО сотрудника), Дата рождения, Процент премии. Мне необходимо выполнить отбор по Дате рождения, т.е. в соответствующих полях я назначаю интервал дат, в соответствии с которым при нажатии кнопки "Вывести" на печать будет выведен список сотрудников, чьи даты рождения входят в назначенный пользователем интервал. Для того, чтобы лучше понять мой вопрос, в прикрепленных файлах имеются картинки. Я вписывал следующий код:

Процедура ВывестиНажатие(Элемент)
    ТабДок = Новый ТабличныйДокумент;
    Макет = Справочники.Сотрудники.ПолучитьМакет("Печать");
    // Заголовок
    Область = Макет.ПолучитьОбласть("Заголовок");
    ТабДок.Вывести(Область);
    //Шапка
    Область = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(Область);
    ДатаРождения = СправочникСписок.Отбор.ДатаРождения;
     Если ДатаРождения.Использование = Истина Тогда
         СтруктураОтбора = Новый Структура("ДатаРождения", ДатаРождения.Значение);
         КонецЕсли;
        Выборка = Справочники.Сотрудники.ВыбратьИерархически(С,По1,"возр");
    Группа = Макет.ПолучитьОбласть("Группа");
    Элемент = Макет.ПолучитьОбласть("Элемент");
    Пока Выборка.Следующий()= Истина Цикл
        Если Выборка.ЭтоГруппа Тогда
        Область = Макет.ПолучитьОбласть("Группа");
    Группа.Параметры.Код = Выборка.Код;
    Группа.Параметры.Наименование = Выборка.Наименование;
   Группа.Параметры.ДатаРождения = Выборка.ДатаРождения;
   Группа.Параметры.ПроцентПремии = Выборка.ПроцентПремии;
   ТабДок.Вывести(Группа);
Иначе
    Область = Макет.ПолучитьОбласть("Элемент");
    Элемент.Параметры.Код = Выборка.Код;
    Элемент.Параметры.Наименование = Выборка.Наименование;
   Элемент.Параметры.ДатаРождения = Выборка.ДатаРождения;
   Элемент.Параметры.ПроцентПремии = Выборка.ПроцентПремии;
   ТабДок.Вывести(Элемент);
   КонецЕсли;

    КонецЦикла;

    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Истина;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать();

    КонецПроцедуры

При нажатии кнопки "Вывести" в режиме исполния мне выдается следующая ошибка:

{Справочник.Сотрудники.Форма.ФормаСписка.Форма(159)}: Ошибка при вызове метода контекста (ВыбратьИерархически): Несоответствие типов (параметр номер '1')
Выборка = Справочники.Сотрудники.ВыбратьИерархически(С,По1,"возр");
по причине:
Несоответствие типов (параметр номер '1')

Подскажите, пожалуйста, что я делаю непарвильно?

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Как я понимаю ошибка в первом параметре "С". Вы его как то определили? ctrl+shift+F1 есть отличная справка с описанием методов.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Вот здесь ваще не понятно:
"Выборка = Справочники.Сотрудники.ВыбратьИерархически(С,По1,"возр");"

Первый параметр - родитель
Второй - владелец
Их вам задавать по идее не надо, то есть как минимум должно быть:
"Выборка = Справочники.Сотрудники.ВыбратьИерархически( , ,"возр");"
Далее.
Третий параметр - отбор. И уж не как не "возр", а например Ваша вышеупомятнутая СтруктураОтбора. То есть наверное так:
"Выборка = Справочники.Сотрудники.ВыбратьИерархически( , , СтруктураОтбора,"возр");"
Далее.
Последний параметр - порядок. Не просто "возр", а имя реквизита. По возрастанию и так по умолчанию сортирует. То есть окончательно примерно так:
"Выборка = Справочники.Сотрудники.ВыбратьИерархически( , , СтруктураОтбора,"Наименование");"

А вообще... Лучше все это выбрать запросом. Например таким:
ВЫБРАТЬ
   ФизическиеЛица.Ссылка,
   ФизическиеЛица.Представление КАК Представление
ИЗ
   Справочник.ФизическиеЛица КАК ФизическиеЛица
ГДЕ
   ФизическиеЛица.ДатаРождения МЕЖДУ &ДатаНач И &ДатаКон

УПОРЯДОЧИТЬ ПО
   ФизическиеЛица.Наименование

СтОит еще учесть 8.2... Могут быть свои заморочки.
Запрос писал на 8.1
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Dmitry_vl_b

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-01
  • Сайт: 
  • Профессия: Ученик 1С
Парни, вопрос может быть лузерский, но тем не менее:
Я создал иерархический справочник(Товар) с реквизитами и табличной частью.
Вопрос в том КАК заполняется табличная часть справочника?

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Зависит от того, что должно быть в этой табличной части и из каких данных ее заполнять :)
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Dmitry_vl_b

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-01
  • Сайт: 
  • Профессия: Ученик 1С
Ну в конфигураторе я сделал перечисления, а в свойствах табличных частей сделал ссылки на эти перечисления, но это неважно. Я не могу понять где открывается окошко для заполнения табличной части справочника )

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Парни, вопрос может быть лузерский, но тем не менее:
Я создал иерархический справочник(Товар) с реквизитами и табличной частью.
Вопрос в том КАК заполняется табличная часть справочника?

Если заполнять должен пользователь визуально, то в форме элемента справочника. Или вам программно нужно?

Оффлайн Dmitry_vl_b

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-01
  • Сайт: 
  • Профессия: Ученик 1С
Нет, не программно! А Что значит форма элемента? Это где :-?


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4293
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5891
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4373
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 279
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal