Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2017, 17:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя печатная форма зависает на сборе данных  (Прочитано 514 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vanek516

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-28
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день,

Есть внешняя печатная форма, генерирующая word-файл, на локальной копи базы формирование doc файла происходит за 7-10 сек, на рабочей зависает. Пробовал с той же версией Office, то же самое. В чем может быть проблема, куда копать?

Заранее спасибо.


Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 40
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Как происходит обращение к word файлу? Через COMОбъект или посредством макета?
Если через COMОбъект, то у пользователей может не быть прав доступа для его создания на сервере.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн vanek516

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-28
  • Сайт: 
  • Профессия: Ученик 1С
Как происходит обращение к word файлу? Через COMОбъект или посредством макета?
Если через COMОбъект, то у пользователей может не быть прав доступа для его создания на сервере.

Я думаю что через макет, т.к шаблон зашит в обработке. Я уже частично нашел проблему, очень нездоровый код был, сейчас пытаюсь отладить
Не могу найти темы кто сталкивался с похожей проблемой, можете помочь?

Функция ПоискИЗаменаВВорде(ОбъектВорд,знач ТекстПоиска = "",знач ТекстЗамены = "",ЗаменитьВсе = Истина)

ДляВозврата = Истина;

ТекстЗамены = Строка(ТекстЗамены);
ТекстПоиска = Строка(ТекстПоиска);

ОбъектВорд.Selection.Collapse();
ОбъектВорд.Selection.Find.Forward = True;
ОбъектВорд.Selection.Find.Text = ТекстПоиска;
ОбъектВорд.Selection.Find.Replacement.Text = ТекстЗамены;
ОбъектВорд.Selection.Find.Execute(, , , , , , , , , , 00000002);
// http://infostart.ru/public/364753/


Возврат ДляВозврата;
КонецФункции



Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Это вы привели уже исправленный код или до вашего исправления?

Оффлайн vanek516

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-28
  • Сайт: 
  • Профессия: Ученик 1С
Это вы привели уже исправленный код или до вашего исправления?

После исправления
Добавлено: 13 Апр 2016, 14:52

Это вы привели уже исправленный код или до вашего исправления?

Сама печать и выше функция замены,
Выдает Поле объекта не обнаружено (Selection)

Функция Печать() Экспорт

Попытка

Договор = ПолучитьМакет(ОпределитьМакетДоговора());
ОбъектWord = Договор.Получить();
ДокументWord = ОбъектWord.Application.Documents(1);
ДокументWord.Activate();
Исключение
Сообщить(ОписаниеОшибки(),СтатусСообщения.ОченьВажное);
Возврат Неопределено;
КонецПопытки;


СоздатьИЗаполнитьТЗподстановок();


Для Каждого Стр ИЗ ТЗп Цикл
ПоискИЗаменаВВорде(ДокументWord,Стр.Шаблон,Стр.СтрокаЗамены);
КонецЦикла;

ОбъектWord.Application.Visible=Истина;
ОбъектWord.Activate();

Возврат Неопределено;

КонецФункции

Последний раз редактировалось: vanek516; 13 Апр 2016, 14:52. Причина: Объединение сообщений


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5071
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2136
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 52
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 2777
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3771
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
155 Сообщений
alex0402
80 Сообщений
alexandr_ll
37 Сообщений
LexaK
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
crow1983
27 Сообщений
sertak sertak
22 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
15 Сообщений
Vzonder
14 Сообщений

* Кто онлайн

  • Точка Гостей: 663
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal