Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Мар 2017, 17:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Розница 2.2.2.15 запрет редактирования  (Прочитано 628 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ArCtic

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 1
  • КПД: 14%
  • Регистрация: 2011-10-31
  • Сайт: 
  • Профессия: Программист 7.7
Здравствуйте! В Розница 2.2.2.15 нужно пользователю сделать права, только на создание документа, без права редактирования. В рознице 1.0 создавал право и в модуле документа ПриОткрытии() писал:
Если РольДоступна("ТолькоСоздание") Тогда
ЭтаФорма.ТолькоПросмотр = Истина;
КонецЕсли;
а в 8.3 версии платформы Розница 2.2.2.15 пишет ошибку,
Цитировать
{Документ.ПоступлениеТоваров.Форма.ФормаДокумента.Форма(403,7)}: Процедура или функция с указанным именем не определена (РольДоступна)
Если <<?>>РольДоступна("ТолькоСоздание") Тогда (Проверка: Тонкий клиент)
подскажите в какую сторону копать?


Оффлайн ArCtic

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 1
  • КПД: 14%
  • Регистрация: 2011-10-31
  • Сайт: 
  • Профессия: Программист 7.7
Классный, мертвый форум!
PS на инфостарте дали ответ, напишу и сюда:
&НаСервере
Функция ПроверитьРольДоступнаСервер(НаименованиеРоли)
    Возврат РольДоступна(НаименованиеРоли);
КонецФункции

Процедура ПриОткрытии()
    ЭтаФорма.ТолькоПросмотр = ПроверитьРольДоступнаСервер("ТолькоСоздание");
КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
alex0402
115 Сообщений
Norfolk
51 Сообщений
LexaK
45 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
друган
21 Сообщений
alexandr_ll
20 Сообщений
AsadRoman
20 Сообщений
Константин5825
18 Сообщений
Alex55
18 Сообщений

* Кто онлайн

  • Точка Гостей: 292
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal