Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Сен 2017, 00:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Групповое редактирование в табличной части  (Прочитано 1098 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Добрый день. Уважаемые форумчане. Возможно ли в 1С групповое редактирование в табличной части документа, например пользователь выделил через ctpl или shift несколько строк, и одновременно поменял статус выделенных строк (в моем примере в колонке (Утвердить-Тип перечисление) поменять статус на утвердить). Руководство ленится редактировать каждую строку в отдельности.


Оффлайн LexaK

  • *****
  • Сообщений: 1254
  • РЕПУТАЦИЯ: 345
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
да конечно так можно сделать
1.Проверьте/установите в табличной части формы возможность МножественныйВыбор
2.Создайте кнопку/команду УстановитьЗначение. поместите рядом с табличной частью.
в обработке
запросите нужное значение у пользователя 
процедурой ПоказатьВводЗначения
далее получаете список отмеченных строк, пример
Элементы.Товары.ВыделенныеСтроки
и устанавливаете в нужную колонку указанное пользователем значение

Порядок работы на клиенте
пользователь выделяет мышкой нужные строки,
нажимает кнопку УстановитьЗначение, в возникшем поле вводит значение (в вашем примере новый статус) нажимает ОК

ваша обработка делает что описано выше! пользователи, особенно руководство - довольны!!!  :zebzdr:
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С

далее получаете список отмеченных строк, пример
Элементы.Товары.ВыделенныеСтроки
и устанавливаете в нужную колонку указанное пользователем значение
  :zebzdr:

Не получается обратиться именно к колонке утвердить.
То есть я получаю массив выделенных строчей ТЧ.
УтвердитьПлатежи=Элементы.Реестр.ВыделенныеСтроки;
Для каждого Значения из УтвердитьПлатежи  цикл
Значения.Утвердить=Оплатить()
КонецЦикла;

Выдает ошибку
{Документ.РеестрНаОплату.Форма.ФормаДокумента.Форма(62)}: Значение не является значением объектного типа (Утвердить)  =Значения.Утвердить=Оплатить()




Оффлайн Kironten

  • *****
  • Сообщений: 867
  • РЕПУТАЦИЯ: 181
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Ну возможно потому, что ВыделенныеСтроки для управляемого приложения получает массив ИДЕНТИФИКАТОРОВ строк ТЧ, а не строк ТЧ как в обычном приложении.

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Проблему решил, всем спасибо.

&НаКлиенте
Процедура Утвердить(Команда)
   ПараметрыФормы= Новый Структура("ЗакрыватьПриВыборе",Истина);
ОткрытьФорму("Перечисление.Утвердить.ФормаВыбора",ПараметрыФормы,Элементы.Реестр)

КонецПроцедуры

&НаКлиенте
Процедура РеестрОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
   Строки=Элементы.Реестр.ВыделенныеСтроки;
   Для каждого ВыдЗнач из Строки цикл   
   СтрокаТабличнойЧасти = Объект.Реестр.НайтиПоИдентификатору(ВыдЗнач);
   СтрокаТабличнойЧасти.Утвердить = ВыбранноеЗначение;
   КонецЦикла;

КонецПроцедуры


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1733
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2905
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2910
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 605
Последний ответ 23 Июн 2015, 14:25
от news
отчет с анализом данных таб.части и документа + сумма.Расходы из Остатки.Обороты

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 205
Последний ответ 18 Май 2017, 19:12
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
135 Сообщений
alex0402
79 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
78 Сообщений
BuhRust
26 Сообщений
AIFrame
24 Сообщений
Golickoff Golickoff
22 Сообщений
ilyay ilyay
21 Сообщений
Варвар
20 Сообщений
Kironten
19 Сообщений
Римма
18 Сообщений

* Кто онлайн

  • Точка Гостей: 272
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal