Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Ноя 2017, 22:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: как повторно открыть модальное окно?  (Прочитано 877 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн т87

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-05
  • Сайт: 
процедура ПоискПоШтрихкоду открывает модальное окно.
Можно ли сделать так, чтобы при нажатии на кнопку "Ок" модального окна, данное окно не закрывалось, а дальше запрашивала ввод значений пользователя. Платформа 8.3.

Процедура ПоискПоШтрихкоду(Команда)

ТекШтрихкод = "";
ПоказатьВводЗначения(Новый ОписаниеОповещения("ПоискПоШтрихкодуЗавершение", ЭтотОбъект, Новый Структура("ТекШтрихкод", ТекШтрихкод)), ТекШтрихкод, НСтр("ru = 'Введите штрихкод'"));

КонецПроцедуры

&НаКлиенте
Процедура ПоискПоШтрихкодуЗавершение(Результат, ДополнительныеПараметры) Экспорт
   
    ТекШтрихкод = ?(Результат = Неопределено, ДополнительныеПараметры.ТекШтрихкод, Результат);
   
   
    Если НЕ ПустаяСтрока(ТекШтрихкод) Тогда
        Сообщить ...;
    КонецЕсли;

КонецПроцедуры


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Ээээээ, в чем смысл?

Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
используйте рекурсию, делов то
Ээээээ, в чем смысл?
а это сакральный смысл, который нам не понять
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн т87

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-05
  • Сайт: 
используйте рекурсию, делов то

Надо, чтобы только если жмем на "Ок" окошко оставалось, а при нажатии на "Отмена" закрывалась. Если использовать рекурсию, то модальное окно вообще не закроется.


Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Тогда создайте общую форму и открывайте её модально
Добавлено: 05 Апр 2016, 12:00

а ваш поиск по штрихкоду можно(даже нужно) сделать с помощью внешней компоненты
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн LexaK

  • *****
  • Сообщений: 1265
  • РЕПУТАЦИЯ: 345
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
конечно можно, не понятно правда зачем....
&НаКлиенте
Процедура ПоискПоШтрихкоду(Команда)
   
    ПоискПоШтрихкодуЗавершение("", "");

КонецПроцедуры

&НаКлиенте
Процедура ПоискПоШтрихкодуЗавершение(Результат, ДополнительныеПараметры) Экспорт

    если Результат = Неопределено Тогда
          //пользователь отказался от ввода, выходим
          Возврат;
    конецесли;
    ТекШтрихкод = Результат;
    лкОписание = Новый ОписаниеОповещения("ПоискПоШтрихкодуЗавершение", ЭтотОбъект, ТекШтрихкод);
    ПоказатьВводЗначения(лкОписание, ТекШтрихкод, НСтр("ru = 'Введите штрихкод'"));

    Если НЕ ПустаяСтрока(ТекШтрихкод) Тогда
        Сообщить (ТекШтрихкод);
    КонецЕсли;

КонецПроцедуры


B) кажется так должно сработать, будет запрашивать значение пока Отмена не нажмете,
правда код не оптимальный, для теста сойдет.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Надо, чтобы только если жмем на "Ок" окошко оставалось, а при нажатии на "Отмена" закрывалась. Если использовать рекурсию, то модальное окно вообще не закроется.

То что вам хочется, было понятно и из первого поста. Я еще раз настойчиво спрашиваю: в чем смысл сего действа?
Открытое модально окно используется только для ввода данных вся полезная деятельность выполняется после закрытия окна. Вы же окно закрывать не хотите, соответственно никаких полезных действий выполнено не будет. Так в чем смысл-то?

Оффлайн т87

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-05
  • Сайт: 
То что вам хочется, было понятно и из первого поста. Я еще раз настойчиво спрашиваю: в чем смысл сего действа?
Открытое модально окно используется только для ввода данных вся полезная деятельность выполняется после закрытия окна. Вы же окно закрывать не хотите, соответственно никаких полезных действий выполнено не будет. Так в чем смысл-то?

Смысл в том, что пользователю лень постоянно нажимать на эту кнопку, когда приходиться сканировать штрихкоды номенклатуры. Ему надо, чтобы один раз открыв окошко, он, держа сканер в одной руке, а другую руку положив на кнопку "Enter" выполнял данные манипуляции. Горячие клавиши тоже не устраивают. А все полезные действия выболняются в методе ПолученыШтрихкоды.

...
 Если НЕ ПустаяСтрока(ТекШтрихкод) Тогда
        ПолученыШтрихкоды(Новый Структура("Штрихкод, Количество", ТекШтрихкод, 1));
    КонецЕсли;
...
Добавлено: 05 Апр 2016, 13:19


B) кажется так должно сработать, будет запрашивать значение пока Отмена не нажмете,
правда код не оптимальный, для теста сойдет.

Работает, благодарю!


Теги:
 

Программно открыть отчет скд и отчет подключенный как внешний отчет

Автор 1ckaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3857
Последний ответ 02 Фев 2015, 10:06
от 1cka
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 18768
Последний ответ 10 Ноя 2010, 14:08
от Lexius
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2709
Последний ответ 13 Июн 2017, 12:17
от Whisper
При попытке открыть справочник "Сотрудники" выскакивает сообщение об ошибке

Автор ЭлиРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4009
Последний ответ 16 Июл 2014, 19:28
от MuI_I_Ika
Рекомендуется открыть новый субсчет к счету «Основные средства» для расчета имущественного налога

Автор newsРаздел Новости

Ответов: 0
Просмотров: 2071
Последний ответ 19 Янв 2015, 16:15
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
MuI_I_Ika MuI_I_Ika
96 Сообщений
oleg-x
71 Сообщений
alex0402
61 Сообщений
ilyay ilyay
51 Сообщений
Dmitry Qwe Dmitry Qwe
32 Сообщений
Sy4a
22 Сообщений
Dima Dddd Dima Dddd
21 Сообщений
BuhRust
21 Сообщений
Kironten
12 Сообщений

* Кто онлайн

  • Точка Гостей: 244
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal