Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2017, 05:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Программирование отчета "Движения на складах"  (Прочитано 1736 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лунатик

  • *
  • Сообщений: 0
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-05
  • Сайт: 
Создал Процедурку, выходят ошибки, что приход и расход неопределено, помогите плиз
Запрос вроде верный в консоле провял
П.С. я новичок

Процедура Печать(ТабДок) Экспорт
   
   ТабДок.Очистить();
   
   Запрос = Новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
                  |   Номенклатура.Ссылка
                  |ПОМЕСТИТЬ Товары
                  |ИЗ
                  |   Справочник.Номенклатура КАК Номенклатура
                  |ГДЕ
                  |   Номенклатура.Ссылка В ИЕРАРХИИ(&ВыбНоменклатура)
                  |;
                  |
                  |////////////////////////////////////////////////////////////////////////////////
                  |ВЫБРАТЬ
                  |   ЦеныСрезПоследних.Номенклатура,
                  |   ЦеныСрезПоследних.Цена
                  |ПОМЕСТИТЬ Цены
                  |ИЗ
                  |   РегистрСведений.Цены.СрезПоследних(
                  |         &ДатаЦен,
                  |         ТипЦены = &ТипЦены
                  |            И Номенклатура В
                  |               (ВЫБРАТЬ
                  |                  Товары.Ссылка
                  |               ИЗ
                  |                  Товары КАК Товары)) КАК ЦеныСрезПоследних
                  |;
                  |
                  |////////////////////////////////////////////////////////////////////////////////
                  |ВЫБРАТЬ
                  |   Товары.Ссылка КАК Номенклатура,
                  |   Цены.Цена КАК Цена
                  |ПОМЕСТИТЬ ТоварыИЦены
                  |ИЗ
                  |   Товары КАК Товары
                  |      ЛЕВОЕ СОЕДИНЕНИЕ Цены КАК Цены
                  |      ПО Товары.Ссылка = Цены.Номенклатура
                  |;
                  |
                  |////////////////////////////////////////////////////////////////////////////////
                  |ВЫБРАТЬ
                  |   ОстаткиНаСкладахОстаткиИОбороты.Склад,
                  |   ОстаткиНаСкладахОстаткиИОбороты.Номенклатура,
                  |   ОстаткиНаСкладахОстаткиИОбороты.КоличествоНачальныйОстаток,
                  |   ОстаткиНаСкладахОстаткиИОбороты.КоличествоКонечныйОстаток,
                  |   ОстаткиНаСкладахОстаткиИОбороты.КоличествоПриход,
                  |   ОстаткиНаСкладахОстаткиИОбороты.КоличествоРасход
                  |ПОМЕСТИТЬ Остатки
                  |ИЗ
                  |   РегистрНакопления.ОстаткиНаСкладах.ОстаткиИОбороты(
                  |         &ДатаНачало,
                  |         &ДатаКонец,
                  |         ,
                  |         ,
                  |         Склад = &Склад
                  |            И Номенклатура В
                  |               (ВЫБРАТЬ
                  |                  Товары.Ссылка
                  |               ИЗ
                  |                  Товары КАК Товары)) КАК ОстаткиНаСкладахОстаткиИОбороты
                  |;
                  |
                  |////////////////////////////////////////////////////////////////////////////////
                  |ВЫБРАТЬ
                  |   ТоварыИЦены.Номенклатура КАК Номенклатура,
                  |   ТоварыИЦены.Цена КАК Цена,
                  |   Остатки.КоличествоНачальныйОстаток КАК КоличествоНачальныйОстаток,
                  |   Остатки.КоличествоКонечныйОстаток КАК КоличествоКонечныйОстаток,
                  |   Остатки.КоличествоПриход КАК КоличествоПриход,
                  |   Остатки.КоличествоРасход КАК КоличествоРасход
                  |ИЗ
                  |   ТоварыИЦены КАК ТоварыИЦены
                  |      ЛЕВОЕ СОЕДИНЕНИЕ Остатки КАК Остатки
                  |      ПО ТоварыИЦены.Номенклатура = Остатки.Номенклатура";
   
   
   Запрос.УстановитьПараметр("ВыбНоменклатура",ВыбНоменклатура );
   Запрос.УстановитьПараметр("ДатаЦен",КонецДня(ДатаЦен) );
   Запрос.УстановитьПараметр("ТипЦены",ТипЦены );
   Запрос.УстановитьПараметр("ДатаНачало",ДатаНачало) ;
   Запрос.УстановитьПараметр("ДатаКонец",ДатаКонец) ;
   Запрос.УстановитьПараметр("Склад",Склад) ;
   
      
   Результат = Запрос.Выполнить();
   Выборка = Результат.Выбрать();

   
   //{{_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ(Печать1)
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   //ТабДок = Новый ТабличныйДокумент;
   Макет = Обработки.Прайс.ПолучитьМакет("Печать");
   // Заголовок
   Область = Макет.ПолучитьОбласть("Заголовок");
   Область.Параметры.Дата=ДатаЦен;
   ТабДок.Вывести(Область);
   // Шапка
   Шапка = Макет.ПолучитьОбласть("Шапка");
   Шапка.Параметры.Заполнить(ЭтотОбъект);
   ТабДок.Вывести(Шапка);
   // Товары
   Область = Макет.ПолучитьОбласть("ТоварыШапка");
   ТабДок.Вывести(Область);

   //Если ВыводитьОстатки Тогда
   //   ОбластьОстаткиШапка=Макет.ПолучитьОбласть("ТоварыШапка|Остатки");
   //   ТабДок.Присоединить(ОбластьОстаткиШапка);
   //   
   //КонецЕсли;
   
   НомерСтроки=0;
   
   НомерСтроки=0;
   
   Пока Выборка.Следующий() Цикл
      НомерСтроки=НомерСтроки+1;
      ОбластьТовары = Макет.ПолучитьОбласть("Товары");
      ОбластьТовары.Параметры.Номенклатура=Выборка.Номенклатура;
      ОбластьТовары.Параметры.Цена=Выборка.Цена;
      ОбластьТовары.Параметры.НомерСтроки=НомерСтроки;
      ОбластьТовары.Параметры.КоличествоПриход=Выборка.КоличествоРасход;
      ОбластьТовары.Параметры.КоличествоПриход=Выборка.КоличествоПриход;
      ОбластьТовары.Параметры.НомерСтроки=НомерСтроки;
      ОбластьТовары.Параметры.КоличествоНачальныйОстаток= Выборка.КоличествоНачальныйОстаток;
      ОбластьТовары.Параметры.КоличествоКонечныйОстаток= Выборка.КоличествоКонечныйОстаток;
            
      ТабДок.Вывести(ОбластьТовары);


      
      
      
   КонецЦикла;
   
   Подвал = Макет.ПолучитьОбласть("Подвал");
   Подвал.Параметры.Заполнить(ЭтотОбъект);
   ТабДок.Вывести(Подвал);
   
   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Истина;
   ТабДок.ТолькоПросмотр = Истина;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ
   
КонецПроцедуры


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
что приход и расход неопределено

Полный текст ошибки пожалуйста. Слов "приход" и "расход" в тексте вашей процедуры нет.


Теги:
 

Исправила в форме авансового отчета и теперь выдает ошибки при открытии авансового док-та

Автор komarova ninaРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1847
Последний ответ 02 Мар 2015, 11:39
от komarova nina
Как перенести возврат товаров из Розницы в Бухгалтерию? При обмене данных из Отчета о розничных продажах не отражается на 50 и 41 счетах

Автор Natalya77-09Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2448
Последний ответ 19 Фев 2014, 00:27
от Natalya77-09
Создание отбора отдельным элементом на форме внешнего отчета через настройки скд без программирования.

Автор MeatCrashРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 372
Последний ответ 14 Янв 2017, 10:14
от MeatCrash
Как зафиксировать колонки таблицы результатов стандартного отчета с помощью внешней обработки?

Автор alexey980Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 761
Последний ответ 10 Апр 2016, 13:25
от alexey980
как в макете отчета сделать, чтоб можно было переходить по выводимым ссылкам

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 720
Последний ответ 20 Апр 2016, 13:31
от ktu78

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
96 Сообщений
Dethmontt Dethmontt
71 Сообщений
alex0402
63 Сообщений
MuI_I_Ika MuI_I_Ika
61 Сообщений
wise wise
50 Сообщений
ilyay ilyay
39 Сообщений
Сергей Федоров Сергей Федоров
36 Сообщений
BuhRust
21 Сообщений
ilnur75
21 Сообщений
magnifico61
20 Сообщений

* Кто онлайн

  • Точка Гостей: 276
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal