Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Апр 2018, 03:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удаление первых 5 строк Таблицы значений  (Прочитано 680 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ktu78

  • ***
  • Сообщений: 153
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С
Сформировал ТЗ - таблицу значений


        ТЗ=ЗагрузитьТЗизФайла(ИмяФайлаНоменклатуры);

Далее мне нужно удалить первые 5 строчек ТЗ
     
    Для Инд=0 По 4 Цикл
        ТЗ.Удалить(Инд);       
    КонецЦикла;

алгоритм удаляет только первые 3
Подскажите пожалуйста. Хорошего дня


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
алгоритм удаляет только первые 3

неправда, удаляет 5, только не по порядку. Слышали выражение " не пили сук на котором сидишь" - это как раз такой вариант.
Наиболее простой для понимания вариант:
ТЗ2=ТЗ.Скопировать();
ТЗ2.Очистить();
Для инд=5 По ТЗ.Количество()-1 Цикл
    НовСтрока=ТЗ2.Добавить();
    ЗаполнитьЗначенияСвойств(НовСтрока,ТЗ[инд]);   
КонецЦикла;

Оффлайн Luzer1C

  • ****
  • Сообщений: 452
  • РЕПУТАЦИЯ: 54
  • КПД: 12%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Для лузеров, чтобы было понятно.

ТЗ.Удалить(0);
ТЗ.Удалить(0);
ТЗ.Удалить(0);
ТЗ.Удалить(0);
ТЗ.Удалить(0);
Халамбалам.

Оффлайн LexaK

  • *****
  • Сообщений: 1291
  • РЕПУТАЦИЯ: 354
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
или
Для Инд=0 По 4 Цикл
    ТЗ.Удалить(0);       
КонецЦикла;
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 356
  • РЕПУТАЦИЯ: 68
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Компания: Центр бизнес решений "ALT"
  • Профессия: Разработчик 1С
P.S. Я бы в принципе пересмотрел задачу и реализацию. Ситуация когда надо что-то точечно удалять зная его расположения в масштабируемой системе не допустимо. Думаю что-то где-то не так пошло.
Если я Вам помог, нажми - Спасибо!

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
P.S. Я бы в принципе пересмотрел задачу и реализацию. Ситуация когда надо что-то точечно удалять зная его расположения в масштабируемой системе не допустимо. Думаю что-то где-то не так пошло.

+1


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 578
Последний ответ 20 Мар 2018, 16:54
от alex0402
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1226
Последний ответ 15 Июн 2017, 07:53
от mvk843
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5327
Последний ответ 24 Ноя 2015, 15:38
от welldone
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 22522
Последний ответ 13 Фев 2011, 17:36
от proofet
Почему реквизит типа "список значений" может оказаться недоступным для изменения

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6552
Последний ответ 28 Июл 2011, 23:55
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
183 Сообщений
alex0402
71 Сообщений
AIFrame AIFrame
66 Сообщений
oleg-x
42 Сообщений
alexandr_ll
40 Сообщений
pavl_vs
22 Сообщений
BuhRust
21 Сообщений
KOI8-R
17 Сообщений
wise wise
13 Сообщений
Sheriff
13 Сообщений

* Кто онлайн

  • Точка Гостей: 149
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal