Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Янв 2017, 08:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удаление первых 5 строк Таблицы значений  (Прочитано 405 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ktu78

  • ***
  • Сообщений: 151
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-08-21
  • Сайт: 
  • Профессия: Программист 1С
Сформировал ТЗ - таблицу значений


        ТЗ=ЗагрузитьТЗизФайла(ИмяФайлаНоменклатуры);

Далее мне нужно удалить первые 5 строчек ТЗ
     
    Для Инд=0 По 4 Цикл
        ТЗ.Удалить(Инд);       
    КонецЦикла;

алгоритм удаляет только первые 3
Подскажите пожалуйста. Хорошего дня

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
алгоритм удаляет только первые 3

неправда, удаляет 5, только не по порядку. Слышали выражение " не пили сук на котором сидишь" - это как раз такой вариант.
Наиболее простой для понимания вариант:
ТЗ2=ТЗ.Скопировать();
ТЗ2.Очистить();
Для инд=5 По ТЗ.Количество()-1 Цикл
    НовСтрока=ТЗ2.Добавить();
    ЗаполнитьЗначенияСвойств(НовСтрока,ТЗ[инд]);   
КонецЦикла;

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 40
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Для лузеров, чтобы было понятно.

ТЗ.Удалить(0);
ТЗ.Удалить(0);
ТЗ.Удалить(0);
ТЗ.Удалить(0);
ТЗ.Удалить(0);
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн LexaK

  • *****
  • Сообщений: 1084
  • РЕПУТАЦИЯ: 285
  • КПД: 26%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
или
Для Инд=0 По 4 Цикл
    ТЗ.Удалить(0);       
КонецЦикла;
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Vladimir_Sh

  • 1С:Специалист
  • ****
  • Сообщений: 348
  • РЕПУТАЦИЯ: 65
  • КПД: 19%
  • Регистрация: 2015-10-16
  • Сайт: 
  • Профессия: Разработчик 1С
P.S. Я бы в принципе пересмотрел задачу и реализацию. Ситуация когда надо что-то точечно удалять зная его расположения в масштабируемой системе не допустимо. Думаю что-то где-то не так пошло.
Если я Вам помог, нажми - Спасибо!

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
P.S. Я бы в принципе пересмотрел задачу и реализацию. Ситуация когда надо что-то точечно удалять зная его расположения в масштабируемой системе не допустимо. Думаю что-то где-то не так пошло.

+1


Теги:
 

Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2335
Последний ответ 24 Ноя 2015, 15:38
от welldone
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 15988
Последний ответ 13 Фев 2011, 17:36
от proofet
Почему реквизит типа "список значений" может оказаться недоступным для изменения

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5024
Последний ответ 28 Июл 2011, 23:55
от Dethmontt
Обход дерева значений на клиенте / развернуть многоуровневое дерево на клиенте

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3869
Последний ответ 01 Ноя 2015, 10:07
от Азиман
Вывод набора данных "объединение" скд в дерево значений

Автор Gae4kaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1081
Последний ответ 02 Июн 2015, 12:19
от Gae4ka

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
alex0402
56 Сообщений
MuI_I_Ika MuI_I_Ika
49 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
28 Сообщений
sertak sertak
25 Сообщений
Vzonder
21 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
17 Сообщений

* Кто онлайн

  • Точка Гостей: 467
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal