Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Янв 2017, 13:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не работает поиск файлов  (Прочитано 481 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн retker64

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-04
  • Сайт: 
  • Профессия: Ученик 1С
Доброго дня.
Возникла такая проблема:
Не получается увидеть файлы, расположенные на другом компьютере в сети его адрес 192.168.0.1
1С клиент-серверная. Служба на сервере запускается от доменного пользователя, он входит в группу которой разрешен полный доступ к папкам на компьютере 192.168.0.1. Ошибки ни какой не выводит.
версия 1С 8.3.7.1790.
При этом на локальной машине файлы нормально находятся.
Смотрел описание НайтиФайлы, там указано, что если компьютер в локальной сети и фтп, то нужно использовать прямые слеши,
т.е. как я понял не  "\\192.168.0.1\Test\", а "//192.168.0.1/Test/", но и так и так не работает.
Подскажите, что еще посмотреть...
Привожу код:

&НаКлиенте
Процедура Пуск(Команда)
ПускНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПускНаСервере()
НайтиФайлыВИерархии("//192.168.0.1/Test/","*.txt");
КонецПроцедуры


&НаСервере
Функция НайтиФайлыВИерархии(Путь, Маска) Экспорт

НайденныеКаталоги = НайтиФайлы(Путь, "*");
МассивРезультатов = Новый Массив;

Для каждого НайденныйФайл Из НайденныеКаталоги Цикл
Если НайденныйФайл.ЭтоКаталог() Тогда
МассивРезультатов.Добавить(НайтиФайлыВИерархии(НайденныйФайл.ПолноеИмя, Маска));
КонецЕсли;
КонецЦикла;

МассивРезультатов.Добавить(НайтиФайлы(Путь, Маска));

Результат = Новый Массив;

Для Каждого ЭлементРезультат Из МассивРезультатов Цикл
Для Каждого Файл Из ЭлементРезультат Цикл
Результат.Добавить(Файл);
КонецЦикла;
КонецЦикла;

Возврат Результат;
КонецФункции 

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а комп, с которого выполняется код видит папку?
а запускаете 1с с правами админа?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн retker64

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-04
  • Сайт: 
  • Профессия: Ученик 1С
а комп, с которого выполняется код видит папку?
а запускаете 1с с правами админа?
Комп видит.
Попробовал запустить 1С от администратора. Хотя сама учетка админская, и все получилось. Вот интересно а когда у меня будет запускаться фоновое задание для загрузки файлов, там же никакой ярлык не запускается.
Спасибо!

Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
просто дайте побольше прав на папку и будет вам счастье
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
76 Сообщений
alexandr_ll
38 Сообщений
LexaK
34 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
crow1983
31 Сообщений
sertak sertak
26 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений
Vzonder
17 Сообщений

* Кто онлайн

  • Точка Гостей: 860
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal