Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 22:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не работает поиск файлов  (Прочитано 754 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн retker64

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-04
  • Сайт: 
  • Профессия: Ученик 1С
Доброго дня.
Возникла такая проблема:
Не получается увидеть файлы, расположенные на другом компьютере в сети его адрес 192.168.0.1
1С клиент-серверная. Служба на сервере запускается от доменного пользователя, он входит в группу которой разрешен полный доступ к папкам на компьютере 192.168.0.1. Ошибки ни какой не выводит.
версия 1С 8.3.7.1790.
При этом на локальной машине файлы нормально находятся.
Смотрел описание НайтиФайлы, там указано, что если компьютер в локальной сети и фтп, то нужно использовать прямые слеши,
т.е. как я понял не  "\\192.168.0.1\Test\", а "//192.168.0.1/Test/", но и так и так не работает.
Подскажите, что еще посмотреть...
Привожу код:

&НаКлиенте
Процедура Пуск(Команда)
ПускНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПускНаСервере()
НайтиФайлыВИерархии("//192.168.0.1/Test/","*.txt");
КонецПроцедуры


&НаСервере
Функция НайтиФайлыВИерархии(Путь, Маска) Экспорт

НайденныеКаталоги = НайтиФайлы(Путь, "*");
МассивРезультатов = Новый Массив;

Для каждого НайденныйФайл Из НайденныеКаталоги Цикл
Если НайденныйФайл.ЭтоКаталог() Тогда
МассивРезультатов.Добавить(НайтиФайлыВИерархии(НайденныйФайл.ПолноеИмя, Маска));
КонецЕсли;
КонецЦикла;

МассивРезультатов.Добавить(НайтиФайлы(Путь, Маска));

Результат = Новый Массив;

Для Каждого ЭлементРезультат Из МассивРезультатов Цикл
Для Каждого Файл Из ЭлементРезультат Цикл
Результат.Добавить(Файл);
КонецЦикла;
КонецЦикла;

Возврат Результат;
КонецФункции 


Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
а комп, с которого выполняется код видит папку?
а запускаете 1с с правами админа?
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн retker64

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-04
  • Сайт: 
  • Профессия: Ученик 1С
а комп, с которого выполняется код видит папку?
а запускаете 1с с правами админа?
Комп видит.
Попробовал запустить 1С от администратора. Хотя сама учетка админская, и все получилось. Вот интересно а когда у меня будет запускаться фоновое задание для загрузки файлов, там же никакой ярлык не запускается.
Спасибо!

Оффлайн Rasty

  • *****
  • Сообщений: 989
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
просто дайте побольше прав на папку и будет вам счастье
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 301
Последний ответ 21 Сен 2017, 10:33
от Insider
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4106
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Дин.список отбор данных - не работает код при тех же данных

Автор Аля ТинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 129
Последний ответ 15 Дек 2017, 14:36
от alex0402
Не работает кнопка "установить интервал дат"

Автор depp_juniorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3695
Последний ответ 11 Июл 2014, 18:07
от LexaK
не работает отчет "Выработка сотрудника" в ЗУП2.5.35.3

Автор a_a2001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3772
Последний ответ 20 Июн 2011, 11:14
от Zvezo

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 271
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal