Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Мар 2017, 06:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печатная форма. Обращение к реквизиту по ссылке на объект  (Прочитано 2152 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AntonBlg

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-31
  • Сайт: 
  • Профессия: Программист 1С
Всем привет! Возникла задача заполнения макета печати документа по данным о студенте.

В реквизитах документа есть только ссылка на элемент справочника "Студенты":

Для получения имени студента я написал следующий код:
Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.Справки.ПолучитьМакет("МойМакет");

СсылкаНаДокумент = Документы.Справки.ПолучитьСсылку();
ИмяСтудента = СсылкаНаДокумент.Студент.Имя;

МояНоваяОбласть = Макет.ПолучитьОбласть("Область1");
МояНоваяОбласть.Параметры.ИмяПараметра = ИмяСтудента;
ТабДок.Вывести(МояНоваяОбласть);
КонецПроцедуры
В итоге, содержание реквизита "Имя" не извлекается по ссылке на объект "Студент":


Подскажите, пожалуйста, что я делаю не так?

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 40
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
    Макет = Документы.Справки.ПолучитьМакет("МойМакет");
   
    ИмяСтудента = Ссылка.Студент.Имя;
   
    МояНоваяОбласть = Макет.ПолучитьОбласть("Область1");
    МояНоваяОбласть.Параметры.ИмяПараметра = ИмяСтудента;
    ТабДок.Вывести(МояНоваяОбласть);
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн AntonBlg

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-31
  • Сайт: 
  • Профессия: Программист 1С
Предложенный вариант не работает:
ИмяСтудента = Ссылка.Студент.Имя;
Эта строка выдает ошибку: Поле объекта не обнаружено (Студент)

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 40
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
 ИмяСтудента = СсылкаНаДокумент.Студент.Наименование
?

Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 40
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
ИмяСтудента = СсылкаНаДокумент.Студент.Наименование
?
Тоже так думал, но смущает, что поле "Студент" не обнаружено.
По сути код ошибки говорит о том, что реквизита "Студент" в документе  нет.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн AntonBlg

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-31
  • Сайт: 
  • Профессия: Программист 1С
Попробовал все предложенные варианты и на 1С:Предприятие 8.2, на которой изначально всё делал, и на 8.3. Везде просто тишина, никаких ошибок не вылетает при выполнении кода, но и в параметр ничего не передается :(

Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
скиньте скрин с развернутом значением ссылка в отладчике
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн AntonBlg

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-31
  • Сайт: 
  • Профессия: Программист 1С
Походу, всё грустно даже начиная с ссылки на документ:

Добавлено: 02 Апр 2016, 04:38

Уже отчаялся и пытаюсь получить сам объект документа из модуля объекта:
Функция ПолучитьМойОбъект() Экспорт
Возврат ЭтотОбъект.Ссылка;
КонецФункции
А затем использовать полученный объект в модуле менеджера:
&НаСервере
Функция ПолучитьЭтотДокумент()
Возврат Документы.Справки.ПолучитьМойОбъект();
КонецФункции

Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)

Макет = Документы.Справки.ПолучитьМакет("МойМакет");
СсылкаНаДокумент = Ссылка;

Переменная1 = ПолучитьЭтотДокумент();

ИмяСтудента = СсылкаНаДокумент.Студент.Имя;
МояНоваяОбласть = Макет.ПолучитьОбласть("Область1");
МояНоваяОбласть.Параметры.ИмяПараметра = ИмяСтудента;
ТабДок.Вывести(МояНоваяОбласть);
КонецПроцедуры
Но, увы, ничего не выходит. Компилятор ошибок не выдаёт, а при отладке выбрасывает ошибку:

Последний раз редактировалось: AntonBlg; 02 Апр 2016, 04:38. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3160
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94
Как программно вызывать обработчик ПриИзменении поля табличной части после того, как форма была заполнена программно?

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2760
Последний ответ 27 Июл 2015, 06:21
от cska-fanat-kz
Шаблон или Форма для заполнения "заказа покупателя"

Автор SandrРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5386
Последний ответ 02 Сен 2013, 14:22
от LordWizard
Интерфейс "ТАКСИ". Управляемая форма как вкладка

Автор NikNivolopРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 2339
Последний ответ 22 Окт 2015, 08:39
от Luzer1C
УТ11 форма подбора товара - редактирование, Добавить колонку "Доступно"!

Автор MEWРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 10952
Последний ответ 25 Авг 2011, 12:34
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
143 Сообщений
alex0402
112 Сообщений
Norfolk
51 Сообщений
LexaK
45 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
друган
21 Сообщений
AsadRoman
20 Сообщений
alexandr_ll
19 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 85
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal