Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Апр 2018, 13:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печатная форма. Обращение к реквизиту по ссылке на объект  (Прочитано 3563 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AntonBlg

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-31
  • Сайт: 
  • Профессия: Программист 1С
Всем привет! Возникла задача заполнения макета печати документа по данным о студенте.

В реквизитах документа есть только ссылка на элемент справочника "Студенты":

Для получения имени студента я написал следующий код:
Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.Справки.ПолучитьМакет("МойМакет");

СсылкаНаДокумент = Документы.Справки.ПолучитьСсылку();
ИмяСтудента = СсылкаНаДокумент.Студент.Имя;

МояНоваяОбласть = Макет.ПолучитьОбласть("Область1");
МояНоваяОбласть.Параметры.ИмяПараметра = ИмяСтудента;
ТабДок.Вывести(МояНоваяОбласть);
КонецПроцедуры
В итоге, содержание реквизита "Имя" не извлекается по ссылке на объект "Студент":


Подскажите, пожалуйста, что я делаю не так?


Оффлайн Luzer1C

  • ****
  • Сообщений: 452
  • РЕПУТАЦИЯ: 54
  • КПД: 12%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
    Макет = Документы.Справки.ПолучитьМакет("МойМакет");
   
    ИмяСтудента = Ссылка.Студент.Имя;
   
    МояНоваяОбласть = Макет.ПолучитьОбласть("Область1");
    МояНоваяОбласть.Параметры.ИмяПараметра = ИмяСтудента;
    ТабДок.Вывести(МояНоваяОбласть);
Халамбалам.

Оффлайн AntonBlg

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-31
  • Сайт: 
  • Профессия: Программист 1С
Предложенный вариант не работает:
ИмяСтудента = Ссылка.Студент.Имя;
Эта строка выдает ошибку: Поле объекта не обнаружено (Студент)

Оффлайн Luzer1C

  • ****
  • Сообщений: 452
  • РЕПУТАЦИЯ: 54
  • КПД: 12%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Халамбалам.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
 ИмяСтудента = СсылкаНаДокумент.Студент.Наименование
?

Оффлайн Luzer1C

  • ****
  • Сообщений: 452
  • РЕПУТАЦИЯ: 54
  • КПД: 12%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
ИмяСтудента = СсылкаНаДокумент.Студент.Наименование
?
Тоже так думал, но смущает, что поле "Студент" не обнаружено.
По сути код ошибки говорит о том, что реквизита "Студент" в документе  нет.
Халамбалам.

Оффлайн AntonBlg

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-31
  • Сайт: 
  • Профессия: Программист 1С
Попробовал все предложенные варианты и на 1С:Предприятие 8.2, на которой изначально всё делал, и на 8.3. Везде просто тишина, никаких ошибок не вылетает при выполнении кода, но и в параметр ничего не передается :(

Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
скиньте скрин с развернутом значением ссылка в отладчике
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн AntonBlg

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-31
  • Сайт: 
  • Профессия: Программист 1С
Походу, всё грустно даже начиная с ссылки на документ:

Добавлено: 02 Апр 2016, 04:38

Уже отчаялся и пытаюсь получить сам объект документа из модуля объекта:
Функция ПолучитьМойОбъект() Экспорт
Возврат ЭтотОбъект.Ссылка;
КонецФункции
А затем использовать полученный объект в модуле менеджера:
&НаСервере
Функция ПолучитьЭтотДокумент()
Возврат Документы.Справки.ПолучитьМойОбъект();
КонецФункции

Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)

Макет = Документы.Справки.ПолучитьМакет("МойМакет");
СсылкаНаДокумент = Ссылка;

Переменная1 = ПолучитьЭтотДокумент();

ИмяСтудента = СсылкаНаДокумент.Студент.Имя;
МояНоваяОбласть = Макет.ПолучитьОбласть("Область1");
МояНоваяОбласть.Параметры.ИмяПараметра = ИмяСтудента;
ТабДок.Вывести(МояНоваяОбласть);
КонецПроцедуры
Но, увы, ничего не выходит. Компилятор ошибок не выдаёт, а при отладке выбрасывает ошибку:

Последний раз редактировалось: AntonBlg; 02 Апр 2016, 04:38. Причина: Объединение сообщений

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С


Теги:
 

УТ 11.3 форма "УправлениеЭквайринговымТерминалом"

Автор skelaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 197
Последний ответ 09 Фев 2018, 21:23
от Геннадий ОбьГЭС
Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5401
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94
Вопрос по УНФ (форма "Задание на работу")

Автор tantonyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 546
Последний ответ 22 Июн 2017, 18:22
от tantony
Как программно вызывать обработчик ПриИзменении поля табличной части после того, как форма была заполнена программно?

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5244
Последний ответ 27 Июл 2015, 06:21
от cska-fanat-kz
Шаблон или Форма для заполнения "заказа покупателя"

Автор SandrРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7163
Последний ответ 02 Сен 2013, 14:22
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
191 Сообщений
alex0402
78 Сообщений
AIFrame AIFrame
74 Сообщений
alexandr_ll
43 Сообщений
oleg-x
39 Сообщений
BuhRust
25 Сообщений
pavl_vs
19 Сообщений
sertak sertak
16 Сообщений
Sandi Sandi
13 Сообщений
Максим ***** Максим *****
13 Сообщений

* Кто онлайн

  • Точка Гостей: 757
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal