Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Июл 2017, 21:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (Вывод на форму)  (Прочитано 536 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 146
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток! Обычные формы.Есть вот такой код:

Процедура ОсновныеДействияФормыДействие(Кнопка)
   //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Для Каждого Стр из ТабличнаяЧасть1 цикл
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Сотрудники.Ссылка,
      |   ФИОСотрудниковСрезПоследних.Фамилия,
      |   ФИОСотрудниковСрезПоследних.Имя,
      |   ФИОСотрудниковСрезПоследних.Отчество,
      |   ФИОСотрудниковСрезПоследних.Фамилия + "" "" + ФИОСотрудниковСрезПоследних.Имя + "" "" + ФИОСотрудниковСрезПоследних.Отчество КАК ФИО,
      |   Сотрудники.ДатаРождения
      |ПОМЕСТИТЬ СпрСОтрФио
      |ИЗ
      |   Справочник.Сотрудники КАК Сотрудники
      |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ФИОСотрудников.СрезПоследних КАК ФИОСотрудниковСрезПоследних
      |      ПО (ФИОСотрудниковСрезПоследних.Сотрудник = Сотрудники.Ссылка)
      |;
      |
      |////////////////////////////////////////////////////////////////////////////////
      |ВЫБРАТЬ
      |   СпрСОтрФио.Ссылка,
      |   СпрСОтрФио.Фамилия,
      |   СпрСОтрФио.Имя,
      |   СпрСОтрФио.Отчество,
      |   СпрСОтрФио.ФИО
      |ИЗ
      |   СпрСОтрФио КАК СпрСОтрФио
      |ГДЕ
      |   СпрСОтрФио.ФИО ПОДОБНО &ФИО
      |   И СпрСОтрФио.ДатаРождения = &ДатаРождения";
   Запрос.УстановитьПараметр("ФИО",СокрЛП(Стр.СотрудникСтр));
   Запрос.УстановитьПараметр("ДатаРождения",Стр.ДатаРождения);
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Стр.СотрудникСпр = ВыборкаДетальныеЗаписи;;
   КонецЦикла;
   КонецЦикла;
   //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

КонецПроцедуры


Данный код проверяет соответствие сотрудников в табличной части и бд. Если соответствие найдено, то сотрудник выводится в табличное поле. Сам запрос верный, что то видимо напутал сдесь: Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Стр.СотрудникСпр = ВыборкаДетальныеЗаписи;;
   КонецЦикла;

ПОдскажите, в чем проблема?


Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Re: (Вывод на форму)
« Ответ #1: 30 Мар 2016, 16:15 »
ВыборкаДетальныеЗаписи.Ссылка
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн GanG031

  • ***
  • Сообщений: 146
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Re: (Вывод на форму)
« Ответ #2: 30 Мар 2016, 16:22 »
я тоже сначала подумал, что Ссылка, но вот гляньте, говорит, что такого метода/свойства нету(

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Re: (Вывод на форму)
« Ответ #3: 30 Мар 2016, 16:32 »
Платформа и колонок таблицы значений не видит, но это не значит, что она не умеет с ними работать.

Оффлайн GanG031

  • ***
  • Сообщений: 146
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Re: (Вывод на форму)
« Ответ #4: 30 Мар 2016, 17:26 »
спасибо!


Теги:
 

Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 889
Последний ответ 18 Янв 2017, 12:32
от sertak
Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 297
Последний ответ 15 Май 2017, 08:59
от ZSS
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 2369
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1962
Последний ответ 13 Июн 2017, 12:17
от Whisper
Версия 8.3, при добавлении поля в форму списка не устанавливается вид поля - выпадающий список пустой

Автор Developer.KZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 96
Последний ответ 22 Июн 2017, 10:50
от Developer.KZ

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
95 Сообщений
oleg-x
82 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
LexaK
23 Сообщений
BuhRust
22 Сообщений

* Кто онлайн

  • Точка Гостей: 368
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal