Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Мар 2017, 09:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как перебрать элементы формы списка?  (Прочитано 440 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dirijabl

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-03
  • Сайт: 
Доброго времени суток! Конфигурация Комплексная 1.1. Нужно, чтобы при открытии формы списка (ну или хоть каком-нибудь событии) при определенном условии 1 колонка документа закрашивалась в другой цвет. Но вот не могу понять, как перебрать документы в списке?
Если пишу что-то типа:
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)

    Для каждого стр из  ОформленияСтрок Цикл
        Если              ЭлементыФормы.ДокументСписок.Колонки.Состояние.Данные=Перечисления.СостоянияОбъектов.Закрыт Тогда
   ЭлементыФормы.ДокументСписок.ЦветТекста= WebЦвета.Аквамарин;
   КонецЕсли;

    КонецЦикла;   
КонецПроцедуры
и потом вызываю эту процедуру в ПриОткрытии(), ошибка- итератор значения не определен.
Подскажите, как правильно?


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С

    Для каждого стр из  ОформленияСтрок Цикл
        Если стр.ДанныеСтроки.Состояние=.... Тогда
ЭлементОформления.Ячейки.<НазваниеЯчейки>.УстановитьТекст(ЗначениеСтатьи);


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
117 Сообщений
Norfolk
52 Сообщений
MuI_I_Ika MuI_I_Ika
50 Сообщений
LexaK
46 Сообщений
AsadRoman
20 Сообщений
друган
20 Сообщений
alexandr_ll
20 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 812
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal