Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Апр 2018, 13:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как перебрать элементы формы списка?  (Прочитано 980 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dirijabl

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-03
  • Сайт: 
Доброго времени суток! Конфигурация Комплексная 1.1. Нужно, чтобы при открытии формы списка (ну или хоть каком-нибудь событии) при определенном условии 1 колонка документа закрашивалась в другой цвет. Но вот не могу понять, как перебрать документы в списке?
Если пишу что-то типа:
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)

    Для каждого стр из  ОформленияСтрок Цикл
        Если              ЭлементыФормы.ДокументСписок.Колонки.Состояние.Данные=Перечисления.СостоянияОбъектов.Закрыт Тогда
   ЭлементыФормы.ДокументСписок.ЦветТекста= WebЦвета.Аквамарин;
   КонецЕсли;

    КонецЦикла;   
КонецПроцедуры
и потом вызываю эту процедуру в ПриОткрытии(), ошибка- итератор значения не определен.
Подскажите, как правильно?


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С

    Для каждого стр из  ОформленияСтрок Цикл
        Если стр.ДанныеСтроки.Состояние=.... Тогда
ЭлементОформления.Ячейки.<НазваниеЯчейки>.УстановитьТекст(ЗначениеСтатьи);


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 574
Последний ответ 21 Сен 2017, 10:33
от Insider
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 122
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5196
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3728
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5639
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
alex0402
68 Сообщений
AIFrame AIFrame
62 Сообщений
alexandr_ll
42 Сообщений
oleg-x
40 Сообщений
pavl_vs
20 Сообщений
BuhRust
20 Сообщений
Sheriff
13 Сообщений
Sandi Sandi
12 Сообщений
KOI8-R
12 Сообщений

* Кто онлайн

  • Точка Гостей: 302
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal