Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 сен 2021, 00:44

Ошибка во внешней печатной форме. Помогите решитью

Автор ckab, 29 мар 2016, 02:21

0 Пользователей и 1 гость просматривают эту тему.

ckab

После обновления конфигурации перстала работать внешняя печатная форма. В чем ошибка?

Ошибка - {Справочник.ВнешниеПечатныеФормы(100)}: Метод объекта не обнаружен (Печать)

Ссылается на следующий кусок кода.

Функция Печать(ДокументОбъект=Неопределено,ТабДокумент=Неопределено) Экспорт
   Если ХранитьВоВнешнемФайле Тогда
      ИмяФайлаПечатнойФормы=ПутьКВнешнемуФайлу;
      Если обЗначениеНеЗаполнено(ИмяФайлаПечатнойФормы) Тогда
         Предупреждение("Отсутствует внешняя печатная форма!");
         Возврат Неопределено;
      КонецЕсли;
   Иначе
      ИмяФайлаПечатнойФормы = ПолучитьИмяВременногоФайла();
      Попытка
         Хранилище.Получить().Записать(ИмяФайлаПечатнойФормы);
      Исключение
         Предупреждение("Внешняя печатная форма не загружена в базу!");
         Возврат Неопределено;
      КонецПопытки;
   КонецЕсли;
   Попытка
      ТабДокумент = ВнешниеОбработки.Создать(ИмяФайлаПечатнойФормы).Печать(ДокументОбъект,ТабДокумент);
   Исключение
      ТабДокумент = ВнешниеОтчеты.Создать(ИмяФайлаПечатнойФормы).Печать(ДокументОбъект,ТабДокумент);
   КонецПопытки;

   
   Попытка
      Если НЕ ХранитьВоВнешнемФайле Тогда
         УдалитьФайлы(ИмяФайлаПечатнойФормы);
      КонецЕсли;
   Исключение
   КонецПопытки;
   Возврат ТабДокумент;
КонецФункции // Печать()







Сама внешняя форма.





Функция Печать(ДокументОбъект = Неопределено, ТабДокумент = Неопределено) Экспорт
//Функция Печать() Экспорт

   ТабДокумент = Новый ТабличныйДокумент;
      
   // Зададим параметры макета
   ТабДокумент.ПолеСверху         = 0;
   ТабДокумент.ПолеСлева          = 0;
   ТабДокумент.ПолеСнизу          = 0;
   ТабДокумент.ПолеСправа         = 0;
   ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
   ТабДокумент.АвтоМасштаб = Истина;
   ТабДокумент.ОтображатьГруппировки = Ложь;
   ТабДокумент.ОтображатьЗаголовки = Ложь;
   ТабДокумент.ОтображатьСетку = Ложь;
   
   Макет = ПолучитьМакет("РабочаяКарта");
   
   Марка = ДокументОбъект.Автомобиль.Модель.МаркаАвтомобиля;
      ОбластьМакетаШапка = Макет.ПолучитьОбласть("Шапка");
   
   ...

vitasw

Какая конфигурация?
Очень похоже, что кто-то покопался в коде. На типовой код не похоже.

ckab


vitasw


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск