Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2017, 19:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка во внешней печатной форме. Помогите решитью  (Прочитано 628 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ckab

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-22
  • Сайт: 
После обновления конфигурации перстала работать внешняя печатная форма. В чем ошибка?

Ошибка - {Справочник.ВнешниеПечатныеФормы(100)}: Метод объекта не обнаружен (Печать)

Ссылается на следующий кусок кода.

Функция Печать(ДокументОбъект=Неопределено,ТабДокумент=Неопределено) Экспорт
   Если ХранитьВоВнешнемФайле Тогда
      ИмяФайлаПечатнойФормы=ПутьКВнешнемуФайлу;
      Если обЗначениеНеЗаполнено(ИмяФайлаПечатнойФормы) Тогда
         Предупреждение("Отсутствует внешняя печатная форма!");
         Возврат Неопределено;
      КонецЕсли;
   Иначе
      ИмяФайлаПечатнойФормы = ПолучитьИмяВременногоФайла();
      Попытка
         Хранилище.Получить().Записать(ИмяФайлаПечатнойФормы);
      Исключение
         Предупреждение("Внешняя печатная форма не загружена в базу!");
         Возврат Неопределено;
      КонецПопытки;
   КонецЕсли;
   Попытка
      ТабДокумент = ВнешниеОбработки.Создать(ИмяФайлаПечатнойФормы).Печать(ДокументОбъект,ТабДокумент);
   Исключение
      ТабДокумент = ВнешниеОтчеты.Создать(ИмяФайлаПечатнойФормы).Печать(ДокументОбъект,ТабДокумент);
   КонецПопытки;

   
   Попытка
      Если НЕ ХранитьВоВнешнемФайле Тогда
         УдалитьФайлы(ИмяФайлаПечатнойФормы);
      КонецЕсли;
   Исключение
   КонецПопытки;
   Возврат ТабДокумент;
КонецФункции // Печать()







Сама внешняя форма.





Функция Печать(ДокументОбъект = Неопределено, ТабДокумент = Неопределено) Экспорт
//Функция Печать() Экспорт

   ТабДокумент = Новый ТабличныйДокумент;
      
   // Зададим параметры макета
   ТабДокумент.ПолеСверху         = 0;
   ТабДокумент.ПолеСлева          = 0;
   ТабДокумент.ПолеСнизу          = 0;
   ТабДокумент.ПолеСправа         = 0;
   ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
   ТабДокумент.АвтоМасштаб = Истина;
   ТабДокумент.ОтображатьГруппировки = Ложь;
   ТабДокумент.ОтображатьЗаголовки = Ложь;
   ТабДокумент.ОтображатьСетку = Ложь;
   
   Макет = ПолучитьМакет("РабочаяКарта");
   
   Марка = ДокументОбъект.Автомобиль.Модель.МаркаАвтомобиля;
      ОбластьМакетаШапка = Макет.ПолучитьОбласть("Шапка");
   
   ...


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Какая конфигурация?
Очень похоже, что кто-то покопался в коде. На типовой код не похоже.

Оффлайн ckab

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-22
  • Сайт: 
Конфигурация альфа-авто 4.1   

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Тогда сочувствую, кроме отладчика вам никто не поможет.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3837
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5086
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5398
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3411
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1662
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
96 Сообщений
Dethmontt Dethmontt
71 Сообщений
alex0402
69 Сообщений
MuI_I_Ika MuI_I_Ika
61 Сообщений
wise wise
50 Сообщений
Сергей Федоров Сергей Федоров
41 Сообщений
ilyay ilyay
39 Сообщений
BuhRust
22 Сообщений
ilnur75
21 Сообщений
magnifico61
20 Сообщений

* Кто онлайн

  • Точка Гостей: 382
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal