Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Апр 2018, 06:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка во внешней печатной форме. Помогите решитью  (Прочитано 975 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ckab

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-22
  • Сайт: 
После обновления конфигурации перстала работать внешняя печатная форма. В чем ошибка?

Ошибка - {Справочник.ВнешниеПечатныеФормы(100)}: Метод объекта не обнаружен (Печать)

Ссылается на следующий кусок кода.

Функция Печать(ДокументОбъект=Неопределено,ТабДокумент=Неопределено) Экспорт
   Если ХранитьВоВнешнемФайле Тогда
      ИмяФайлаПечатнойФормы=ПутьКВнешнемуФайлу;
      Если обЗначениеНеЗаполнено(ИмяФайлаПечатнойФормы) Тогда
         Предупреждение("Отсутствует внешняя печатная форма!");
         Возврат Неопределено;
      КонецЕсли;
   Иначе
      ИмяФайлаПечатнойФормы = ПолучитьИмяВременногоФайла();
      Попытка
         Хранилище.Получить().Записать(ИмяФайлаПечатнойФормы);
      Исключение
         Предупреждение("Внешняя печатная форма не загружена в базу!");
         Возврат Неопределено;
      КонецПопытки;
   КонецЕсли;
   Попытка
      ТабДокумент = ВнешниеОбработки.Создать(ИмяФайлаПечатнойФормы).Печать(ДокументОбъект,ТабДокумент);
   Исключение
      ТабДокумент = ВнешниеОтчеты.Создать(ИмяФайлаПечатнойФормы).Печать(ДокументОбъект,ТабДокумент);
   КонецПопытки;

   
   Попытка
      Если НЕ ХранитьВоВнешнемФайле Тогда
         УдалитьФайлы(ИмяФайлаПечатнойФормы);
      КонецЕсли;
   Исключение
   КонецПопытки;
   Возврат ТабДокумент;
КонецФункции // Печать()







Сама внешняя форма.





Функция Печать(ДокументОбъект = Неопределено, ТабДокумент = Неопределено) Экспорт
//Функция Печать() Экспорт

   ТабДокумент = Новый ТабличныйДокумент;
      
   // Зададим параметры макета
   ТабДокумент.ПолеСверху         = 0;
   ТабДокумент.ПолеСлева          = 0;
   ТабДокумент.ПолеСнизу          = 0;
   ТабДокумент.ПолеСправа         = 0;
   ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
   ТабДокумент.АвтоМасштаб = Истина;
   ТабДокумент.ОтображатьГруппировки = Ложь;
   ТабДокумент.ОтображатьЗаголовки = Ложь;
   ТабДокумент.ОтображатьСетку = Ложь;
   
   Макет = ПолучитьМакет("РабочаяКарта");
   
   Марка = ДокументОбъект.Автомобиль.Модель.МаркаАвтомобиля;
      ОбластьМакетаШапка = Макет.ПолучитьОбласть("Шапка");
   
   ...


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Какая конфигурация?
Очень похоже, что кто-то покопался в коде. На типовой код не похоже.

Оффлайн ckab

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-22
  • Сайт: 
Конфигурация альфа-авто 4.1   

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Тогда сочувствую, кроме отладчика вам никто не поможет.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4624
Последний ответ 24 Дек 2015, 15:34
от дфтын
При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5018
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6692
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4753
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9991
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
176 Сообщений
alex0402
65 Сообщений
AIFrame AIFrame
61 Сообщений
alexandr_ll
41 Сообщений
oleg-x
40 Сообщений
pavl_vs
20 Сообщений
BuhRust
20 Сообщений
Sheriff
13 Сообщений
KOI8-R
12 Сообщений
Sandi Sandi
12 Сообщений

* Кто онлайн

  • Точка Гостей: 233
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal