Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июл 2017, 13:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнить программно партию в документе "Ввод начальных остатков"  (Прочитано 1124 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ирина1109

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-26
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет. На форме в поле "Документ" я выбираю из списка нужный документ ввода начальных остатков и мне нужно не открывая его в нем заполнить партию. Для этого нужно получить объект по ссылке на документ..пишу вот так, но не работает..подскажите в чем ошибка

         Док = Документ.ПолучитьОбъект(); 

Для каждого СтрокаТаблицы Из Док.МПЗОтгруженные Цикл
  СтрокаТаблицы.Партия = Документы.ДокументРасчетовСКонтрагентом.НайтиПоНомеру("0s00000002");
КонецЦикла;


Оффлайн Hedinnk

  • **
  • Сообщений: 84
  • РЕПУТАЦИЯ: 14
  • КПД: 17%
  • Регистрация: 2016-03-04
  • Сайт: 
  • Профессия: Программист 1С
Если у Вас установлен период уникальности номеров документов то в
Документы.ДокументРасчетовСКонтрагентом.НайтиПоНомеру("0s00000002");
вторым параметром надо передавать дату интервала уникальности документа.
Из синтакс-помощника:
Цитировать
<ДатаИнтервала> (необязательный)

Тип: Дата.
Дата из интервала, в котором проводится поиск по номеру. Сам интервал определяется как период уникальности номеров документа, в который входит указанная дата. Например, если номера документов уникальны в пределах месяца и задана дата 10 декабря 2001 года, то поиск будет проводиться в интервале с 01 по 31 декабря 2001 года.
Параметр используется для документов с периодической нумерацией.
На форуме есть волшебная кнопка "Сказать СПАСИБО"

Оффлайн Ирина1109

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-26
  • Сайт: 
  • Профессия: Ученик 1С
Если у Вас установлен период уникальности номеров документов то в
Документы.ДокументРасчетовСКонтрагентом.НайтиПоНомеру("0s00000002");
вторым параметром надо передавать дату интервала уникальности документа.
Из синтакс-помощника:
Цитировать
<ДатаИнтервала> (необязательный)

Тип: Дата.
Дата из интервала, в котором проводится поиск по номеру. Сам интервал определяется как период уникальности номеров документа, в который входит указанная дата. Например, если номера документов уникальны в пределах месяца и задана дата 10 декабря 2001 года, то поиск будет проводиться в интервале с 01 по 31 декабря 2001 года.
Параметр используется для документов с периодической нумерацией.


Кажется дело не в этом. Смотрю через отладчик и СтрокаТаблицы не определяется - скриншот в приложенном файле.


Оффлайн Hedinnk

  • **
  • Сообщений: 84
  • РЕПУТАЦИЯ: 14
  • КПД: 17%
  • Регистрация: 2016-03-04
  • Сайт: 
  • Профессия: Программист 1С
На форуме есть волшебная кнопка "Сказать СПАСИБО"

Оффлайн Ирина1109

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-26
  • Сайт: 
  • Профессия: Ученик 1С
Покажите весь код процедуры

Там пока кроме этого больше ничего и нет

&НаСервере
Процедура ЗагрузитьПартииНаСервере()

Док = Документ.ПолучитьОбъект();

Для каждого СтрокаТаблицы Из Док.МПЗОтгруженные Цикл
  СтрокаТаблицы.Партия = Документы.ДокументРасчетовСКонтрагентом.НайтиПоНомеру("0s00-000002", '2015-12-31');
КонецЦикла;
КонецПроцедуры

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
1.
Документ.ПолучитьОбъект();

Документ - это реквизит формы или объекта?
2.
но не работает..подскажите в чем ошибка
Не работает - это как понимать. Ошибок нет, но не выполняет те функции, которые вы ожидаете; или есть ошибка, но вы ее забыли привести?

Онлайн LexaK

  • *****
  • Сообщений: 1247
  • РЕПУТАЦИЯ: 344
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
1.проверьте переменную Документ, похоже что она пустая.
2.документ партии надо получить ОДИН раз до цикла, (если у вас 1000... строк в ТЧ, то столько же раз вы ищите этот(один и тотже документ)
3.после правки документа его необходимо записать

вот ваш код с примерными исправлениями
&НаСервере
Процедура ЗагрузитьПартииНаСервере()

//проверка на заполненность переменной документ
Если ЗначениеЗаполнено(Документ) Тогда

     Док = Документ.ПолучитьОбъект();

     //один раз получаем документ партии
     лкПартия = Документы.ДокументРасчетовСКонтрагентом.НайтиПоНомеру("0s00-000002", Дата(2015,12,31));

     Для каждого СтрокаТаблицы Из Док.МПЗОтгруженные Цикл
          СтрокаТаблицы.Партия = лкПартия;
     КонецЦикла;

    //запись можно сделать за два приема, и при необходимости взять в попытку
    Док.Записать(РежимЗаписиДокумента.Проведение);

Иначе
    Сообщить("Не выбран Документ");
КонецЕсли;   

КонецПроцедуры

Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

«Единица для отчетов» и «Единица хранения остатков»

Автор tranceferРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6941
Последний ответ 14 Фев 2012, 02:29
от Dethmontt
Программно открыть отчет скд и отчет подключенный как внешний отчет

Автор 1ckaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3464
Последний ответ 02 Фев 2015, 10:06
от 1cka
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2823
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
Верно ли, что при соединении с виртуальной таблицей остатков регистра накопления отбираются остатки по измерениям, перечисленным в условии соединения таблиц?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 475
Последний ответ 25 Ноя 2016, 11:25
от Zeed
Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 888
Последний ответ 18 Янв 2017, 12:32
от sertak

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
92 Сообщений
oleg-x
80 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений
Dethmontt Dethmontt
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal