Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Май 2017, 08:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: (Не выводит номер документа)  (Прочитано 579 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн GanG031

  • ***
  • Сообщений: 143
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Доброго времени суток! Пишу внешнюю печатную форму под обычные формы БП 2,0 Вот код модуля объекта:

Функция Печать() Экспорт
Запрос = Новый Запрос;
   
   Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект.Ссылка);
   
   Запрос.Текст =
   "ВЫБРАТЬ
   | Номер                    КАК Номер,
   | Дата                     КАК ДатаДокумента,
   | Дата                     КАК ДатаСоставления,
   | Организация              КАК Организация,
   | Склад                    КАК Склад,
   | Местонахождение          КАК Подразделение
   |ИЗ
   | Документ.ПередачаМатериаловВЭксплуатацию КАК ПередачаМатериаловВЭксплуатацию
   |
   |ГДЕ
   | ПередачаМатериаловВЭксплуатацию.Ссылка = &ТекущийДокумент";
   
   Шапка = Запрос.Выполнить().Выбрать();
   Шапка.Следующий();
   
   Запрос = Новый Запрос;
   
   Запрос.УстановитьПараметр("Ссылка",                                                        ЭтотОбъект.СсылкаНаОбъект.Ссылка);
   Запрос.УстановитьПараметр("ДатаДок",                                                       Шапка.ДатаДокумента);
   Запрос.УстановитьПараметр("СчетУчетаСпецодеждыЗабалансовый",                             ПланыСчетов.Хозрасчетный.СпецодеждаВЭксплуатацииВспомогательный);
   Запрос.УстановитьПараметр("СчетУчетаСпецоснасткиЗабалансовый",                           ПланыСчетов.Хозрасчетный.СпецоснасткаВЭксплуатацииВспомогательный);
   Запрос.УстановитьПараметр("СчетУчетаИнвентаряИХозяйственныхПринадлежностейЗабалансовый", ПланыСчетов.Хозрасчетный.ИнвентарьИХозяйственныеПринадлежностиВЭксплуатации);
   
   Запрос.Текст =
   "ВЫБРАТЬ
   | ВложенныйЗапрос.ID КАК ID,
   | ВложенныйЗапрос.НомерСтроки КАК НомерСтроки,
   | ВложенныйЗапрос.Номенклатура КАК Номенклатура,
   | ВЫРАЗИТЬ(ВложенныйЗапрос.Номенклатура.НаименованиеПолное КАК СТРОКА(1000)) КАК МатериалНаименование,
   | ВложенныйЗапрос.Номенклатура.Код КАК НоменклатурныйНомер,
   | ВложенныйЗапрос.Номенклатура.БазоваяЕдиницаИзмерения.Наименование КАК ЕдиницаИзмеренияНаименование,
   | ВложенныйЗапрос.Номенклатура.БазоваяЕдиницаИзмерения.Код КАК ЕдиницаИзмеренияКод,
   | ВложенныйЗапрос.СчетУчета КАК Счет,
   | ЕСТЬNULL(ВложенныйЗапрос.Количество, 0) КАК Количество,
   | СУММА(ЕСТЬNULL(ХозрасчетныйДвиженияССубконто.Сумма, 0)) КАК Сумма
   |ИЗ
   | (ВЫБРАТЬ
   | 1 КАК ID,
   | МИНИМУМ(Спецодежда.НомерСтроки) КАК НомерСтроки,
   | Спецодежда.Номенклатура КАК Номенклатура,
   | Спецодежда.СчетУчета КАК СчетУчета,
   | СУММА(Спецодежда.Количество) КАК Количество
   | ИЗ
   | Документ.ПередачаМатериаловВЭксплуатацию.Спецодежда КАК Спецодежда
   | ГДЕ
   | Спецодежда.Ссылка = &Ссылка
   |
   | СГРУППИРОВАТЬ ПО
   | Спецодежда.Номенклатура,
   | Спецодежда.СчетУчета
   |
   | ОБЪЕДИНИТЬ ВСЕ
   |
   | ВЫБРАТЬ
   | 2,
   | МИНИМУМ(Спецоснастка.НомерСтроки),
   | Спецоснастка.Номенклатура,
   | Спецоснастка.СчетУчета,
   | СУММА(Спецоснастка.Количество)
   | ИЗ
   | Документ.ПередачаМатериаловВЭксплуатацию.Спецоснастка КАК Спецоснастка
   | ГДЕ
   | Спецоснастка.Ссылка = &Ссылка
   |
   | СГРУППИРОВАТЬ ПО
   | Спецоснастка.Номенклатура,
   | Спецоснастка.СчетУчета
   |
   | ОБЪЕДИНИТЬ ВСЕ
   |
   | ВЫБРАТЬ
   | 3 КАК ID,
   | МИНИМУМ(ИнвентарьИХозяйственныеПринадлежности.НомерСтроки) КАК НомерСтроки,
   | ИнвентарьИХозяйственныеПринадлежности.Номенклатура КАК Номенклатура,
   | ИнвентарьИХозяйственныеПринадлежности.СчетУчета КАК СчетУчета,
   | СУММА(ИнвентарьИХозяйственныеПринадлежности.Количество) КАК Количество
   | ИЗ
   | Документ.ПередачаМатериаловВЭксплуатацию.ИнвентарьИХозяйственныеПринадлежности КАК ИнвентарьИХозяйственныеПринадлежности
   | ГДЕ
   | ИнвентарьИХозяйственныеПринадлежности.Ссылка = &Ссылка
   |
   | СГРУППИРОВАТЬ ПО
   | ИнвентарьИХозяйственныеПринадлежности.Номенклатура,
   | ИнвентарьИХозяйственныеПринадлежности.СчетУчета) КАК ВложенныйЗапрос
   | ЛЕВОЕ СОЕДИНЕНИЕ РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
   | &ДатаДок,
   | &ДатаДок,
   | Регистратор = &Ссылка
   |     И (НЕ СчетДт = &СчетУчетаСпецодеждыЗабалансовый)
   |     И (НЕ СчетДт = &СчетУчетаСпецоснасткиЗабалансовый)
   |     И (НЕ СчетДт = &СчетУчетаИнвентаряИХозяйственныхПринадлежностейЗабалансовый)) КАК ХозрасчетныйДвиженияССубконто
   | ПО ВложенныйЗапрос.Номенклатура = ХозрасчетныйДвиженияССубконто.СубконтоКт1
   | И ВложенныйЗапрос.СчетУчета = ХозрасчетныйДвиженияССубконто.СчетКт
   |
   |СГРУППИРОВАТЬ ПО
   | ВложенныйЗапрос.ID,
   | ВложенныйЗапрос.НомерСтроки,
   | ВложенныйЗапрос.Номенклатура,
   | ВложенныйЗапрос.Номенклатура.Код,
   | ВложенныйЗапрос.Номенклатура.БазоваяЕдиницаИзмерения.Наименование,
   | ВложенныйЗапрос.Номенклатура.БазоваяЕдиницаИзмерения.Код,
   | ВложенныйЗапрос.СчетУчета,
   | ВложенныйЗапрос.Количество,
   | ВЫРАЗИТЬ(ВложенныйЗапрос.Номенклатура.НаименованиеПолное КАК СТРОКА(1000))
   |
   |УПОРЯДОЧИТЬ ПО
   | ID,
   | НомерСтроки";
   
   Если Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить() = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
      Запрос.Текст = СтрЗаменить(Запрос.Текст, "Номенклатура.Код", "Номенклатура.Артикул");
   КонецЕсли;
   
   ЗапросПоНоменклатуре = Запрос.Выполнить();
   
   ТабДокумент = Новый ТабличныйДокумент;
   ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
   ТабДокумент.ИмяПараметровПечати = "ПараметрыПечати_ПередачаМатериаловВЭксплуатацию_М11";
   
   // Вывод заголовка
   Макет = ПолучитьМакет("Макет");
   
   Область = Макет.ПолучитьОбласть("Шапка");
   
   Область.Параметры.Заголовок = "ТРЕБОВАНИЕ-НАКЛАДНАЯ № " + ОбщегоНазначения.ПолучитьНомерНаПечать(Шапка.Номер);
   
   Область.Параметры.Заполнить(Шапка);
   
   СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.ДатаДокумента);
   
   Область.Параметры.ПредставлениеОрганизации   = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации);
   Область.Параметры.ПредставлениеПодразделения = Шапка.Подразделение;
   Область.Параметры.КодОКПО                    = СведенияОбОрганизации.КодПоОКПО;
   
   ТабДокумент.Вывести(Область);
   
   ВыборкаПоСтрокам = ЗапросПоНоменклатуре.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   Пока ВыборкаПоСтрокам.Следующий() Цикл
      
      Область = Макет.ПолучитьОбласть("Строка");
      Область.Параметры.Заполнить(ВыборкаПоСтрокам);
      
      Область.Параметры.МатериалНаименование = СокрЛП(ВыборкаПоСтрокам.МатериалНаименование);
      Область.Параметры.Цена =                 ?(ВыборкаПоСтрокам.Количество = 0, 0, ВыборкаПоСтрокам.Сумма / ВыборкаПоСтрокам.Количество);
      
      ТабДокумент.Вывести(Область);
      
   КонецЦикла;
   
   Область = Макет.ПолучитьОбласть("Подвал");
   ТабДокумент.Вывести(Область);
   
   Возврат ТабДокумент;
   
КонецФункции



но почему то не выводится номер документа. ПОдскажите, в чем ошибка? выделил наклонным шрифтом, нужную строку кода. Заранее спасибо!


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
И в каком же это месте наклонный шрифт? Вы сами то это место найдете?

Оффлайн GanG031

  • ***
  • Сообщений: 143
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
Извиняюсь, вот
Область.Параметры.Заголовок = "ТРЕБОВАНИЕ-НАКЛАДНАЯ № " + ОбщегоНазначения.ПолучитьНомерНаПечать(Шапка.Номер);
   

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Вы эту функцию "ОбщегоНазначения.ПолучитьНомерНаПечать" открывали? Не ленитесь, откройте и посмотрите параметры функции и что вы в нее пихаете.

Оффлайн GanG031

  • ***
  • Сообщений: 143
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-28
  • Сайт: 
  • Профессия: Ученик 1С
делал и "Шапка", и ЭтотОбъект.Ссылка", все равно не выводит

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Эээээээ, вы перед тем как что-то пихать не пробовали хоть чуть-чуть подумать?
Функция ПолучитьНомерНаПечать(Документ, МассивПрефиксов = Неопределено, ПечатьПрефиксовРИБ = Истина) Экспорт

где Документ - ссылка на документ
делал и "Шапка"
- это результат запроса!
ЭтотОбъект.Ссылка
- это вообще хрень несусветная. Находясь во внешней обработке вы пишите "ЭтотОбъект.Ссылка"! Ничего не смущает?

Запихните "СсылкаНаОбъект"


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4049
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14202
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3548
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 151
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7012
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
89 Сообщений
wise wise
68 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
49 Сообщений
Dethmontt Dethmontt
48 Сообщений
Сергей Федоров Сергей Федоров
29 Сообщений
ilyay ilyay
28 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 560
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal