Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2017, 07:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не поняла условия задачи  (Прочитано 291 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AnastasyaM

  • *
  • Сообщений: 0
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-20
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!
На данный момент прохожу веб-обучение на курсах 1с. И вот встретилась такая задача:
Реализовать алгоритм подбора кода. Код состоит из 3х цифр (то, что нужно подобрать вводится в «ПодбираемыйКод»). Из 3х цифр кода известна только одна: первая, вторая или третья (номер цифры указывается в «НомерИзвестнойЦифры»). Нужно «подобрать» две недостающие цифры. Для этой цели лучше всего использовать цикл-счетчик:

Для ТекущаяЦифра=0 По 9 цикл

        // ваши действия

КонецЦикла;

 

Для подбора двух цифр используйте «вложенные» циклы

Для ТекущаяЦифра1=0 По 9 цикл

        // ваши действия

Для ТекущаяЦифра2=0 По 9 цикл

               // ваши действия

КонецЦикла;

        // ваши действия

КонецЦикла;

 

Требуется, оптимизировать данный алгоритм (перебрать всего 100 вариантов, а не 1000).


Я не уловила задания, что понимается под "подобрать код"? То есть мне нужно циклом перебрать цифры от 0 до 9 для двух неизвестных цифр и если они равны цифре из заданного кода, то задание я выполнила или как? Прошу тапками в меня не кидать)) Просто не очень поняла формулировку задания. Спасибо заранее! Очень надеюсь на разъяснения!

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Согласно логике, ваше предположение - верное.
Но согласно задания....
Для подбора двух цифр используйте «вложенные» циклы
Возникает мысль что, что целью является выработка навыков "индусского" кода.


Теги:
 

Что значит такое условие задачи? "Считается, что документы задним числом не ..."

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3978
Последний ответ 01 Май 2012, 19:21
от DirecTwiX
1С:Документооборот задачи стартуют только только первым 2-м пользователям (попарный! старт задач).

Автор Aleksey_ArtРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 216
Последний ответ 10 Окт 2016, 11:54
от Aleksey_Art
Условия применения "вмененки" для деятельности, связанной с ремонтом, обслуживанием и мойкой транспортных средств

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 728
Последний ответ 09 Июн 2014, 20:45
от topics
Уведомление по почте пользователей при создании задачи в управляемом приложении

Автор Tgr11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 5016
Последний ответ 31 Окт 2013, 09:59
от Tgr11
Уведомление о постановке Задачи (поле данных - просрочено)

Автор Юлия_MРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 555
Последний ответ 25 Май 2015, 20:25
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
61 Сообщений
MuI_I_Ika MuI_I_Ika
45 Сообщений
alexandr_ll
32 Сообщений
LexaK
32 Сообщений
crow1983
31 Сообщений
sertak sertak
27 Сообщений
Vzonder
22 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 148
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal