Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Ноя 2018, 07:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1с 8 табличный документ, объединение сводных таблиц.  (Прочитано 5542 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mishmeister

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-01-20
  • Сайт: 
Доброго времени суток коллеги! В отчет построенный на СКД, в табличный документ выводится несколько сводных таблиц. т.к. таблицы разные, то при изменении ширины колонок в одной таблице, ширина олонок в остальных не меняется. Можно ли какими средствами объединить эти таблицы?Иликакто программно изменять ширину колонок?


Оффлайн mishmeister

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-01-20
  • Сайт: 

Оффлайн mishmeister

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-01-20
  • Сайт: 
Можно товарищи, можно и не сложно! Пишу код, м.б. кто в поиске искать будет.
Сделал следующее, чтоб к чему нибудь привязаться выбрал "ПРиАктивизацииСтроки" и следующая процедура.

Процедура РезультатПриАктивизацииОбласти(Элемент)
    ТабДок = ЭлементыФормы.Результат;
    ТекСтрока = 1;
    //Перебираем все строки.
    Пока ТекСтрока <=ТабДок.ВысотаТаблицы Цикл
        //Ищем нужные строки.
        Если ТабДок.Область(ТекСтрока,1).Текст = "Маржинальная прибыль" ИЛИ ТабДок.Область(ТекСтрока,1).Текст = "Валовая прибыль" Тогда
            Сч = 1;
            //у меня максимум 14 колонок.
            Пока Сч <> 14 Цикл
                //Ширина текущей колонки приравнивается к ширине колончи следующей через 1 строку(Такая структура у меня).
                ТабДок.Область(ТекСтрока,Сч).ШиринаКолонки = ТабДок.Область(ТекСтрока-2,Сч).ШиринаКолонки;
                Сч = Сч +1;
            КонецЦикла;
        КонецЕсли;
        ТекСтрока = ТекСтрока + 1;
    КонецЦикла;
КонецПроцедуры


Теги:
 

не находить контрагента (Выбрать * Из Документ ГДЕ контрагент = "имя контрагента")

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 691
Последний ответ 23 Окт 2017, 23:14
от Ivan94
УТ 10.3 При провеедении реализации выходит ошибка "состояние договора отличается от "договор есть, документы есть", документ подсвечивается серым цветом

Автор MilaZzerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 133
Последний ответ 25 Сен 2018, 13:32
от MilaZzerber
Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4866
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 11695
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5261
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
64 Сообщений
wise wise
58 Сообщений
AIFrame AIFrame
50 Сообщений
alexandr_ll
46 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
43 Сообщений
alex0402
41 Сообщений
LexaK
32 Сообщений
BuhRust
28 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 283
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal