Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 05:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сохраниение отчета из 1с в Excel  (Прочитано 1938 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vinceras

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-23
  • Сайт: 
Программным путем в после формирования отчета добовляю в нужные ячейки примечания. Вот пример кода:

Для Каждого Строка Из ТаблицаПримечаний Цикл 
КолонкаНоменклатура = Результат.НайтиТекст(СокрЛП(Строка.Номенклатура.Код));
КолонкаПериод = Результат.НайтиТекст(Формат(Строка.Дата, "ДФ=""дд.ММ.гггг"""));
Если (КолонкаНоменклатура <> Неопределено) и (КолонкаПериод <> Неопределено) Тогда
Если Строка.Поле = "План" Тогда
АдресЯчейки = Лев(КолонкаНоменклатура.Имя,Найти(КолонкаНоменклатура.Имя,"C") - 1);
Иначе
АдресЯчейки = Лев(КолонкаНоменклатура.Имя,1) + Строка(Число(Сред(КолонкаНоменклатура.Имя, 2, Найти(КолонкаНоменклатура.Имя,"C") - 2)) + 1);
КонецЕсли;
АдресЯчейки = АдресЯчейки +  Сред(КолонкаПериод.Имя,Найти(КолонкаПериод.Имя,"C"),СтрДлина(КолонкаПериод.Имя));
Область = Результат.Область(АдресЯчейки);
Попытка
Область.Примечание.Текст = Строка.Примечание;
Исключение
Сообщить("Не найдено примечание по адресу ячейки: " + АдресЯчейки, СтатусСообщения.Внимание);
КонецПопытки;
КонецЕсли;
КонецЦикла;

Далее Сохранить копию -> Лист Excel. При открытиии в Excel все примечании сохраняются, но если внести какие-либо изменения и пересохранить файл в Excel все примечания пропадают(вне зависимости от версии, что в 2003, что в 2007). Вопрос: косяк 1С, моего отчета или Ecxel?


Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7036
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2990
Последний ответ 27 Май 2015, 10:02
от casper009
Ошибка при выгрузке отчета "Прибыль"

Автор VasilРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4088
Последний ответ 28 Апр 2011, 14:34
от MaryaAlbertovna
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3866
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Программирование отчета "Движения на складах"

Автор ЛунатикРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1948
Последний ответ 05 Апр 2016, 10:15
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 230
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal