Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Окт 2017, 15:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: {Форма.Форма.Форма(814)}: Поле объекта не обнаружено (ПолноеНаименование)  (Прочитано 517 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Айя Удинцева

  • *
  • Сообщений: 0
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-14
  • Сайт: 
Здравствуйте, не понимаю почему ошибка. Прайс xls/
Процедура ЗагрузитьУралГалантНажатие(Элемент)
   
   Если НЕ ЗначениеЗаполнено(ЭтотОбъект.КонтрагентУралГалант) Тогда
      Предупреждение("Не указан контрагент!");
      Возврат;
   КонецЕсли;
   
   Если НЕ ЗначениеЗаполнено(ЭтотОбъект.ТипЦенУралГалант) Тогда
      Предупреждение("Не указан тип цен!");
      Возврат;
   КонецЕсли;
   
   ТекКонтрагент = ЭтотОбъект.КонтрагентУралГалант;
   ЗагрузитьНоменклатуруУралГалант(ТекКонтрагент);
   ЗагрузитьУстановкуЦенУралГалант(ТекКонтрагент);
   
КонецПроцедуры

Процедура ЗагрузитьНоменклатуруУралГалант(ТекКонтрагент)
   
   КорневаяГруппа = Справочники.Номенклатура.НайтиПоНаименованию(ТекКонтрагент.Наименование);
   Если КорневаяГруппа.Пустая() Тогда
      НоваяГруппа = Справочники.Номенклатура.СоздатьГруппу();
      НоваяГруппа.Наименование = ТекКонтрагент.Наименование;
      НоваяГруппа.Записать();
      КорневаяГруппа = НоваяГруппа.Ссылка;
   КонецЕсли;
   
   ТекВидНоменклатуры = Справочники.ВидыНоменклатуры.НайтиПоНаименованию("Товар");
   Если ТекВидНоменклатуры.Пустая() Тогда
      НовыйВид = Справочники.ВидыНоменклатуры.СоздатьЭлемент();
      НовыйВид.Наименование = "Товар";
      НовыйВид.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар;
      НовыйВид.Записать();
      ТекВидНоменклатуры = НовыйВид.Ссылка;
   КонецЕсли;
   ЭтотОбъект.ВидНоменклатуры = ТекВидНоменклатуры;
   
   ТабличныйДокумент = ЭлементыФормы.ПолеТабличногоДокументаУралГалант;
   Сообщить("Загрузка номенклатуры """ + ТекКонтрагент + """...", СтатусСообщения.Информация);
   Для Сч = ЭтотОбъект.НачальнаяСтрокаУралГалант По ТабличныйДокумент.ВысотаТаблицы Цикл
      НоваяСтрока = ЭтотОбъект.НоменклатураУралГалант.Добавить();
      НоваяСтрока.Группа = ТабличныйДокумент.Область(Сч, 2).Текст;
      НоваяСтрока.КодТовара = ТабличныйДокумент.Область(Сч, 3).Текст;
      НоваяСтрока.Артикул = ТабличныйДокумент.Область(Сч, 5).Текст;
      НоваяСтрока.Наименование = ТабличныйДокумент.Область(Сч, 6).Текст;
      НоваяСтрока.Бренд = ", " + СокрЛП(ТабличныйДокумент.Область(Сч, 8).Текст);
      НоваяСтрока.Цвет = ", " + СокрЛП(ТабличныйДокумент.Область(Сч, 10).Текст);
      НоваяСтрока.ПолноеНаименование = ТабличныйДокумент.Область(Сч, 11).Текст;
      НоваяСтрока.Материал = ", " + СокрЛП(ТабличныйДокумент.Область(Сч, 12).Текст);
      НоваяСтрока.Размер = ", " + СокрЛП(ТабличныйДокумент.Область(Сч, 13).Текст);
      НоваяСтрока.Цена = Число(ТабличныйДокумент.Область(Сч, 14).Текст);
   КонецЦикла;
   Сообщить("Обработка номенклатуры """ + ТекКонтрагент + """ окончена", СтатусСообщения.Информация);
   
   Сообщить("Формирование номенклатуры """ + ТекКонтрагент + """ в справочнике...", СтатусСообщения.Информация);
   Для каждого СтрокаНоменклатуры Из ЭтотОбъект.НоменклатураУралГалант Цикл
      СтрокаНоменклатуры.Номенклатура = ПолучитьНоменклатуруУралГалант(ТекКонтрагент, СтрокаНоменклатуры, КорневаяГруппа);
   КонецЦикла;
   Сообщить("Номенклатура """ + ТекКонтрагент + """ сформирована в справочнике", СтатусСообщения.Информация);
   
КонецПроцедуры

Помогите пожалуйста


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
91 Сообщений
alex0402
53 Сообщений
AIFrame
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
38 Сообщений
Oldman06
31 Сообщений
Golickoff Golickoff
30 Сообщений
vitasw
29 Сообщений
MuI_I_Ika MuI_I_Ika
19 Сообщений
DmitriyF DmitriyF
14 Сообщений
Св Ч Св Ч
12 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal