Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 19:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: работа с реквизитом типа хранилище значения  (Прочитано 15826 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sunady

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-13
  • Сайт: 
Всем добрый день!
Хочу из внешней обработки передавать массив серийных номеров в табличную часть Товары. Добавила реквизит табличной части с типом хранилище значения и в обработке сохраняю в него выборку. Тут же беру ее обратно, чтобы проверить как сохранилось и получаю неопределено.
Если делать через локальную переменную типа хранилище значения - все работает.
Подскажите пожалуйста в чем может быть дело.
ДокументРеализации.ПолучитьОбъект().Товары[НомерСтроки].СерийныеНомера = Новый ХранилищеЗначения(СерийныеНомера.Выгрузить());;
               
ТаблицаЗначений = ДокументРеализации.Товары[НомерСтроки].СерийныеНомера.Получить();

Если ТаблицаЗначений <> Неопределено Тогда
                   
   Для каждого СтрокаСерийника из ТаблицаЗначений Цикл
     Сообщить(СтрокаСерийника.СерийныйНомер);
     КонецЦикла;
КонецЕсли;


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Думаю, чтобы получить изменения, нужно их в документ в начале записать :)

То есть как-то так:
ДокОбъект=ДокументРеализации.ПолучитьОбъект();
ДокОбъект.Товары[НомерСтроки].СерийныеНомера = Новый ХранилищеЗначения(СерийныеНомера.Выгрузить());
ДокОбъект.Записать();
               
ТаблицаЗначений = ДокументРеализации.Товары[НомерСтроки].СерийныеНомера.Получить();

Если ТаблицаЗначений <> Неопределено Тогда
                   
   Для каждого СтрокаСерийника из ТаблицаЗначений Цикл
     Сообщить(СтрокаСерийника.СерийныйНомер);
     КонецЦикла;
КонецЕсли;
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн sunady

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-13
  • Сайт: 
Спасибо, Клякса! Твой вариант работает, причем я пробовала тоже записывать и не работало, а твой код скопировала и все ок :)

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 293
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
<< "Работа с комментариями" >>

Автор MaximРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 5556
Последний ответ 17 Май 2011, 11:06
от cska-fanat-kz
Доступ к реквизитам формы из другой формы? 8.x, работа с табличным полем формы

Автор nick_EРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 5920
Последний ответ 24 Окт 2011, 03:00
от nick_E
v8: УТ 10.3 работа с набор-пакетами и набор-комплектами

Автор altayknigaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3151
Последний ответ 14 Сен 2011, 12:07
от altaykniga
Стаж "Работа на Севере"

Автор PartizAnkaРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5375
Последний ответ 25 Окт 2013, 07:27
от PartizAnka

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
63 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 262
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal