Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Июл 2017, 15:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Передача параметров из ячейки поля табличного документа в форму отчета 1с 8.3  (Прочитано 682 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
Всем привет!

Есть определенная схема рассадки, которая выводится на экран в виде ТабличногоПоля....  По правой мыши вызывается контекстное меню, где один из пунктов это Формирование отчета...

https://drive.google.com/file/d/0BwF_oocLEKVLbTBvM19LTnk0ZDg/view?usp=sharing

Вот код, который должен передавать в форму отчета два параметра (Стол и Место) из выделенной ячейки...

&НаКлиенте
Процедура ГИВЦ_Химсостав_По_Столам(Команда)
   СоответствиеЯчеек = Новый Соответствие;
   ОписаниеТипов = Новый ОписаниеТипов("Строка");
   
   Для Каждого ВыделеннаяОбласть Из Результат2.ВыделенныеОбласти Цикл
      Для Индекс1 = ВыделеннаяОбласть.Лево По ВыделеннаяОбласть.Право Цикл
         Для Индекс2 = ВыделеннаяОбласть.Верх По ВыделеннаяОбласть.Низ Цикл
            Область = Результат2.Область(Индекс2, Индекс1, Индекс2, Индекс1);
            Значение = ОписаниеТипов.ПривестиЗначение(Область.Текст);
            СоответствиеЯчеек.Вставить(Область.Имя, Значение);
         КонецЦикла;
      КонецЦикла;
   КонецЦикла;
   
   Для каждого Ячейка Из СоответствиеЯчеек Цикл
      Значение = Ячейка.Значение;
      Если НЕ Значение = "" Тогда
         ЧастьСтроки = Сред(СокрЛП(Значение),1,7);
         ПоследнийСимвол = Прав(ЧастьСтроки,1);
         НомерМеста = Прав(ЧастьСтроки,1);
         Если ПоследнийСимвол = " / " Тогда
            КолСимСтол = СтрДлина(ЧастьСтроки)-1;
            ЧастьСтроки = Лев(Значение,КолСимСтол);
            НомерСтола = Прав(ЧастьСтроки,2);
         Иначе
            НомерСтола = Прав(ЧастьСтроки,3);
         КонецЕсли;
      КонецЕсли;
   КонецЦикла;
   
   УсловияОтбора  = Новый Структура("Место, Стол");
   УсловияОтбора.Место = НомерМеста;
        УсловияОтбора.Стол = НомерСтола;   
      
    ПараметрыФормы = Новый Структура("Отбор, СформироватьПриОткрытии", УсловияОтбора, Истина);
    ОткрытьФорму("Отчет.ГИВЦ_Химсостав_По_Столам.ФормаОбъекта", ПараметрыФормы);
      
КонецПроцедуры

Вот код в модуле формы отчета ПриСоздании

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   
   Отчет.Место = Параметры.Место;   
   Отчет.Стол = Параметры.Стол;
   
   ДополнитьСоответствиеХарактеристикПищевойЦенности();
    ЗаполнитьТаблицуХПЦ();
    ПечатьОтчетов.ПриСозданииФормыОтчета(ЭтаФорма);
КонецПроцедуры

По нажатию форма отчета выводится на экран, но поля Стол и Место  пустые...

https://drive.google.com/file/d/0BwF_oocLEKVLLXJwd3FtbVdJSmM/view?usp=sharing

Что-то пропустила, а где ?????....

Подскажите кто может, пожалуйста.....



Оффлайн wise

  • ****
  • Сообщений: 401
  • РЕПУТАЦИЯ: 55
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
а ЧТО говорит отладчик??
{
   УсловияОтбора.Место = НомерМеста;
   УсловияОтбора.Стол = НомерСтола;   
}
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
 УсловияОтбора.Стол = НомерСтола;   

....говорит ОШИБКА В ВЫРАЖЕНИИ.......  :(

...буду думать....

...может воспользоваться ПоместитьВоВременноеХранилище......????

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
....говорит ОШИБКА В ВЫРАЖЕНИИ.......  :(

...буду думать....

...может воспользоваться ПоместитьВоВременноеХранилище......????
Судя по вашим фразам - вам хочется поговорить с собой.
А если все-таки ожидаете получить помощь, то потрудитесь привести полный текст ошибки.


Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
...это полный текст, который выдаёт отладчик на этой строке....

строка    УсловияОтбора.Стол = НомерСтола;
ошибка    ОШИБКА В ВЫРАЖЕНИИ

Пробую сейчас чуточку по другому....
Добавлено: 18 Мар 2016, 10:32

Всем спасибо!  Разобралась....заодно научилась пользоваться отладчиком.... Отличная штуковина!!!!

Пустые значения изначально пыталась передать....

:btbzdb:

Последний раз редактировалось: Анна Баханович; 18 Мар 2016, 10:32. Причина: Объединение сообщений


Теги:
 

Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14654
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 284
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7225
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4271
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1275
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
116 Сообщений
alex0402
102 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
AIFrame
51 Сообщений
Golickoff Golickoff
49 Сообщений
ilyay ilyay
49 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 234
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal