Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 22:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Регистры  (Прочитано 2103 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн 6aToH

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-15
  • Сайт: 
  • Профессия: Ученик 1С
Регистры
« Первое сообщение: 16 Янв 2011, 17:56 »
Прошу сильно не пинать т.к. с регистрами я не работал.
Читал про них пробовал написать но мне выходит пустая таблица.
Подскажите как сделать отчет который выводил бы список контрагентов по которым за выбранный период была реализация товаров?
Выберать необходимо из регистров.
Регистр Реализованный товар

Имерения
организация
основание
тмц
партия

ДокПродажи
Ресурсы
Кол-во
Стоимость



вот это что выдать должно?
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Владелец = Регистр.РеализованныйТовар.Основание.Владелец;
|Количество = Регистр.РеализованныйТовар.Количество;
|ПродСтоимость = Регистр.РеализованныйТовар.ПродСтоимость;
|Группировка Владелец упорядочить по Владелец.РегионПродаж;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей Владелец
Таб.ВывестиСекцию("Владелец");
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры


Оффлайн 6aToH

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-15
  • Сайт: 
  • Профессия: Ученик 1С
Re: Регистры
« Ответ #1: 16 Янв 2011, 18:33 »
т.е. я вроде правильно сделал. ясно значит у меня база глючная

Оффлайн 6aToH

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-15
  • Сайт: 
  • Профессия: Ученик 1С
Re: Регистры
« Ответ #2: 17 Янв 2011, 18:30 »
короче вот такая задача:
Нужно отобразить Реализованный товар за период в разрезе контрагента.
и сгруппировать по регионам продаж(поле справочника контрагент)

Дайте ссылку если у кого есть, где разжеваны регистры и как с ними работать!
Желательно с примерами!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 331
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal