Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Июл 2017, 11:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите в чем ошибка  (Прочитано 582 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zatochi

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-13
  • Сайт: 
  • Профессия: Программист 1С
//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
   Перем Запрос, ТекстЗапроса, Таб;
   //Создание объекта типа Запрос
   Запрос = СоздатьОбъект("Запрос");
   ТекстЗапроса =
   "//{{ЗАПРОС(Сформировать)
   |Период с ВыбНачПериода по ВыбКонПериода;
   |Обрабатывать НеПомеченныеНаУдаление;
   |контрагенты = Справочник.контрагенты.ТекущийЭлемент;
   |Отгрузка = Документ.Отгрузка.ТекущийДокумент;
   |ПРИХОД_НАЛИЧНЫХ = Документ.ПРИХОД_НАЛИЧНЫХ.ТекущийДокумент;
   |Перечисление = Документ.Перечисление.ТекущийДокумент;
   |Группировка контрагенты упорядочить по контрагенты.Наименование, контрагенты.долг_на_начало_года, контрагенты.лимит;
   |Группировка Отгрузка упорядочить по Отгрузка.итого_отгрузка, Отгрузка.итого_понижение, Отгрузка.итого_повышение, Отгрузка.итого_возврат, Отгрузка.итого_внутреннее_перемешение;
   |Группировка ПРИХОД_НАЛИЧНЫХ упорядочить по ПРИХОД_НАЛИЧНЫХ.Итогосданонал, ПРИХОД_НАЛИЧНЫХ.итого_скидка, ПРИХОД_НАЛИЧНЫХ.итого_скидка_С_накладной;
   |Группировка Перечисление упорядочить по Перечисление.итого_перечис, Перечисление.итого_доп_пр;
   |"//}}ЗАПРОС
   ;
   // Если ошибка в запросе, то выход из процедуры
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
   КонецЕсли;

   // Подготовка к заполнению выходных форм данными запроса
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Сформировать");
   // Заполнение полей "Заголовок"
   Таб.ВывестиСекцию("Заголовок");
   Состояние("Заполнение выходной таблицы...");
   Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
   Пока Запрос.Группировка(1) = 1 Цикл
      // Заполнение полей контрагенты
      Таб.ВывестиСекцию("контрагенты");
      Пока Запрос.Группировка(2) = 1 Цикл
         // Заполнение полей Отгрузка
         Таб.ВывестиСекцию("Отгрузка");
         Пока Запрос.Группировка(3) = 1 Цикл
            // Заполнение полей ПРИХОД_НАЛИЧНЫХ
            Таб.ВывестиСекцию("ПРИХОД_НАЛИЧНЫХ");
            Пока Запрос.Группировка(4) = 1 Цикл
               // Заполнение полей Перечисление
               Таб.ВывестиСекцию("Перечисление");
            КонецЦикла;
         КонецЦикла;
      КонецЦикла;
   КонецЦикла;
   // Вывод заполненной формы
   Таб.ТолькоПросмотр(1);
   Таб.Показать("Сформировать", "");
КонецПроцедуры




Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
В отсутствии вопроса - ошибка, как минимум
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
 // Если ошибка в запросе, то выход из процедуры
:ooifh::D


Оффлайн zatochi

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-02-13
  • Сайт: 
  • Профессия: Программист 1С
//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
   Перем Запрос, ТекстЗапроса, Таб;
   //Создание объекта типа Запрос
   Запрос = СоздатьОбъект("Запрос");
   ТекстЗапроса =
   "//{{ЗАПРОС(Сформировать)
   |Период с ВыбНачПериода по ВыбКонПериода;
   |Обрабатывать НеПомеченныеНаУдаление;
   |контрагенты = Документ.Отгрузка.контрагенты;
   |отгрузка = Документ.Отгрузка.отгрузка;
   |Контрагенты1 = Документ.Перечисление.Контрагенты;
   |сдано_перечислением = Документ.Перечисление.сдано_перечислением;
   |Функция отгрузкаСумма = Сумма(отгрузка);
   |Функция сдано_перечислениемСумма = Сумма(сдано_перечислением);
   |Группировка контрагенты упорядочить по контрагенты.Наименование, сдано_перечислениемСумма, отгрузкаСумма;
   |"//}}ЗАПРОС
   ;
   // Если ошибка в запросе, то выход из процедуры
   Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
      Возврат;
   КонецЕсли;

   // Подготовка к заполнению выходных форм данными запроса
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Сформировать");
   // Заполнение полей "Заголовок"
   Таб.ВывестиСекцию("Заголовок");
   Состояние("Заполнение выходной таблицы...");
   Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
   Пока Запрос.Группировка(1) = 1 Цикл
      // Заполнение полей контрагенты
      Таб.ВывестиСекцию("контрагенты");
   КонецЦикла;
   // Заполнение полей "Итого"
   Таб.ВывестиСекцию("Итого");
   // Вывод заполненной формы
   Таб.ТолькоПросмотр(1);
   Таб.Показать("Сформировать", "");
КонецПроцедуры
контрагенты НаименованиеотгрузкаСуммасдано_перечислениемСумма
АЗИЯ АРТ ПАРКЕТ1843.00пусто
АЛЕКСЕЙ (Мастер Стиль)1080.00пусто



в таблице выводится кантрагенты и его отгрузка, но графа сдано наличними пустая
Добавлено: 16 Мар 2016, 10:13

В отсутствии вопроса - ошибка, как минимум

в таблице выводится кантрагенты и его отгрузка, но графа сдано наличними пустая

Последний раз редактировалось: zatochi; 16 Мар 2016, 10:13. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
94 Сообщений
oleg-x
71 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
BuhRust
22 Сообщений
lansy
22 Сообщений
Dethmontt Dethmontt
22 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal