Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 13:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выбор значения из составного типа данных.  (Прочитано 1021 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн EliGreen

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-10
  • Сайт: 
Доброе утро, добрый день, добрый вечер.

Есть справочник ДОГОВОР, у него есть составное поле ОБЪЕКТНЕДВИЖМОСТИ, который ссылается на 4 справочника: квартиры, дома, ..., ..., а также поле ЦЕНАСДЕЛКИ

У каждого из 4 последних справочников есть поле ЦЕНА.

Хочется, чтобы при указании поля ОБЪЕКТНЕДВИЖИМОСТИ в форме ДОГОВОРА, поле ЦЕНА в форме ДОГОВОРА выставлялась автоматически.

1 картинка - ОБЪЕКТНЕДВИЖИМОСТИ
2 картинка - пример одного из четырех справочников
3 картинка - форма договора
4 картинка - попытка решения

Пытался сделать это как показано на последнем рисунке - не получилось.
Гуглил - не нашлось.

Совет, пожалуйста. :befhbt:


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ...ПриИзменении(Элемент)
    Объект.Цена=ПолучитьЦенуОбъекта(Объект.ОбъектНедвижимости);
КонецПроцедуры;

&НаСервере
Функцияя ПолучитьЦенуОбъекта(ОбъектВыбора)
    Возврат ОбъектВыбора.Цена;
КонецФункции

Оффлайн EliGreen

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-10
  • Сайт: 
&НаКлиенте
Процедура ...ПриИзменении(Элемент)
    Объект.Цена=ПолучитьЦенуОбъекта(Объект.ОбъектНедвижимости);
КонецПроцедуры;

&НаСервере
Функцияя ПолучитьЦенуОбъекта(ОбъектВыбора)
    Возврат ОбъектВыбора.Цена;
КонецФункции

Большое спасибо Вам за ответ. Реализовал, но все равно вылезает ошибка. Фото реализации, а также информацию по ошибке прикрепил в приложении.
Добавлено: 12 Мар 2016, 21:10

&НаКлиенте
Процедура ...ПриИзменении(Элемент)
    Объект.Цена=ПолучитьЦенуОбъекта(Объект.ОбъектНедвижимости);
КонецПроцедуры;

&НаСервере
Функцияя ПолучитьЦенуОбъекта(ОбъектВыбора)
    Возврат ОбъектВыбора.Цена;
КонецФункции

Как только выбираю один из справочников, чтобы указать объект, вылезает ошибка.
Демонстрация - https://gyazo.com/415032b7fdc42525b69ad131a1d1709d

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
:) Вставте проверку на заполненность "ОбъектВыбора"

Оффлайн EliGreen

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-10
  • Сайт: 
:) Вставте проверку на заполненность "ОбъектВыбора"
Огромное спасибо, теперь, когда я выбираю справочник, то могу выбрать саму квартиру, и 1С не ругается до тех пор, пока квартира не выбрана.
НО как только квартира выбрана, таже ошибка вылетает (есть в вложении)
Все дело в том, что он просто не хочет видеть поле Цена. Может быть там есть еще какое-то поле между ценой и объектом, которое нужно прописать?
Визуализация взаимодействия - https://gyazo.com/cf379e44c1f8e9474592f7243de15317

Вложения:
1 - Ошибка
2 - Реализация
Добавлено: 14 Мар 2016, 15:52

:) Вставте проверку на заполненность "ОбъектВыбора"

Проблему решил, большое спасибо :ooifh:
Неправильно прописал поле :nhsrm:


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6881
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3632
Последний ответ 19 Май 2014, 15:40
от kot_oo
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 6409
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6352
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
Как перенести конфу базы данных на новую конфу?

Автор dim3740Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 10457
Последний ответ 23 Авг 2010, 15:41
от mohock

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
93 Сообщений
oleg-x
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
45 Сообщений
AIFrame
41 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 880
  • Точка Скрытых: 0
  • Точка Пользователей: 18
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal