Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Апр 2018, 04:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: HTML в 1С  (Прочитано 874 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ermak1985

  • **
  • Сообщений: 61
  • РЕПУТАЦИЯ: -6
  • Регистрация: 2016-02-01
  • Сайт: 
  • Профессия: Ученик 1С
HTML в 1С
« Первое сообщение: 10 Мар 2016, 08:39 »
Доброе утро! Решил по пробовать парсер. Не понятно почему не читает код

Функция ПолучитьБлокиПоКлассу(Документ, Класс)  
   
    МассивБлоков = Новый Массив;   
    СписокЭлементов = Документ.ПолучитьЭлементыПоИмени("div");
    Для Каждого Элемент Из СписокЭлементов Цикл
        АтрибутКласс = Элемент.ПолучитьАтрибут("class");
        Если АтрибутКласс<>Неопределено Тогда
            Если АтрибутКласс=Класс Тогда
                МассивБлоков.Добавить(Элемент);
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
   
    Возврат МассивБлоков;
   
КонецФункции
 
Функция Выгрузка()
   
    ДанныеТекущейСтраницы="http://www.cyberforum.ru/";
    Чтение = Новый ЧтениеHtml;
    Чтение.УстановитьСтроку(ДанныеТекущейСтраницы, "UTF8");
    Построитель = Новый ПостроительDOM;
    Документ = Построитель.Прочитать(Чтение);
   
    Блоки = ПолучитьБлокиПоКлассу(Документ, "navbar");
    Если Блоки.Количество()=0 Тогда
        Возврат Неопределено;
    Иначе
        Возврат Блоки[0];
    КонецЕсли;
   
КонецФункции   
 
Процедура КнопкаВыполнитьНажатие(Кнопка)
      Выгрузка();   
КонецПроцедуры


Теги:
 

HTML в 1С. Делаем "выпадающее" меню

Автор 1СNachaloРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 266
Последний ответ 17 Апр 2018, 17:52
от AIFrame
При переводе из ДокументHTML в ДокументDOM выдает ошибку. (Создание ДокументDOM из Html страницы).

Автор antant1992Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 248
Последний ответ 22 Янв 2018, 16:21
от alex0402
1C 8.3 управляемые формы вставка HTML файла в форматированный документ, не вставляются картинки

Автор Putilin007Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2318
Последний ответ 24 Мар 2016, 17:08
от Putilin007
Как убрать колонтитулы при печати макета HTML-документа из поля HTMLДокумента

Автор starz555Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4594
Последний ответ 19 Июл 2013, 18:53
от GRADUS
Получение HTML кода из ПолеHTMLДокумента в тонком клиенте на платформе 8.2

Автор s.rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3220
Последний ответ 05 Июл 2010, 20:27
от s.r

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
176 Сообщений
alex0402
65 Сообщений
AIFrame AIFrame
61 Сообщений
alexandr_ll
41 Сообщений
oleg-x
40 Сообщений
BuhRust
20 Сообщений
pavl_vs
20 Сообщений
Sheriff
13 Сообщений
Sandi Sandi
12 Сообщений
KOI8-R
12 Сообщений

* Кто онлайн

  • Точка Гостей: 159
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal