Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Ноя 2017, 01:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не производится расчет в документе  (Прочитано 1083 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ospov11789

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-09
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! У меня такая проблема. Необходимо рассчитать долю финансирования науки по научным исследованиям
Я создал такой модуль
&НаКлиенте
Процедура НаучноПедагогическиеРаботникиКоличествоЧасовОтводимыхНаНаучныеИсследованияПриИзменении(Элемент)
СтрокаТабличнойЧасти=Элементы.НаучноПедагогическиеРаботники.ТекущиеДанные;
ФинансированиеНауки.РассчитатьСумму(СтрокаТабличнойЧасти)

КонецПроцедуры

А также общий модуль следующего содержания
Процедура РассчитатьСумму(СтрокаТабличнойЧасти)Экспорт
СтрокаТабличнойЧасти.ДоляЗаработнойПлатыЗаНауку=СтрокаТабличнойЧасти.ЗаработнаяПлата/СтрокаТабличнойЧасти.СуммарнаяПродолжительностьРабочегоВремени*СтрокаТабличнойЧасти.КоличествоЧасовОтводимыхНаНаучныеИсследования;
КонецПроцедуры
Отладчик ничего не показывает, но и расчет не производится. Хотелось бы узнать в чем ошибка


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн IL2016

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 3
  • КПД: 17%
  • Регистрация: 2016-02-20
  • Сайт: 
  • Профессия: Ученик 1С
...
общий модуль следующего содержания
Процедура РассчитатьСумму(СтрокаТабличнойЧасти)Экспорт
СтрокаТабличнойЧасти.ДоляЗаработнойПлатыЗаНауку=СтрокаТабличнойЧасти.ЗаработнаяПлата/СтрокаТабличнойЧасти.СуммарнаяПродолжительностьРабочегоВремени*СтрокаТабличнойЧасти.КоличествоЧасовОтводимыхНаНаучныеИсследования;
КонецПроцедуры
Отладчик ничего не показывает, но и расчет не производится. Хотелось бы узнать в чем ошибка
конечно, в этом коде ничего и не должно произойти, чтобы повлияло на процедуру на Клиенте. В данном случае для логики работы программы системы 1С ошибки нет, но что тогда не так?
Ответ простой - общий модуль на Клиентскую процедуру результат расчета не отправляет.Процедура не умеет возвращать результат в другую процедуру. Полагаю что теперь ясно где недоработка.
Нужно просто что-то переименовать и добавить команду "Возврат  .... ;".
Также имеет смысл установить проверку на заполнение полей значениями в исходных справочниках и выводить сообщение пользователю о том , что поле такое не введено и надо заполнить.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
конечно, в этом коде ничего и не должно произойти, чтобы повлияло на процедуру на Клиенте. В данном случае для логики работы программы системы 1С ошибки нет, но что тогда не так?
Ответ простой - общий модуль на Клиентскую процедуру результат расчета не отправляет.Процедура не умеет возвращать результат в другую процедуру. Полагаю что теперь ясно где недоработка.
Нужно просто что-то переименовать и добавить команду "Возврат  .... ;".
Также имеет смысл установить проверку на заполнение полей значениями в исходных справочниках и выводить сообщение пользователю о том , что поле такое не введено и надо заполнить.
бред бредовый. вы не в состоянии прочитать простейший код.

Оффлайн LexaK

  • *****
  • Сообщений: 1265
  • РЕПУТАЦИЯ: 346
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
ospov11789, даже не знаю как вам посоветовать воспользоваться отладчиком,
поставьте на своем коде точку останова, в документе измените количество часов, по шагам проверьте что и как рассчитывается!
может вы отладчиком не умеете пользоваться? <_<
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн IL2016

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 3
  • КПД: 17%
  • Регистрация: 2016-02-20
  • Сайт: 
  • Профессия: Ученик 1С
Если актуально,
вот решение.
для простоты и удобства себе назвал элементы по-своему.
Логика работы - в форме при изменении пользователем значения "ФЗП", либо "Время", либо "НормаВр"
автоматически интерактивно пересчитывается значение "ДоляЗП", т.е. результат расчета виден сразу также как в Экселе. У всех элементов тип "Число".
Нужно конечно усовершенствовать и добавить проверку на ноль значения "Время".
В этом автор, полагаю,сам справится.

&НаКлиенте
 Процедура ПоказателиФЗППриИзменении(Элемент)
   Стр=Элементы.Показатели.ТекущиеДанные;
   РасчетДоляЗП.РасчетСтроки(Стр)
 КонецПроцедуры


&НаКлиенте
 Процедура ПоказателиВремяПриИзменении(Элемент)
   Стр=Элементы.Показатели.ТекущиеДанные;
   РасчетДоляЗП.РасчетСтроки(Стр)   
 КонецПроцедуры

&НаКлиенте
 Процедура ПоказателиНормаВрПриИзменении(Элемент)
   Стр=Элементы.Показатели.ТекущиеДанные;
   РасчетДоляЗП.РасчетСтроки(Стр)
 КонецПроцедуры


//Общий модуль РасчетДоляЗП
Процедура РасчетСтроки(ТекСтр) Экспорт
ТекСтр.ДоляЗП = ТекСтр.ФЗП / ТекСтр.Время * ТекСтр.НормаВр;
КонецПроцедуры

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
ТекСтр.ДоляЗП = ТекСтр.ФЗП / ТекСтр.Время * ТекСтр.НормаВр;

сдается мне,что тут ошибка в формуле.

Оффлайн IL2016

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 3
  • КПД: 17%
  • Регистрация: 2016-02-20
  • Сайт: 
  • Профессия: Ученик 1С
абы да кабы , проверьте на практике.
воссоздать необходимый документ Вам не составит труда.

Оффлайн ospov11789

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-09
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! У меня такая проблема. Необходимо рассчитать долю финансирования науки по научным исследованиям
Я создал такой модуль
&НаКлиенте
Процедура НаучноПедагогическиеРаботникиКоличествоЧасовОтводимыхНаНаучныеИсследованияПриИзменении(Элемент)
СтрокаТабличнойЧасти=Элементы.НаучноПедагогическиеРаботники.ТекущиеДанные;
ФинансированиеНауки.РассчитатьСумму(СтрокаТабличнойЧасти)

КонецПроцедуры



А также общий модуль следующего содержания
Процедура РассчитатьСумму(СтрокаТабличнойЧасти)Экспорт
СтрокаТабличнойЧасти.ДоляЗаработнойПлатыЗаНауку=СтрокаТабличнойЧасти.ЗаработнаяПлата/СтрокаТабличнойЧасти.СуммарнаяПродолжительностьРабочегоВремени*СтрокаТабличнойЧасти.КоличествоЧасовОтводимыхНаНаучныеИсследования;
КонецПроцедуры
Отладчик ничего не показывает, но и расчет не производится. Хотелось бы узнать в чем ошибка

Лучше всего сбойные модули отключать от системы убрав с них все флажки
Тогда система заработает нормально.
С уважением Осипов Михаил Юрьевич


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4247
Последний ответ 24 Дек 2015, 15:34
от дфтын
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3559
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 245
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3119
Последний ответ 21 Мар 2015, 20:24
от дфтын
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3731
Последний ответ 29 Июн 2012, 18:37
от LexaK

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
144 Сообщений
MuI_I_Ika MuI_I_Ika
99 Сообщений
oleg-x
69 Сообщений
alex0402
62 Сообщений
ilyay ilyay
53 Сообщений
Dmitry Qwe Dmitry Qwe
32 Сообщений
Sy4a
22 Сообщений
Dima Dddd Dima Dddd
21 Сообщений
BuhRust
19 Сообщений
Kironten
12 Сообщений

* Кто онлайн

  • Точка Гостей: 288
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal