Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 03:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: нумерация доков с прибамбасами  (Прочитано 1502 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн soleg78

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-06-16
  • Сайт: 
УТП 8.1.
Докектор хочет следующее:
Например док. РеализацияТоваровУслуг
в нем есть 3 реквизита :
- ОтражатьВУправленческомУчете;
- ОтражатьВБухгалтерскомУчете;
- ОтражатьВНалоговомУчете;

Руководство хочет видет такой результат:
например, когда вслючены(истина) все 3 реквизита - нумерация документа идет нормально,
когда стоит только реквизит ОтражатьВУправленческомУчете - нумерация идет другая и с префиксом "У", если включен только реквизит ОтражатьВБухгалтерскомУчете - нумерация еще друга и с префиксом "Б", .... в налоговом по аналогии с префиксом "Н"

И так надо во всех доках где естьети реквизиты. (приказы начальства не обсуждаются. просто НАДО и ВСЁ!)

кто что думает? ... с чего начать?... и где могут быть "грабли"?


Оффлайн retnan

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-14
  • Сайт: 
  • Профессия: Программист 8.1
Попробуйте такой вариант. Для каждого документа перед записью вызывайте общую серверную процедуру, например, РаботаСДокументами.СформироватьНомер(ЭтотОбъект).
В общем модуле пропишите следующее:
Процедура СформироватьНомер(Объект) Экспорт
   Если ТипЗнч(Объект.Номер)<>Тип("Строка") Тогда Возврат
   КонецЕсли;   
   ПрефиксИБ = ПолучитьПрефикс(Объект,Объект.У,Объект.Б,Объект.Н);
   УстановитьНомер = Ложь;
   Если Объект.ЭтоНовый() Тогда УстановитьНомер = Истина
   Иначе
      СтарыйОбъект = Объект.Ссылка.ПолучитьОбъект();   
      СтарыйОбъект.Прочитать();
      СтарыйПрефикс=ПолучитьПрефикс(Объект,СтарыйОбъект.У,СтарыйОбъект.Б,СтарыйОбъект.Н);
      Если ПрефиксИБ<>СтарыйПрефикс Тогда
         УстановитьНомер = Истина   
      КонецЕсли   
   КонецЕсли;   
   Если УстановитьНомер Тогда Объект.УстановитьНовыйНомер(ПрефиксИБ);         
   КонецЕсли;
КонецПроцедуры

Функция ПолучитьПрефикс(Объект,У,Б,Н)
   Если У И НЕ Б И НЕ Н Тогда Возврат Строка(Перечисления.ТипыНумерации.У)
   ИначеЕсли НЕ У И Б И НЕ Н Тогда Возврат Строка(Перечисления.ТипыНумерации.Б)
   ИначеЕсли НЕ У И НЕ Б И Н Тогда Возврат Строка(Перечисления.ТипыНумерации.Н)
   Иначе Возврат КакойТоПрефиксПоУмолчаниюНапример0
   КонецЕсли;   
КонецФункции


Теги:
 

Автоматическая нумерация в журнале счет-фактура выданный

Автор Olga777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 18518
Последний ответ 08 Июл 2011, 11:19
от Шурыгин Иван Сергеевич
Сбитая нумерация счет-фактур, неправильная амортизация ОС

Автор majenteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3109
Последний ответ 20 Июл 2014, 19:28
от majente
повторная нумерация документов при загрузке из внешней системы

Автор SerpovichРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 545
Последний ответ 01 Авг 2016, 13:54
от cska-fanat-kz
нумерация и создание новой строки справочника

Автор KrysPiperРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1639
Последний ответ 10 Дек 2010, 19:15
от progmikon
нужна дополнительная нумерация доментов в УТ11

Автор ahmatoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 7051
Последний ответ 04 Дек 2011, 03:29
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 125
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal