Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 02:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: нумерация доков с прибамбасами  (Прочитано 1598 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн soleg78

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-06-16
  • Сайт: 
УТП 8.1.
Докектор хочет следующее:
Например док. РеализацияТоваровУслуг
в нем есть 3 реквизита :
- ОтражатьВУправленческомУчете;
- ОтражатьВБухгалтерскомУчете;
- ОтражатьВНалоговомУчете;

Руководство хочет видет такой результат:
например, когда вслючены(истина) все 3 реквизита - нумерация документа идет нормально,
когда стоит только реквизит ОтражатьВУправленческомУчете - нумерация идет другая и с префиксом "У", если включен только реквизит ОтражатьВБухгалтерскомУчете - нумерация еще друга и с префиксом "Б", .... в налоговом по аналогии с префиксом "Н"

И так надо во всех доках где естьети реквизиты. (приказы начальства не обсуждаются. просто НАДО и ВСЁ!)

кто что думает? ... с чего начать?... и где могут быть "грабли"?


Оффлайн retnan

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-01-14
  • Сайт: 
  • Профессия: Программист 8.1
Попробуйте такой вариант. Для каждого документа перед записью вызывайте общую серверную процедуру, например, РаботаСДокументами.СформироватьНомер(ЭтотОбъект).
В общем модуле пропишите следующее:
Процедура СформироватьНомер(Объект) Экспорт
   Если ТипЗнч(Объект.Номер)<>Тип("Строка") Тогда Возврат
   КонецЕсли;   
   ПрефиксИБ = ПолучитьПрефикс(Объект,Объект.У,Объект.Б,Объект.Н);
   УстановитьНомер = Ложь;
   Если Объект.ЭтоНовый() Тогда УстановитьНомер = Истина
   Иначе
      СтарыйОбъект = Объект.Ссылка.ПолучитьОбъект();   
      СтарыйОбъект.Прочитать();
      СтарыйПрефикс=ПолучитьПрефикс(Объект,СтарыйОбъект.У,СтарыйОбъект.Б,СтарыйОбъект.Н);
      Если ПрефиксИБ<>СтарыйПрефикс Тогда
         УстановитьНомер = Истина   
      КонецЕсли   
   КонецЕсли;   
   Если УстановитьНомер Тогда Объект.УстановитьНовыйНомер(ПрефиксИБ);         
   КонецЕсли;
КонецПроцедуры

Функция ПолучитьПрефикс(Объект,У,Б,Н)
   Если У И НЕ Б И НЕ Н Тогда Возврат Строка(Перечисления.ТипыНумерации.У)
   ИначеЕсли НЕ У И Б И НЕ Н Тогда Возврат Строка(Перечисления.ТипыНумерации.Б)
   ИначеЕсли НЕ У И НЕ Б И Н Тогда Возврат Строка(Перечисления.ТипыНумерации.Н)
   Иначе Возврат КакойТоПрефиксПоУмолчаниюНапример0
   КонецЕсли;   
КонецФункции


Теги:
 

Нумерация при создании "на основании"

Автор Hard03Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 94
Последний ответ 15 Май 2018, 15:03
от buketov.av
Автоматическая нумерация в журнале счет-фактура выданный

Автор Olga777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 20005
Последний ответ 08 Июл 2011, 11:19
от Шурыгин Иван Сергеевич
Сбитая нумерация счет-фактур, неправильная амортизация ОС

Автор majenteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3480
Последний ответ 20 Июл 2014, 19:28
от majente
повторная нумерация документов при загрузке из внешней системы

Автор SerpovichРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 673
Последний ответ 01 Авг 2016, 13:54
от cska-fanat-kz
нумерация и создание новой строки справочника

Автор KrysPiperРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1841
Последний ответ 10 Дек 2010, 19:15
от progmikon

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
ilyay ilyay
29 Сообщений
Анюта17
29 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 207
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal