Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Сен 2017, 16:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Веб клиент и excel  (Прочитано 985 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 357
  • РЕПУТАЦИЯ: 67
  • КПД: 19%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
Перерыла все, перепробовала многое - не получается :kmtu:. Надеюсь на вашу помощь!

Есть в облаке 1Сина, и есть внешний отчет. После формирования отчета, пользователь нажимает на кнопочку на форме и отчет сохраняется на локальный компьютер пользователя в формате .xlsx.

Код для записи там такой
Результат.Записать(ФайлДанныхВыгрузки, ТипФайлаТабличногоДокумента.XLSX);

А мне нужно в этот файл еще дописать данные, но не выходит. Ругается на

	
ExcelПриложение = Новый COMОбъект("Excel.Application");
ExcelПриложение.Visible = 0;
Книга = ExcelПриложение.WorkBooks.Open(ФайлДанныхВыгрузки);

Ошибка на вебе такая

https://yadi.sk/i/gujc8mDFpuR6w

Я понимаю, что веб-сервер не видит файлы на моем локальном компе, но как тогда? Типовая же сохранялка работает!

Буду признательна за любую помощь!
Народная мудрость: Программу встречают по интерфейсу


Оффлайн LexaK

  • *****
  • Сообщений: 1254
  • РЕПУТАЦИЯ: 345
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Re: Веб клиент и excel
« Ответ #1: 04 Мар 2016, 14:20 »
э-э-э, зачем так сложно?
вы формируете отчет и выводите в Ексель!
и еще хотите что-то добавить!
ЗАЧЕМ открывать Ексель?

ПЕРЕД сохранением отчета в Ексель, ДОБАВЬТЕ ТО ЧТО НАДО В ОТЧЕТ
(это табличный документ, очень легко с ним сделать все что надо в самой 1С) и ЗАТЕМ сохраняйте!!!

:befhbt:

и в этом случае ни какой Ексель вам не надо запоускать и ломать голову как с его помощью исправить/дополнить отчет!
вот блин любители все через Ж... Ексель делать! :D
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн SitnovaMarina

  • Помогла? Скажи "Спасибо"!
  • ****
  • Сообщений: 357
  • РЕПУТАЦИЯ: 67
  • КПД: 19%
  • E-mail: Marishka0604@yandex.ru
  • Регистрация: 2014-09-12
    • Skype: Marishka0604991
  • Сайт: vk.com
  • Профессия: Программист 1С
Re: Веб клиент и excel
« Ответ #2: 04 Мар 2016, 15:59 »
э-э-э, зачем так сложно?
вы формируете отчет и выводите в Ексель!
и еще хотите что-то добавить!
ЗАЧЕМ открывать Ексель?

ПЕРЕД сохранением отчета в Ексель, ДОБАВЬТЕ ТО ЧТО НАДО В ОТЧЕТ
(это табличный документ, очень легко с ним сделать все что надо в самой 1С) и ЗАТЕМ сохраняйте!!!

:befhbt:

и в этом случае ни какой Ексель вам не надо запоускать и ломать голову как с его помощью исправить/дополнить отчет!
вот блин любители все через Ж... Ексель делать! :D

Спасибо, конечно. Но задача в том и состоит, чтобы в этот драный Ексель формулы вставить и красиво так что бы все выводилось! Про типовое сохранение я вкурсе :D

В любом случае спасибо! Извратилась, но сделала!:zebzdr:
Добавлено: 04 Мар 2016, 16:00

ВОПРОС ЗАКРЫТ
&НаКлиенте
Процедура СохранитьВФайл(Команда)
ВХ = "";
ФайлДанныхВыгрузки = "";
ОООЗ = Новый ОписаниеОповещения("ЗаполняемФайл",ЭтотОбъект);
НачатьПомещениеФайла(ОООЗ,ВХ,ФайлДанныхВыгрузки,,УникальныйИдентификатор);
КонецПроцедуры

&НаКлиенте
Процедура ЗаполняемФайл(ФайлВыбран, ВХ, ФайлДанныхВыгрузки, ДопПараметры) Экспорт
Если ФайлВыбран Тогда
Результат.Записать(ФайлДанныхВыгрузки, ТипФайлаТабличногоДокумента.XLSX);
ИмяНаСервере= "";
ВХССервера = ДобавитьТаблицы(ВХ,ФайлДанныхВыгрузки, ИмяНаСервере);
ПолучитьФайл(ВХССервера,ФайлДанныхВыгрузки);
КонецЕсли;
КонецПроцедуры

&НаСервере
Функция ДобавитьТаблицы(ВХ,ИмяНаКлиенте, ИмяНаСервере)
ИмяНаСервере = КаталогВременныхФайлов() + Новый УникальныйИдентификатор + ".xlsx";
ФайлМой = ПолучитьИзВременногоХранилища(ВХ);
ФайлМой.Записать(ИмяНаСервере);
ExcelПриложение = Новый COMОбъект("Excel.Application");

ExcelПриложение.Visible = 0;
Книга = ExcelПриложение.WorkBooks.Open(ИмяНаСервере);
Лист = Книга.WorkSheets(1);
Лист.UnProtect();

.......................
        .......................
        .......................

ExcelПриложение.DisplayAlerts = 0;
Книга.SaveAs(ИмяНаСервере);
ExcelПриложение.Quit();
ExcelПриложение.DisplayAlerts = 1;
ExcelПриложение = "";

ДвоичДанные = Новый ДвоичныеДанные(ИмяНаСервере);
Адрес = ПоместитьВоВременноеХранилище(ДвоичДанные, УникальныйИдентификатор);
Возврат Адрес;
КонецФункции

Народная мудрость: Программу встречают по интерфейсу


Теги:
 

Круглый стол "Автоматизация учета и отчетности по МСФО: Excel против программных продуктов"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1621
Последний ответ 10 Сен 2014, 10:25
от mixqn
работа с файлами excel открытие файла xls, чтение данных и запись нового файла xls

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2372
Последний ответ 11 Фев 2016, 12:49
от Rasty
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 6582
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
настройка профили доступа "Клиент"

Автор chipРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2234
Последний ответ 15 Ноя 2012, 16:05
от chip
Загрузка в 1С Управление Торговлей 11.1.5.16 электронных выписок из клиент банка "Альфа-Банк"

Автор regnusРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 11029
Последний ответ 11 Июл 2014, 17:22
от regnus

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
176 Сообщений
alex0402
81 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
81 Сообщений
AsadRoman
35 Сообщений
Kironten
34 Сообщений
ilyay ilyay
30 Сообщений
Golickoff Golickoff
29 Сообщений
AIFrame
27 Сообщений
BuhRust
26 Сообщений
Варвар
20 Сообщений

* Кто онлайн

  • Точка Гостей: 856
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal