Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Мар 2017, 21:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод формы на экран 1С 8.3  (Прочитано 1404 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
Всем привет!

Есть форма документа в которой для ТЧ задается набор полей в том числе поле ДИЕТА, которое ссылается на справочник по ДИЕТАМ... кроме того есть кнопка, по которой хотелось бы автоматически разнести одну диету для всех записей в ТЧ документа...
Почему при выборе поля в ТЧ выводится нормальная форма выбора для этого справочника, а при нажатии на кнопку "не то".....нет возможности выбрать....
 вот скрины...

https://drive.google.com/file/d/0BwF_oocLEKVLNjdIeGV3WTNSTDA/view?usp=sharing

https://drive.google.com/file/d/0BwF_oocLEKVLN1ZzZEJHdEptMk0/view?usp=sharing

вот код который должен открывать форму выбора для этого справочника  по кнопке

&НаКлиенте
Процедура ОбщаяДиета(Команда)
   Форма = ПолучитьФорму("Справочник.Питание_Рационы.ФормаВыбора");
   РезДиета = Форма.ОткрытьМодально();
      
   Для каждого ТекущаяСтрока Из Объект.Питающиеся Цикл
           ТекущаяСтрока.ДиетаПитающихся = РезДиета;
   КонецЦикла;
КонецПроцедуры


Подскажите, пожалуйста, что не так? 


 


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Покажите скрин из конфигуратора как на примере

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Теперь скрин формы выбора в конфигураторе


Оффлайн Rasty

  • *****
  • Сообщений: 963
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
 ПолучитьФорму("Справочник.Питание_Рационы.Форма.ФормаВыбора")
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
...пробовала....не работает....:dfbsdfbsdf:

&НаКлиенте
Процедура ОбщаяДиета(Команда)
   Форма = ПолучитьФорму("Справочник.Питание_Рационы.Форма.ФормаВыбора");
   РезДиета = Форма.ОткрытьМодально();
      
   Для каждого ТекущаяСтрока Из Объект.Питающиеся Цикл
           ТекущаяСтрока.ДиетаПитающихся = РезДиета;
   КонецЦикла;
КонецПроцедуры

:fdbsdfbsd:

...вот так выводится...
https://drive.google.com/file/d/0BwF_oocLEKVLN1ZzZEJHdEptMk0/view?usp=sharing

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
   Форма = ПолучитьФорму("Справочник.Питание_Рационы.ФормаВыбора");

Тяжело искать черную кошку в темной комнате,... особенно если ее там нет.
Справочники разные, в коде и на скрине.

И используйте метод ОткрытьФорму вместо получитьФорму

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
Прошу прощения, я болбес.... зарапортовалась....

https://drive.google.com/file/d/0BwF_oocLEKVLaTZ0ajV6M3M4ajA/view?usp=sharing


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Результат=ОткрытьФормуМодально("Справочник.Питание_Рационы.Форма.ФормаВыбора",,ЭтаФорма);


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
151 Сообщений
alex0402
109 Сообщений
MuI_I_Ika MuI_I_Ika
53 Сообщений
Norfolk
51 Сообщений
LexaK
48 Сообщений
AsadRoman
27 Сообщений
SlimShady
22 Сообщений
друган
21 Сообщений
alexandr_ll
19 Сообщений
Константин5825
17 Сообщений

* Кто онлайн

  • Точка Гостей: 428
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal