Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Ноя 2017, 03:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод формы на экран 1С 8.3  (Прочитано 1889 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
Всем привет!

Есть форма документа в которой для ТЧ задается набор полей в том числе поле ДИЕТА, которое ссылается на справочник по ДИЕТАМ... кроме того есть кнопка, по которой хотелось бы автоматически разнести одну диету для всех записей в ТЧ документа...
Почему при выборе поля в ТЧ выводится нормальная форма выбора для этого справочника, а при нажатии на кнопку "не то".....нет возможности выбрать....
 вот скрины...

https://drive.google.com/file/d/0BwF_oocLEKVLNjdIeGV3WTNSTDA/view?usp=sharing

https://drive.google.com/file/d/0BwF_oocLEKVLN1ZzZEJHdEptMk0/view?usp=sharing

вот код который должен открывать форму выбора для этого справочника  по кнопке

&НаКлиенте
Процедура ОбщаяДиета(Команда)
   Форма = ПолучитьФорму("Справочник.Питание_Рационы.ФормаВыбора");
   РезДиета = Форма.ОткрытьМодально();
      
   Для каждого ТекущаяСтрока Из Объект.Питающиеся Цикл
           ТекущаяСтрока.ДиетаПитающихся = РезДиета;
   КонецЦикла;
КонецПроцедуры


Подскажите, пожалуйста, что не так? 


 


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Покажите скрин из конфигуратора как на примере

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Теперь скрин формы выбора в конфигураторе


Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
 ПолучитьФорму("Справочник.Питание_Рационы.Форма.ФормаВыбора")
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
...пробовала....не работает....:dfbsdfbsdf:

&НаКлиенте
Процедура ОбщаяДиета(Команда)
   Форма = ПолучитьФорму("Справочник.Питание_Рационы.Форма.ФормаВыбора");
   РезДиета = Форма.ОткрытьМодально();
      
   Для каждого ТекущаяСтрока Из Объект.Питающиеся Цикл
           ТекущаяСтрока.ДиетаПитающихся = РезДиета;
   КонецЦикла;
КонецПроцедуры

:fdbsdfbsd:

...вот так выводится...
https://drive.google.com/file/d/0BwF_oocLEKVLN1ZzZEJHdEptMk0/view?usp=sharing

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
   Форма = ПолучитьФорму("Справочник.Питание_Рационы.ФормаВыбора");

Тяжело искать черную кошку в темной комнате,... особенно если ее там нет.
Справочники разные, в коде и на скрине.

И используйте метод ОткрытьФорму вместо получитьФорму

Оффлайн Анна Баханович

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-10-05
  • Сайт: 
Прошу прощения, я болбес.... зарапортовалась....

https://drive.google.com/file/d/0BwF_oocLEKVLaTZ0ajV6M3M4ajA/view?usp=sharing


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Результат=ОткрытьФормуМодально("Справочник.Питание_Рационы.Форма.ФормаВыбора",,ЭтаФорма);


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 252
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4761
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3374
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4922
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 555
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
MuI_I_Ika MuI_I_Ika
96 Сообщений
oleg-x
67 Сообщений
alex0402
66 Сообщений
ilyay ilyay
58 Сообщений
Dmitry Qwe Dmitry Qwe
32 Сообщений
Sy4a
22 Сообщений
Dima Dddd Dima Dddd
20 Сообщений
BuhRust
19 Сообщений
Golickoff Golickoff
16 Сообщений

* Кто онлайн

  • Точка Гостей: 146
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal