Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Окт 2017, 02:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подчиненный справочник 1с 8.2  (Прочитано 1413 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alrain

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-30
  • Сайт: 
  • Профессия: Ученик 1С
Приветствую знатоков, есть задачка, нужно в печатную форму вывести поле контактное лицо контрагента, как это сделать пока не пойму...
https://yadi.sk/i/6wQaSG59pmmN3
Есть такой код, но он не то показывает...

Выборка = Справочники.КонтактныеЛица.Выбрать();
Пока Выборка.Следующий() Цикл
КонецЦикла;

ОбластьМакета.Параметры.КонтактныеЛицаКонтрагента = Выборка.Наименование;


Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
ОбластьМакета.Параметры.КонтактныеЛицаКонтрагента = Выборка.Наименование;
В цмкл вставьте
Пока Выборка.Следующий() Цикл
ОбластьМакета.Параметры.КонтактныеЛицаКонтрагента = Выборка.Наименование;
КонецЦикла;
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн alrain

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-30
  • Сайт: 
  • Профессия: Ученик 1С
Вставил - пустое значение показывает...

 Выборка = Справочники.КонтактныеЛица.Выбрать();

   ОбластьМакета = Макет.ПолучитьОбласть("Текст");
   ОбластьМакета.Параметры.Организация = СсылкаНаОбъект.Организация;   
   ОбластьМакета.Параметры.Контрагент = СсылкаНаОбъект.Контрагент;
   ТабДокумент.Вывести(ОбластьМакета);

   Пока Выборка.Следующий() Цикл
   ОбластьМакета.Параметры.КонтактныеЛицаКонтрагента = Выборка.Наименование;
КонецЦикла;

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
гы
   ТабДокумент.Вывести(ОбластьМакета);
тоже в цикл запихните

и идите уже книжки читайте
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн alrain

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-30
  • Сайт: 
  • Профессия: Ученик 1С
Благодарю за подсказки, но теперь выдаёт мне весь список контрагентов, а надо по одному конкретному...
Книжки читать буду)

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
Добавьте условие :)
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн alrain

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-12-30
  • Сайт: 
  • Профессия: Ученик 1С
Появилась вторая задача, необходимо в печатной форме отобразить фактический адрес контрагента, который показан на рисунке.
https://yadi.sk/i/AgUeknmmq3Tss
Кучу статей в инете перерыл, много кода испробовал, но не один не отображает сам фактический адрес...

На данный момент такой код:

ОбластьМакета = Макет.ПолучитьОбласть("Поставка");
   ОбластьМакета.Параметры.Заполнить(ПараметрыПечати);
   ОбластьМакета.Параметры.Контрагент = СсылкаНаОбъект.Контрагент.НаименованиеПолное;
   ОбластьМакета.Параметры.ФактАдрес = УправлениеКонтактнойИнформацией.ПолучитьАдресИзКонтактнойИнформации(Контрагент, "Фактический");
   ТабДокумент.Вывести(ОбластьМакета);

нажимаю кнопку Печать с выбором нужной формы, пишет такую ошибку:
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (ФактАдрес)

Специалисты, подскажите\помогите новичку с кодом... Заранее благодарю...
Добавлено: 11 Мар 2016, 10:16

Сам отвечу на свой вопрос, вот решение:
ОбластьМакета.Параметры.ФактАдрес = УправлениеКонтактнойИнформацией.ПолучитьАдресИзКонтактнойИнформации(СсылкаНаОбъект.Контрагент, "Фактический");

Последний раз редактировалось: alrain; 11 Мар 2016, 10:16. Причина: Объединение сообщений

Оффлайн дфтын

  • Могу решить ЛЮБУЮ задачу в 1С и не только.. С вопросами в личку:)
  • *****
  • Сообщений: 2720
  • РЕПУТАЦИЯ: 325
  • КПД: 12%
  • 1С наше все
  • Регистрация: 2014-04-29
    • Skype: Soprov1C
  • Компания: Корпорация зонтиков
  • Профессия: Разработчик 1С
печеньки давайте уже
Помог? Нажми - Спасибо :)
skype: Soprov1C

Оффлайн IL2016

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 3
  • КПД: 17%
  • Регистрация: 2016-02-20
  • Сайт: 
  • Профессия: Ученик 1С
конструктором печати не хочется пользоваться?
только кодироваться!:befhbt:


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
89 Сообщений
alex0402
53 Сообщений
AIFrame
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
37 Сообщений
Oldman06
31 Сообщений
Golickoff Golickoff
30 Сообщений
vitasw
29 Сообщений
MuI_I_Ika MuI_I_Ika
19 Сообщений
DmitriyF DmitriyF
14 Сообщений
Св Ч Св Ч
12 Сообщений

* Кто онлайн

  • Точка Гостей: 157
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal