Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Янв 2017, 15:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переменная не определена (ФормированиеПечатныхФорм) в 8.3  (Прочитано 842 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Labaman

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Доброго дня!
Для ленивых бухов потребовалось модифицировать ТТНку, чтобы вот прямо все выбиралось из справочников.  В 8.2 у меня было уже реализовано отдельным документом, который тянул недостающие поля из дополнительных справочников (водители, места погрузки/разгрузки итд). Начал переносить свои наработки в 8.3 и столкнулся с проблемой заполнения на основании - в 8.2 у меня заполнялось так: 
Процедура ОбработкаЗаполнения(Основание)
Если ТипЗнч(Основание) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
// Заполнение шапки
Контрагент = Основание.Контрагент;
ДокОснование = Основание.Ссылка;
Грузополучатель = Основание.Грузополучатель;
Организация = Основание.Организация;
Если ЗначениеЗаполнено(Грузополучатель)=Ложь Тогда
Грузополучатель = Контрагент;
СведенияОГрузополучателе  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Грузополучатель, Дата);
        ПунктРазгрузки = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе,  "ФактическийАдрес");
//НомТорг12 = Основание.Номер;
КонецЕсли;
ТабличнаяЧасть1.Очистить();
Для Каждого ТекСтрокаТовары Из Основание.Товары Цикл
НоваяСтрока = ТабличнаяЧасть1.Добавить();
НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
НоваяСтрока.Товар = ТекСтрокаТовары.Номенклатура;
НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
КонецЦикла;
КонецЕсли;
КонецПроцедуры

В 8.3 выдает ошибку:
{Документ.ТТН.МодульОбъекта(11,26)}: Переменная не определена (ФормированиеПечатныхФорм)
        ПунктРазгрузки = <<?>>ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе,  "ФактическийАдрес"); (Проверка: Сервер
Подскажите как адаптировать процидуру под 8.3?

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн Kironten

  • *****
  • Сообщений: 712
  • РЕПУТАЦИЯ: 153
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
ПунктРазгрузки = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузополучателе,  "ФактическийАдрес");
Это если у вас конечно БП 3.0 Вы же не потрудились указать конфигурацию

Оффлайн Labaman

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо, помогло. Да, именно Бух 3.0.


Теги:
 

Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 1714
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Ошибка Процедура или функция с указанным именем не определена

Автор ser36Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1274
Последний ответ 26 Май 2015, 09:45
от cska-fanat-kz
Для каждого запроса, области макета новая переменная?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 450
Последний ответ 29 Июн 2016, 10:15
от Luzer1C
Процедура или функция с указанным именем не определена

Автор asd_123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4848
Последний ответ 24 Янв 2012, 16:07
от asd_123
Глобальная экспортная переменная как указать тип данных

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4110
Последний ответ 20 Авг 2013, 23:48
от mixqn

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
79 Сообщений
alexandr_ll
37 Сообщений
LexaK
29 Сообщений
crow1983
27 Сообщений
MuI_I_Ika MuI_I_Ika
26 Сообщений
sertak sertak
22 Сообщений
дфтын дфтын
17 Сообщений
Vzonder
14 Сообщений
BuhRust
13 Сообщений

* Кто онлайн

  • Точка Гостей: 876
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal