Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2017, 16:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переменная не определена (ФормированиеПечатныхФорм) в 8.3  (Прочитано 1320 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн Labaman

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Доброго дня!
Для ленивых бухов потребовалось модифицировать ТТНку, чтобы вот прямо все выбиралось из справочников.  В 8.2 у меня было уже реализовано отдельным документом, который тянул недостающие поля из дополнительных справочников (водители, места погрузки/разгрузки итд). Начал переносить свои наработки в 8.3 и столкнулся с проблемой заполнения на основании - в 8.2 у меня заполнялось так: 
Процедура ОбработкаЗаполнения(Основание)
Если ТипЗнч(Основание) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
// Заполнение шапки
Контрагент = Основание.Контрагент;
ДокОснование = Основание.Ссылка;
Грузополучатель = Основание.Грузополучатель;
Организация = Основание.Организация;
Если ЗначениеЗаполнено(Грузополучатель)=Ложь Тогда
Грузополучатель = Контрагент;
СведенияОГрузополучателе  = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Грузополучатель, Дата);
        ПунктРазгрузки = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе,  "ФактическийАдрес");
//НомТорг12 = Основание.Номер;
КонецЕсли;
ТабличнаяЧасть1.Очистить();
Для Каждого ТекСтрокаТовары Из Основание.Товары Цикл
НоваяСтрока = ТабличнаяЧасть1.Добавить();
НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
НоваяСтрока.Товар = ТекСтрокаТовары.Номенклатура;
НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
НоваяСтрока.Цена = ТекСтрокаТовары.Цена;
КонецЦикла;
КонецЕсли;
КонецПроцедуры

В 8.3 выдает ошибку:
{Документ.ТТН.МодульОбъекта(11,26)}: Переменная не определена (ФормированиеПечатныхФорм)
        ПунктРазгрузки = <<?>>ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОГрузополучателе,  "ФактическийАдрес"); (Проверка: Сервер
Подскажите как адаптировать процидуру под 8.3?


Онлайн Kironten

  • *****
  • Сообщений: 793
  • РЕПУТАЦИЯ: 169
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
ПунктРазгрузки = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(СведенияОГрузополучателе,  "ФактическийАдрес");
Это если у вас конечно БП 3.0 Вы же не потрудились указать конфигурацию

Оффлайн Labaman

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-19
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо, помогло. Да, именно Бух 3.0.


Теги:
 

Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 4082
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Ошибка Процедура или функция с указанным именем не определена

Автор ser36Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1702
Последний ответ 26 Май 2015, 09:45
от cska-fanat-kz
Процедура или функция с указанным именем не определена (Записать)

Автор oo ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 597
Последний ответ 02 Фев 2017, 13:04
от oo oo
Процедура или функция с указанным именем не определена

Автор asd_123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5103
Последний ответ 24 Янв 2012, 16:07
от asd_123
Для каждого запроса, области макета новая переменная?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 554
Последний ответ 29 Июн 2016, 10:15
от Luzer1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
91 Сообщений
Dethmontt Dethmontt
66 Сообщений
MuI_I_Ika MuI_I_Ika
63 Сообщений
wise wise
63 Сообщений
alex0402
58 Сообщений
ilyay ilyay
42 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
magnifico61
25 Сообщений
ilnur75
22 Сообщений
Дмитрий Медведков
18 Сообщений

* Кто онлайн

  • Точка Гостей: 283
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal